gnu: Add kafs-client
[jackhill/guix/guix.git] / gnu / packages / patches / busybox-CVE-2021-28831.patch
1 From f25d254dfd4243698c31a4f3153d4ac72aa9e9bd Mon Sep 17 00:00:00 2001
2 From: Samuel Sapalski <samuel.sapalski@nokia.com>
3 Date: Wed, 3 Mar 2021 16:31:22 +0100
4 Subject: decompress_gunzip: Fix DoS if gzip is corrupt
5
6 On certain corrupt gzip files, huft_build will set the error bit on
7 the result pointer. If afterwards abort_unzip is called huft_free
8 might run into a segmentation fault or an invalid pointer to
9 free(p).
10
11 In order to mitigate this, we check in huft_free if the error bit
12 is set and clear it before the linked list is freed.
13
14 Signed-off-by: Samuel Sapalski <samuel.sapalski@nokia.com>
15 Signed-off-by: Peter Kaestle <peter.kaestle@nokia.com>
16 Signed-off-by: Denys Vlasenko <vda.linux@googlemail.com>
17 ---
18 archival/libarchive/decompress_gunzip.c | 12 ++++++++++--
19 1 file changed, 10 insertions(+), 2 deletions(-)
20
21 diff --git a/archival/libarchive/decompress_gunzip.c b/archival/libarchive/decompress_gunzip.c
22 index eb3b64930..e93cd5005 100644
23 --- a/archival/libarchive/decompress_gunzip.c
24 +++ b/archival/libarchive/decompress_gunzip.c
25 @@ -220,10 +220,20 @@ static const uint8_t border[] ALIGN1 = {
26 * each table.
27 * t: table to free
28 */
29 +#define BAD_HUFT(p) ((uintptr_t)(p) & 1)
30 +#define ERR_RET ((huft_t*)(uintptr_t)1)
31 static void huft_free(huft_t *p)
32 {
33 huft_t *q;
34
35 + /*
36 + * If 'p' has the error bit set we have to clear it, otherwise we might run
37 + * into a segmentation fault or an invalid pointer to free(p)
38 + */
39 + if (BAD_HUFT(p)) {
40 + p = (huft_t*)((uintptr_t)(p) ^ (uintptr_t)(ERR_RET));
41 + }
42 +
43 /* Go through linked list, freeing from the malloced (t[-1]) address. */
44 while (p) {
45 q = (--p)->v.t;
46 @@ -289,8 +299,6 @@ static unsigned fill_bitbuffer(STATE_PARAM unsigned bitbuffer, unsigned *current
47 * or a valid pointer to a Huffman table, ORed with 0x1 if incompete table
48 * is given: "fixed inflate" decoder feeds us such data.
49 */
50 -#define BAD_HUFT(p) ((uintptr_t)(p) & 1)
51 -#define ERR_RET ((huft_t*)(uintptr_t)1)
52 static huft_t* huft_build(const unsigned *b, const unsigned n,
53 const unsigned s, const struct cp_ext *cp_ext,
54 unsigned *m)
55 --
56 cgit v1.2.1
57