gnu: Add kafs-client
[jackhill/guix/guix.git] / gnu / packages / patches / bsdiff-CVE-2014-9862.patch
1 diff --git a/bspatch.c b/bspatch.c
2 index 8d95633..ab77722 100644
3 --- a/bspatch.c
4 +++ b/bspatch.c
5
6 @@ -187,6 +187,10 @@
7 };
8
9 /* Sanity-check */
10 + if ((ctrl[0] < 0) || (ctrl[1] < 0))
11 + errx(1,"Corrupt patch\n");
12 +
13 + /* Sanity-check */
14 if(newpos+ctrl[0]>newsize)
15 errx(1,"Corrupt patch\n");