gnu: Add kafs-client
[jackhill/guix/guix.git] / gnu / packages / patches / blender-2.79-gcc8.patch
1 diff --git a/intern/itasc/kdl/tree.hpp b/intern/itasc/kdl/tree.hpp
2 index c8a253fc901..bd35f82d185 100644
3 --- a/intern/itasc/kdl/tree.hpp
4 +++ b/intern/itasc/kdl/tree.hpp
5 @@ -34,7 +34,7 @@ namespace KDL
6 //Forward declaration
7 class TreeElement;
8 // Eigen allocator is needed for alignment of Eigen data types
9 - typedef std::map<std::string,TreeElement, std::less<std::string>, Eigen::aligned_allocator<std::pair<std::string, TreeElement> > > SegmentMap;
10 + typedef std::map<std::string,TreeElement, std::less<std::string>, Eigen::aligned_allocator<std::pair<const std::string, TreeElement> > > SegmentMap;
11
12 class TreeElement
13 {
14 diff --git a/intern/cycles/util/util_sseb.h b/intern/cycles/util/util_sseb.h
15 index 6e669701f3b..977976c3fc0 100644
16 --- a/intern/cycles/util/util_sseb.h
17 +++ b/intern/cycles/util/util_sseb.h
18 @@ -22,6 +22,9 @@ CCL_NAMESPACE_BEGIN
19
20 #ifdef __KERNEL_SSE2__
21
22 +struct ssei;
23 +struct ssef;
24 +
25 /*! 4-wide SSE bool type. */
26 struct sseb
27 {
28 @@ -116,7 +119,7 @@ __forceinline const sseb unpacklo( const sseb& a, const sseb& b ) { return _mm_u
29 __forceinline const sseb unpackhi( const sseb& a, const sseb& b ) { return _mm_unpackhi_ps(a, b); }
30
31 template<size_t i0, size_t i1, size_t i2, size_t i3> __forceinline const sseb shuffle( const sseb& a ) {
32 - return _mm_shuffle_epi32(a, _MM_SHUFFLE(i3, i2, i1, i0));
33 + return _mm_castsi128_ps(_mm_shuffle_epi32(a, _MM_SHUFFLE(i3, i2, i1, i0)));
34 }
35
36 template<> __forceinline const sseb shuffle<0, 1, 0, 1>( const sseb& a ) {