gnu: Add kafs-client
[jackhill/guix/guix.git] / gnu / packages / patches / audacity-add-include.patch
1 Without <sys/time.h>, gettimeofday is undefined.
2
3 diff --git a/src/AudioIO.cpp b/src/AudioIO.cpp
4 index 0187e3962..e15d55f4c 100644
5 --- a/src/AudioIO.cpp
6 +++ b/src/AudioIO.cpp
7 @@ -479,6 +479,8 @@ time warp info and AudioIOListener and whether the playback is looped.
8 #include "../lib-src/portmidi/porttime/porttime.h"
9 #include "../lib-src/header-substitutes/allegro.h"
10
11 +#include <sys/time.h>
12 +
13 #define MIDI_SLEEP 10 /* milliseconds */
14 // how long do we think the thread that fills MIDI buffers,
15 // if it is separate from the portaudio thread,