gnu: Add kafs-client
[jackhill/guix/guix.git] / gnu / packages / patches / adb-add-libraries.patch
1 --- a/adb/Android.mk 2018-04-25 23:23:29.527198350 +0200
2 +++ b/adb/Android.mk 2018-04-25 23:24:25.558632573 +0200
3 @@ -226,7 +226,7 @@
4 LOCAL_SRC_FILES := test_track_devices.cpp
5 LOCAL_SANITIZE := $(adb_host_sanitize)
6 LOCAL_SHARED_LIBRARIES := libbase
7 -LOCAL_STATIC_LIBRARIES := libadb libcrypto_static libcutils
8 +LOCAL_STATIC_LIBRARIES := libadb libbase libcrypto_static libcutils
9 LOCAL_LDLIBS += -lrt -ldl -lpthread
10 include $(BUILD_HOST_EXECUTABLE)
11 endif
12 @@ -278,6 +278,7 @@
13 LOCAL_SANITIZE := $(adb_host_sanitize)
14 LOCAL_STATIC_LIBRARIES := \
15 libadb \
16 + libcutils \
17 libbase \
18 libcrypto_static \
19 libdiagnose_usb \
20 --- a/adb/sysdeps_test.cpp 2018-05-09 23:58:46.583163684 +0200
21 +++ b/adb/sysdeps_test.cpp 2018-05-09 23:56:41.356544648 +0200
22 @@ -17,6 +17,8 @@
23 #include <gtest/gtest.h>
24 #include <unistd.h>
25 #include <atomic>
26 +#include <climits>
27 +#include <mutex>
28
29 #include "adb_io.h"
30 #include "sysdeps.h"