gnu: Add kafs-client
[jackhill/guix/guix.git] / gnu / packages / patches / ableton-link-system-libraries-debian.patch
1 This patch was borrowed from Debian's package:
2 https://salsa.debian.org/multimedia-team/ableton-link/-/blob/9c65141bf5bba0872811c179af77ac95770352cc/debian/patches/DEBIAN_system_libraries.patch
3 Description: Drop dependencies on included 3rd-party libs
4 upstream includes git-submodules for Catch and ASIO (not found in the tarball).
5 on Debian we want to use the system provided libraries.
6 Author: IOhannes m zmölnig
7 Origin: Debian
8 Forwarded: not-needed
9 Last-Update: 2016-10-26
10 ---
11 This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
12 --- ableton-link.orig/cmake_include/AsioStandaloneConfig.cmake
13 +++ ableton-link/cmake_include/AsioStandaloneConfig.cmake
14 @@ -1,6 +1,2 @@
15 add_library(AsioStandalone::AsioStandalone IMPORTED INTERFACE)
16
17 -set_property(TARGET AsioStandalone::AsioStandalone APPEND PROPERTY
18 - INTERFACE_INCLUDE_DIRECTORIES
19 - ${CMAKE_CURRENT_LIST_DIR}/../modules/asio-standalone/asio/include
20 -)
21 --- ableton-link.orig/cmake_include/CatchConfig.cmake
22 +++ ableton-link/cmake_include/CatchConfig.cmake
23 @@ -1,6 +1,2 @@
24 add_library(Catch::Catch IMPORTED INTERFACE)
25
26 -set_property(TARGET Catch::Catch APPEND PROPERTY
27 - INTERFACE_INCLUDE_DIRECTORIES
28 - ${CMAKE_SOURCE_DIR}/third_party/catch
29 -)