gnu: fplll: Update to version 4.0.2.
[jackhill/guix/guix.git] / gnu / packages / screen.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages screen)
20 #:use-module (guix licenses)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu)
24 #:use-module (gnu packages)
25 #:use-module (gnu packages ncurses)
26 #:use-module (gnu packages perl))
27
28 (define-public screen
29 (package
30 (name "screen")
31 (version "4.0.3")
32 (source (origin
33 (method url-fetch)
34 (uri (string-append "http://ftp.gnu.org/gnu/screen/screen-"
35 version ".tar.gz"))
36 (sha256
37 (base32 "0xvckv1ia5pjxk7fs4za6gz2njwmfd54sc464n8ab13096qxbw3q"))))
38 (build-system gnu-build-system)
39 (inputs
40 `(("ncurses", ncurses)
41 ("perl" ,perl)))
42 (home-page "http://www.gnu.org/software/screen/")
43 (synopsis "GNU Screen, a terminal multiplexer")
44 (description
45 "GNU screen is a full-screen window manager that multiplexes a physical
46 terminal between several processes, typically interactive shells. Each virtual
47 terminal provides the functions of the DEC VT100 terminal and, in addition,
48 several control functions from the ANSI X3.64 (ISO 6429) and ISO 2022 standards
49 (e.g., insert/delete line and support for multiple character sets). There is a
50 scrollback history buffer for each virtual terminal and a copy-and-paste
51 mechanism that allows the user to move text regions between windows. When
52 screen is called, it creates a single window with a shell in it (or the
53 specified command) and then gets out of your way so that you can use the
54 program as you normally would. Then, at any time, you can create new
55 (full-screen) windows with other programs in them (including more shells), kill
56 the current window, view a list of the active windows, turn output logging on
57 and off, copy text between windows, view the scrollback history, switch between
58 windows, etc. All windows run their programs completely independent of each
59 other. Programs continue to run when their window is currently not visible and
60 even when the whole screen session is detached from the users terminal.")
61 (license gpl2+)))