gnu: autogen: Update to 5.18.14.
[jackhill/guix/guix.git] / gnu / packages / autogen.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2014 Eric Bavier <bavier@member.fsf.org>
3 ;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
4 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages autogen)
22 #:use-module (guix packages)
23 #:use-module (guix licenses)
24 #:use-module (guix download)
25 #:use-module (guix build-system gnu)
26 #:use-module (gnu packages)
27 #:use-module (gnu packages perl)
28 #:use-module (gnu packages pkg-config)
29 #:use-module (gnu packages base)
30 #:use-module (gnu packages guile))
31
32 (define-public autogen
33 (package
34 (name "autogen")
35 (version "5.18.14")
36 (source
37 (origin
38 (method url-fetch)
39 (uri (string-append "mirror://gnu/autogen/rel" version
40 "/autogen-" version ".tar.xz"))
41 (sha256
42 (base32
43 "1r06gam7sicb9ssn02mhv6r0g5vr4k0l0c67shpqa5i172cspizz"))))
44 (build-system gnu-build-system)
45 (native-inputs `(("pkg-config" ,pkg-config)
46 ("which" ,which)))
47 (inputs `(("guile" ,guile-2.0)
48 ("perl" ,perl))) ; for doc generator mdoc
49 (arguments
50 '(#:phases
51 (modify-phases %standard-phases
52 (add-before 'patch-source-shebangs 'patch-test-scripts
53 (lambda _
54 (let ((sh (which "sh")))
55 (substitute*
56 (append (find-files "agen5/test" "\\.test$")
57 (find-files "autoopts/test" "\\.(test|in)$"))
58 (("/bin/sh") sh))
59 #t))))))
60 (home-page "https://www.gnu.org/software/autogen/")
61 (synopsis "Automated program generator")
62 (description
63 "AutoGen is a program to ease the maintenance of programs that contain
64 large amounts of repetitive text. It automates the construction of these
65 sections of the code, simplifying the task of keeping the text in sync. It
66 also includes an add-on package called AutoOpts, which is specialized for the
67 maintenance and documentation of program options.")
68 (license gpl3+)))