Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / libbsd.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages libbsd)
20 #:use-module (guix build-system gnu)
21 #:use-module (guix download)
22 #:use-module (guix licenses)
23 #:use-module (guix packages))
24
25 (define-public libbsd
26 (package
27 (name "libbsd")
28 (version "0.8.7")
29 (source (origin
30 (method url-fetch)
31 (uri (string-append "https://libbsd.freedesktop.org/releases/"
32 "libbsd-" version ".tar.xz"))
33 (sha256
34 (base32
35 "0c9bl49zs0xdddcwj5dh0lay9sxi2m1yi74848g8p87mb87g2j7m"))))
36 (build-system gnu-build-system)
37 (synopsis "Utility functions from BSD systems")
38 (description "This library provides useful functions commonly found on BSD
39 systems, and lacking on others like GNU systems, thus making it easier to port
40 projects with strong BSD origins, without needing to embed the same code over
41 and over again on each project.")
42 (home-page "https://libbsd.freedesktop.org/wiki/")
43 ;; This package is a collection of third-party functions that were
44 ;; originally released under various non-copyleft licenses.
45 (license (list bsd-2 bsd-3 bsd-4 expat isc public-domain
46 (non-copyleft "file://COPYING"
47 "See COPYING in the distribution.")))))