gnu: icecat: Use system harfbuzz and graphite2 libraries.
[jackhill/guix/guix.git] / gnu / packages / gps.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014, 2015 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
4 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
5 ;;; Copyright © 2018 Mathieu Othacehe <m.othacehe@gmail.com>
6 ;;;
7 ;;; This file is part of GNU Guix.
8 ;;;
9 ;;; GNU Guix is free software; you can redistribute it and/or modify it
10 ;;; under the terms of the GNU General Public License as published by
11 ;;; the Free Software Foundation; either version 3 of the License, or (at
12 ;;; your option) any later version.
13 ;;;
14 ;;; GNU Guix is distributed in the hope that it will be useful, but
15 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
16 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
17 ;;; GNU General Public License for more details.
18 ;;;
19 ;;; You should have received a copy of the GNU General Public License
20 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
21
22 (define-module (gnu packages gps)
23 #:use-module (guix packages)
24 #:use-module (guix download)
25 #:use-module (guix git-download)
26 #:use-module (guix build-system gnu)
27 #:use-module ((guix licenses) #:prefix license:)
28 #:use-module (gnu packages)
29 #:use-module (gnu packages base)
30 #:use-module (gnu packages pkg-config)
31 #:use-module (gnu packages compression)
32 #:use-module (gnu packages databases)
33 #:use-module (gnu packages docbook)
34 #:use-module (gnu packages image)
35 #:use-module (gnu packages xml)
36 #:use-module (gnu packages gtk)
37 #:use-module (gnu packages qt))
38
39 (define-public gpsbabel
40 (package
41 (name "gpsbabel")
42 (version "1.5.4")
43 (source (origin
44 (method url-fetch)
45 ;; XXX: Downloads from gpsbabel.org are hidden behind a POST, so
46 ;; get it from elsewhere.
47 (uri (string-append
48 "mirror://debian/pool/main/g/gpsbabel/gpsbabel_"
49 version ".orig.tar.gz"))
50 (sha256
51 (base32
52 "19hykxhyl567gf8qcrl33qhv95w0g4vxw9r3h9b8d8plx9bnaf8l"))
53 (patches (search-patches
54 "gpsbabel-minizip.patch"
55 ;; XXX: Remove this patch on the next release.
56 "gpsbabel-qstring.patch"))
57 (modules '((guix build utils)))
58 (snippet
59 '(begin
60 ;; Delete files under GPL-compatible licences but never used
61 ;; on GNU systems, rather than bloating the LICENSE field.
62 (delete-file "gui/serial_mac.cc") ; Apple MIT
63 (delete-file "mingw/include/ddk/hidsdi.h") ; public domain
64 #t))))
65 (build-system gnu-build-system)
66 ;; TODO: "make doc" requires Docbook & co.
67 (arguments
68 `(#:configure-flags
69 '("--with-zlib=system"
70 ;; XXX Use -fPIC to work around build problems with Qt, GCC 5, and
71 ;; recent binutils:
72 ;; https://codereview.qt-project.org/#/c/111787/
73 "CXXFLAGS=-std=gnu++11 -fPIC")
74 ;; On i686, 'raymarine.test' fails because of a rounding error:
75 ;; <http://hydra.gnu.org/build/133040>. As a workaround, disable tests
76 ;; on these platforms.
77 ;; FIXME: On x86_64 with -std=gnu++11 tests also fail due to rounding
78 ;; error.
79 #:tests? #f))
80 (inputs
81 `(("expat" ,expat)
82 ("zlib" ,zlib)
83 ("qtbase" ,qtbase)
84 ("qttools" ,qttools)))
85 (native-inputs
86 `(("which" ,which)
87 ("libxml2" ,libxml2))) ;'xmllint' needed for the KML tests
88 (home-page "https://www.gpsbabel.org/")
89 (synopsis "Convert and exchange data with GPS and map programs")
90 (description
91 "GPSBabel converts waypoints, tracks, and routes between hundreds of
92 popular GPS receivers and mapping programs. It contains extensive data
93 manipulation abilities making it a convenient for server-side processing or as
94 the back-end for other tools. It does not convert, transfer, send, or
95 manipulate maps.")
96 (license (list license:expat ; shapelib/*.[ch]
97 license:gpl2+)))) ; everything else
98
99 (define-public gpscorrelate
100 ;; This program is "lightly maintained", so to speak, so we end up taking it
101 ;; directly from its Git repo.
102 (let ((commit "365f6e1b3f"))
103 (package
104 (name "gpscorrelate")
105 (version (string-append "1.6.1." commit))
106 (source (origin
107 (method git-fetch)
108 (uri (git-reference
109 (url "https://github.com/freefoote/gpscorrelate")
110 (commit commit)))
111 (sha256
112 (base32
113 "006a6l8p38a4h7y2959sqrmjjn29d8pd50zj9nypcp5ph18nybjb"))))
114 (build-system gnu-build-system)
115 (arguments
116 `(#:phases
117 (modify-phases %standard-phases
118 (replace 'configure
119 (lambda* (#:key inputs outputs #:allow-other-keys)
120 ;; This is a rudimentary build system.
121 (substitute* "Makefile"
122 (("prefix[[:blank:]]*=.*$")
123 (string-append "prefix = " (assoc-ref outputs "out")
124 "\n")))
125 #t)))
126 #:tests? #f))
127 (inputs
128 `(("gtk+" ,gtk+-2)
129 ("libxml2" ,libxml2)
130 ("exiv2" ,exiv2)))
131 (native-inputs
132 `(("pkg-config" ,pkg-config)
133 ("docbook-xml" ,docbook-xml)
134 ("docbook-xsl" ,docbook-xsl)
135 ("libxslt" ,libxslt)))
136 (home-page "http://freefoote.dview.net/linux/gpscorrelate")
137 (synopsis "GPS photo correlation tool to geo-localize images")
138 (description
139 "GPS Correlate is a program to match a recorded GPS track with the EXIF
140 tags in digital camera photos, and update the EXIF tags with the location that
141 the photo was taken. It does this by using the timestamp in the photo and
142 finding a data point in the GPS track that matches, or interpolating a point
143 between two other data points.")
144 (license license:gpl2+))))
145
146 (define-public gama
147 (package
148 (name "gama")
149 (version "1.21")
150 (source
151 (origin
152 (method url-fetch)
153 (uri (string-append "mirror://gnu/gama/gama-"
154 version ".tar.gz"))
155 (sha256
156 (base32
157 "0yy8czw5dldbw1qj5v2h2wfh397bfx5wd3lrrgs8m1qdf1njnhcq"))))
158 (build-system gnu-build-system)
159 (arguments '(#:parallel-tests? #f)) ; race condition
160 (native-inputs
161 `(("libxml2" ,libxml2)))
162 (inputs
163 `(("expat" ,expat)
164 ("sqlite" ,sqlite)))
165 (home-page "https://www.gnu.org/software/gama")
166 (synopsis "Adjustment of geodetic networks")
167 (description
168 "GNU Gama is a program for the adjustment of geodetic networks. It is
169 useful in measurements where Global Positioning System (GPS) is not available,
170 such as underground. It features the ability to adjust in local Cartesian
171 coordinates as well as partial support for adjustments in global coordinate systems.")
172 (license license:gpl3+)))
173
174 (define-public gpxsee
175 (package
176 (name "gpxsee")
177 (version "4.19")
178 (source (origin
179 (method url-fetch)
180 (uri
181 (string-append "https://github.com/tumic0/GPXSee/archive/"
182 version ".tar.gz"))
183 (file-name (string-append name "-" version ".tar.gz"))
184 (sha256
185 (base32
186 "00j0gjldw1kn3i45dppld1pz8r4s1g7lw89k7gfvvqbjjyjih1wg"))))
187 (build-system gnu-build-system)
188 (arguments
189 '(#:phases
190 (modify-phases %standard-phases
191 (replace 'configure
192 ;; Use lrelease to convert TS translation files into QM files.
193 (lambda* (#:key inputs outputs #:allow-other-keys)
194 (for-each (lambda (file)
195 (system* "lrelease" file))
196 (find-files "lang" "\\.ts"))
197 (substitute* "src/config.h"
198 (("/usr/share/gpxsee")
199 (string-append
200 (assoc-ref outputs "out") "/share/gpxsee")))
201 (invoke "qmake"
202 (string-append "PREFIX="
203 (assoc-ref outputs "out")))))
204 (replace 'install
205 (lambda* (#:key outputs #:allow-other-keys)
206 (let* ((out (assoc-ref outputs "out"))
207 (share (string-append out "/share/gpxsee/")))
208 (install-file "GPXSee" (string-append out "/bin/GPXSee"))
209 (install-file "pkg/maps.txt" share))
210 #t)))))
211 (inputs
212 `(("qtbase" ,qtbase)))
213 (native-inputs
214 `(("qttools" ,qttools)))
215 (home-page "http://www.gpxsee.org")
216 (synopsis "GPX file viewer and analyzer")
217 (description
218 "GPXSee is a Qt-based GPS log file viewer and analyzer that supports GPX,
219 TCX, KML, FIT, IGC and NMEA files.")
220 (license license:gpl3)))