gnu: Add librevenge.
[jackhill/guix/guix.git] / gnu / packages / libreoffice.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
3 ;;; Copyright © 2014 John Darrington <jmd@gnu.org>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages libreoffice)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module ((guix licenses) #:select (lgpl2.1+ mpl2.0))
24 #:use-module (guix build-system gnu)
25 #:use-module (gnu packages boost)
26 #:use-module (gnu packages check)
27 #:use-module (gnu packages compression)
28 #:use-module (gnu packages doxygen)
29 #:use-module (gnu packages pkg-config)
30 #:use-module (gnu packages python))
31
32 (define-public ixion
33 (package
34 (name "ixion")
35 (version "0.9.1")
36 (source
37 (origin
38 (method url-fetch)
39 (uri (string-append "http://kohei.us/files/ixion/src/libixion-"
40 version ".tar.xz"))
41 (sha256 (base32
42 "18g3nk29ljiqbyi0ml49j2x3f3xrqckdm9i66sw5fxnj7hb5rqvp"))))
43 (build-system gnu-build-system)
44 (native-inputs
45 `(("pkg-config" ,pkg-config)))
46 (inputs
47 `(("mdds" ,mdds)
48 ("python" ,python-2))) ; looks for python.pc, not python3.pc
49 (home-page "https://gitlab.com/ixion/ixion")
50 (synopsis "General purpose formula parser and interpreter")
51 (description "Ixion is a library for calculating the results of formula
52 expressions stored in multiple named targets, or \"cells\". The cells can
53 be referenced from each other, and the library takes care of resolving
54 their dependencies automatically upon calculation.")
55 (license mpl2.0)))
56
57 (define-public orcus
58 (package
59 (name "orcus")
60 (version "0.7.1")
61 (source
62 (origin
63 (method url-fetch)
64 (uri (string-append "http://kohei.us/files/" name "/src/lib"
65 name "-" version ".tar.xz"))
66 (sha256 (base32
67 "0hva4qalg3dk6n1118ncr5fy8cqnj2f7fwldw7aa04124rj6p104"))))
68 (build-system gnu-build-system)
69 (native-inputs
70 `(("pkg-config" ,pkg-config)))
71 (inputs
72 `(("ixion" ,ixion)
73 ("mdds" ,mdds)
74 ("zlib" ,zlib)))
75 (home-page "https://gitlab.com/orcus/orcus")
76 (synopsis "File import filter library for spreadsheet documents")
77 (description "Orcus is a library that provides a collection of standalone
78 file processing filters. It is currently focused on providing filters for
79 spreadsheet documents. The library includes import filters for
80 Microsoft Excel 2007 XML, Microsoft Excel 2003 XML, Open Document Spreadsheet,
81 Plain Text, Gnumeric XML, Generic XML. It also includes low-level parsers for
82 CSV, CSS and XML.")
83 (license mpl2.0)))
84
85 (define-public librevenge
86 (package
87 (name "librevenge")
88 (version "0.0.2")
89 (source
90 (origin
91 (method url-fetch)
92 (uri (string-append "mirror://sourceforge/libwpd/" name "/" name "-"
93 version ".tar.xz"))
94 (sha256 (base32
95 "03ygxyb0vfjv8raif5q62sl33b54wkr5rzgadb8slijm6k281wpn"))))
96 (build-system gnu-build-system)
97 (native-inputs
98 `(("boost" ,boost)
99 ("cppunit" ,cppunit)
100 ("doxygen" ,doxygen)
101 ("pkg-config" ,pkg-config)))
102 (inputs
103 `(("zlib" ,zlib)))
104 (arguments
105 ;; avoid triggering configure errors by simple inclusion of boost headers
106 `(#:configure-flags '("--disable-werror")))
107 (home-page "http://sourceforge.net/p/libwpd/wiki/librevenge/")
108 (synopsis "Document importer for office suites")
109 (description "Librevenge is a base library for writing document import
110 filters. It has interfaces for text documents, vector graphics,
111 spreadsheets and presentations.")
112 (license '(mpl2.0 lgpl2.1+)))) ; dually licensed