gnu: python2-ipykernel: Split from python-ipykernel.
[jackhill/guix/guix.git] / gnu / packages / printers.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2018 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
4 ;;; Copyright © 2019 Ricardo Wurmus <rekado@elephly.net>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages printers)
22 #:use-module (guix packages)
23 #:use-module (guix git-download)
24 #:use-module (guix build-system cmake)
25 #:use-module (guix build-system gnu)
26 #:use-module ((guix licenses) #:prefix license:)
27 #:use-module (gnu packages compression)
28 #:use-module (gnu packages cups)
29 #:use-module (gnu packages libusb)
30 #:use-module (gnu packages ghostscript)
31 #:use-module (gnu packages pkg-config)
32 #:use-module (gnu packages qt))
33
34 ;; This is a module for packages related to printer-like devices, but not
35 ;; related to CUPS.
36
37 (define-public robocut
38 (package
39 (name "robocut")
40 (version "1.0.11")
41 (source
42 (origin
43 (method git-fetch)
44 (uri (git-reference
45 (url "https://github.com/Timmmm/robocut.git")
46 (commit (string-append "v" version))))
47 (file-name (git-file-name name version))
48 (sha256
49 (base32 "0dp9cssyik63yvkk35s51v94a873x751iqg93qzd8dpqkmz5z8gn"))))
50 (build-system gnu-build-system)
51 (arguments
52 '(#:phases (modify-phases %standard-phases
53 (replace 'configure
54 (lambda* (#:key outputs #:allow-other-keys)
55 (let ((out (assoc-ref outputs "out")))
56 (substitute* "Robocut.pro"
57 (("/usr/")
58 (string-append out "/")))
59
60 (invoke "qmake"
61 (string-append "PREFIX=" out))
62 #t))))))
63 (inputs
64 `(("libusb" ,libusb)
65 ("qt" ,qtbase)
66 ("qtsvg" ,qtsvg)))
67 (native-inputs
68 `(("pkg-config" ,pkg-config)
69 ("qmake" ,qtbase)))
70 (synopsis "Graphical program to drive plotting cutters")
71 (description
72 "Robocut is a simple graphical program that allows you to cut graphics
73 with Graphtec and Sihouette plotting cutters using an SVG file as its input.")
74 (home-page "http://robocut.org")
75 (license license:gpl3+)))
76
77 (define-public brlaser
78 (let ((commit "779f71e80fcc583f4537c844de141cf8e6a738fe")
79 (revision "1"))
80 (package
81 (name "brlaser")
82 (version (git-version "4" revision commit))
83 (source (origin
84 (method git-fetch)
85 (uri (git-reference
86 (url "https://github.com/pdewacht/brlaser.git")
87 (commit commit)))
88 (file-name (git-file-name name version))
89 (sha256
90 (base32
91 "0yrz9706660hdfi2y0ndp254r0vw9y665hwmxbbzfnz4ai13vj50"))))
92 (build-system cmake-build-system)
93 (arguments
94 `(#:configure-flags
95 (list (string-append "-DCUPS_DATA_DIR="
96 (assoc-ref %outputs "out")
97 "/share/cups")
98 (string-append "-DCUPS_SERVER_BIN="
99 (assoc-ref %outputs "out")
100 "/lib/cups"))))
101 (inputs
102 `(("ghostscript" ,ghostscript)
103 ("cups" ,cups)
104 ("zlib" ,zlib)))
105 (home-page "https://github.com/pdewacht/brlaser")
106 (synopsis "Brother laser printer driver")
107 (description "Brlaser is a CUPS driver for Brother laser printers. This
108 driver is known to work with these printers:
109
110 @enumerate
111 @item Brother DCP-1510
112 @item Brother DCP-7030
113 @item Brother DCP-7040
114 @item Brother DCP-7055
115 @item Brother DCP-7055W
116 @item Brother DCP-7065DN
117 @item Brother DCP-7080
118 @item Brother HL-1200 series
119 @item Brother HL-L2320D series
120 @item Brother HL-L2360D series
121 @item Brother MFC-7240
122 @item Brother MFC-7360N
123 @end enumerate
124
125 It partially works with printers from the Brother HL-L2300D series.")
126 (license license:gpl2+))))