gnu: python2-ipykernel: Split from python-ipykernel.
[jackhill/guix/guix.git] / gnu / packages / enchant.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 Marek Benc <merkur32@gmail.com>
3 ;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages enchant)
21 #:use-module (gnu packages)
22 #:use-module (gnu packages aspell)
23 #:use-module (gnu packages check)
24 #:use-module (gnu packages glib)
25 #:use-module (gnu packages pkg-config)
26 #:use-module (guix packages)
27 #:use-module (guix download)
28 #:use-module (guix build-system gnu)
29 #:use-module (guix licenses)
30 #:use-module (srfi srfi-1))
31
32 (define-public enchant
33 (package
34 (name "enchant")
35 (version "2.2.3")
36 (source (origin
37 (method url-fetch)
38 (uri (string-append "https://github.com/AbiWord/enchant/releases"
39 "/download/v" version "/enchant-"
40 version ".tar.gz"))
41 (sha256
42 (base32
43 "0v87p1ls0gym95qirijpclk650sjbkcjjl6ssk059zswcwaykn5b"))))
44 (build-system gnu-build-system)
45 (arguments
46 '(#:configure-flags '("--disable-static"
47 ;; Tests require a relocatable build.
48 "--enable-relocatable")))
49 (inputs
50 `(("aspell" ,aspell))) ;; Currently, the only supported backend in Guix
51 (propagated-inputs ;; is aspell. (This information might be old)
52 ;; Required by enchant.pc.
53 `(("glib" ,glib)))
54 (native-inputs
55 `(("glib:bin" ,glib "bin")
56 ("pkg-config" ,pkg-config)
57 ("unittest-cpp" ,unittest-cpp)))
58 (synopsis "Multi-backend spell-checking library wrapper")
59 (description
60 "On the surface, Enchant appears to be a generic spell checking library.
61 Looking closer, you'll see the Enchant is more-or-less a fancy wrapper around
62 the dlopen() system call.
63
64 Enchant steps in to provide uniformity and conformity on top of these libraries,
65 and implement certain features that may be lacking in any individual provider
66 library. Everything should \"just work\" for any and every definition of \"just
67 working\".")
68 (home-page "https://abiword.github.io/enchant/")
69 (license lgpl2.1+)))
70
71 ;; Some packages are not ready for the 2.x API yet, so we keep this version
72 ;; around. The library and executables of Enchant 2 have been designed not to
73 ;; conflict with 1.x, so it's OK if both end up in the same profile.
74 (define-public enchant-1.6
75 (package
76 (inherit enchant)
77 (version "1.6.0")
78 (arguments '(#:configure-flags '("--disable-static")))
79 (native-inputs (alist-delete "unittest-cpp"
80 (package-native-inputs enchant)))
81 (source (origin
82 (method url-fetch)
83 (uri (string-append "http://www.abisource.com/downloads/enchant/"
84 version "/enchant-" version ".tar.gz"))
85 (sha256
86 (base32
87 "0zq9yw1xzk8k9s6x83n1f9srzcwdavzazn3haln4nhp9wxxrxb1g"))))))