gnu: libmtp: Update to 1.1.11.
[jackhill/guix/guix.git] / gnu / packages / patches / findutils-test-xargs.patch
1 This test relies on 'xargs' being available in $PATH, which is not
2 the case when we build the initial Findutils doing bootstrapping.
3 Reported at <https://savannah.gnu.org/bugs/index.php?46786>.
4
5 --- findutils-4.6.0/find/testsuite/sv-34976-execdir-fd-leak.sh 2015-12-31 19:37:59.401526288 +0100
6 +++ findutils-4.6.0/find/testsuite/sv-34976-execdir-fd-leak.sh 2015-12-31 19:38:36.061770693 +0100
7 @@ -50,13 +50,14 @@ die() {
8 # Create test files, each 98 in the directories ".", "one" and "two".
9 make_test_data() {
10 d="$1"
11 + xargs="`cd ../../xargs; pwd -P`/xargs"
12 (
13 cd "$1" || exit 1
14 mkdir one two || exit 1
15 for i in ${three_to_hundred} ; do
16 printf "./%03d one/%03d two/%03d " $i $i $i
17 done \
18 - | xargs touch || exit 1
19 + | "$xargs" touch || exit 1
20 ) \
21 || die "failed to set up the test in ${outdir}"
22 }