gnu: calibre: Build with non-modular Qt.
[jackhill/guix/guix.git] / gnu / packages / acl.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
3 ;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
4 ;;; Copyright © 2014 Andreas Enge <andreas@enge.fr>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages acl)
22 #:use-module (guix licenses)
23 #:use-module (gnu packages attr)
24 #:use-module (gnu packages base)
25 #:use-module (gnu packages gettext)
26 #:use-module (gnu packages perl)
27 #:use-module (guix packages)
28 #:use-module (guix download)
29 #:use-module (gnu packages)
30 #:use-module (guix build-system gnu))
31
32 (define-public acl
33 (package
34 (name "acl")
35 (version "2.2.52")
36 (source
37 (origin
38 (method url-fetch)
39 (uri (string-append "mirror://savannah/acl/acl-"
40 version ".src.tar.gz"))
41 (sha256
42 (base32
43 "08qd9s3wfhv0ajswsylnfwr5h0d7j9d4rgip855nrh400nxp940p"))
44 (patches (search-patches "acl-hurd-path-max.patch"))))
45 (build-system gnu-build-system)
46 (arguments
47 `(#:tests? #f ; FIXME: Investigate test suite failures
48 #:test-target "tests"
49 #:phases
50 (alist-cons-after
51 'build 'patch-exec-bin-sh
52 (lambda _
53 (substitute* "test/run"
54 (("/bin/sh") (which "sh"))))
55 (alist-replace
56 'install
57 (lambda _
58 (zero? (system* "make" "install" "install-lib" "install-dev")))
59 %standard-phases))))
60 (inputs `(("attr" ,attr)))
61 (native-inputs
62 `(("gettext" ,gnu-gettext)
63 ("perl" ,perl)))
64 (home-page "http://savannah.nongnu.org/projects/acl")
65 (synopsis
66 "Library and tools for manipulating access control lists")
67 (description
68 "Library and tools for manipulating access control lists.")
69 (license (list gpl2+ lgpl2.1+))))