gnu: libvirt: Update to 7.2.0.
[jackhill/guix/guix.git] / gnu / packages / patches / ocaml-bitstring-fix-configure.patch
1 From 0aaddfceeea3e89df196ab1846da54d09713a512 Mon Sep 17 00:00:00 2001
2 From: Julien Lepiller <julien@lepiller.eu>
3 Date: Thu, 15 Dec 2016 21:17:31 +0100
4 Subject: [PATCH] fix configure
5
6 ---
7 Makefile.in | 9 +++++----
8 1 file changed, 5 insertions(+), 4 deletions(-)
9
10 diff --git a/Makefile.in b/Makefile.in
11 index d040f4c..85e0b38 100644
12 --- a/Makefile.in
13 +++ b/Makefile.in
14 @@ -32,6 +32,7 @@ BISECT_REPORT = @BISECT_REPORT@
15 BYTESWAP_H = @BYTESWAP_H@
16
17 OCAMLLIB = @OCAMLLIB@
18 +BISECTLIB = $(shell if test -z $${BISECTLIB}; then echo $(OCAMLLIB); else echo $${BISECTLIB}; fi)
19 top_srcdir = @top_srcdir@
20
21 pkg_cil = @OCAML_PKG_cil@
22 @@ -47,9 +48,9 @@ OCAMLOPTPACKAGES = $(OCAMLCPACKAGES)
23 OCAMLOPTLIBS = -linkpkg
24
25 ifneq ($(enable_coverage),no)
26 -OCAMLCFLAGS += -I +bisect -pp 'camlp4o $(OCAMLLIB)/bisect/instrument.cma'
27 +OCAMLCFLAGS += -I +bisect -pp 'camlp4o $(BISECTLIB)/bisect/instrument.cma'
28 OCAMLCLIBS += -I +bisect bisect.cma
29 -OCAMLOPTFLAGS += -I +bisect -pp 'camlp4o $(OCAMLLIB)/bisect/instrument.cma'
30 +OCAMLOPTFLAGS += -I +bisect -pp 'camlp4o $(BISECTLIB)/bisect/instrument.cma'
31 OCAMLOPTLIBS += -I +bisect bisect.cmxa
32 endif
33
34 @@ -110,7 +111,7 @@ bitstring_persistent.cmi: bitstring_persistent.mli
35 -I +camlp4 -pp camlp4of -c $<
36
37 pa_bitstring.cmo: pa_bitstring.ml bitstring.cma bitstring_persistent.cma
38 - $(OCAMLFIND) ocamlc bitstring.cma -I +camlp4 dynlink.cma camlp4lib.cma \
39 + $(OCAMLFIND) ocamlc $(OCAMLCFLAGS) bitstring.cma -I +camlp4 dynlink.cma camlp4lib.cma \
40 -pp camlp4of -c $< -o $@
41
42 bitstring-objinfo: bitstring_objinfo.cmo bitstring.cma bitstring_persistent.cma
43 @@ -133,7 +134,7 @@ byteswap.h: byteswap.in.h
44 ifeq ($(enable_coverage),no)
45 PP = -pp 'camlp4o bitstring.cma bitstring_persistent.cma pa_bitstring.cmo'
46 else
47 -PP = -pp 'camlp4o $(OCAMLLIB)/bisect/bisect.cma bitstring.cma bitstring_persistent.cma pa_bitstring.cmo'
48 +PP = -pp 'camlp4o $(BISECTLIB)/bisect/bisect.cma bitstring.cma bitstring_persistent.cma pa_bitstring.cmo'
49 endif
50
51 check: test
52 --
53 2.11.0