Merge branch 'master' into staging
[jackhill/guix/guix.git] / gnu / packages / file-systems.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2017, 2018, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
3 ;;; Copyright © 2017 Gábor Boskovits <boskovits@gmail.com>
4 ;;; Copyright © 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
5 ;;; Copyright © 2018 Leo Famulari <leo@famulari.name>
6 ;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
7 ;;;
8 ;;; This file is part of GNU Guix.
9 ;;;
10 ;;; GNU Guix is free software; you can redistribute it and/or modify it
11 ;;; under the terms of the GNU General Public License as published by
12 ;;; the Free Software Foundation; either version 3 of the License, or (at
13 ;;; your option) any later version.
14 ;;;
15 ;;; GNU Guix is distributed in the hope that it will be useful, but
16 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
17 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
18 ;;; GNU General Public License for more details.
19 ;;;
20 ;;; You should have received a copy of the GNU General Public License
21 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
22
23 (define-module (gnu packages file-systems)
24 #:use-module ((guix licenses) #:prefix license:)
25 #:use-module (guix packages)
26 #:use-module (guix download)
27 #:use-module (guix git-download)
28 #:use-module (guix build-system cmake)
29 #:use-module (guix build-system gnu)
30 #:use-module (guix build-system linux-module)
31 #:use-module (guix build-system trivial)
32 #:use-module (guix utils)
33 #:use-module (gnu packages)
34 #:use-module (gnu packages acl)
35 #:use-module (gnu packages attr)
36 #:use-module (gnu packages autotools)
37 #:use-module (gnu packages bison)
38 #:use-module (gnu packages check)
39 #:use-module (gnu packages compression)
40 #:use-module (gnu packages crypto)
41 #:use-module (gnu packages curl)
42 #:use-module (gnu packages datastructures)
43 #:use-module (gnu packages documentation)
44 #:use-module (gnu packages docbook)
45 #:use-module (gnu packages flex)
46 #:use-module (gnu packages glib)
47 #:use-module (gnu packages libffi)
48 #:use-module (gnu packages linux)
49 #:use-module (gnu packages nfs)
50 #:use-module (gnu packages onc-rpc)
51 #:use-module (gnu packages pkg-config)
52 #:use-module (gnu packages python)
53 #:use-module (gnu packages readline)
54 #:use-module (gnu packages sqlite)
55 #:use-module (gnu packages tls)
56 #:use-module (gnu packages valgrind)
57 #:use-module (gnu packages xml))
58
59 (define-public bcachefs-tools
60 (let ((commit "ab2f1ec24f5307b0cf1e3c4ad19bf350d9f54d9f")
61 (revision "0"))
62 (package
63 (name "bcachefs-tools")
64 (version (git-version "0.1" revision commit))
65 (source
66 (origin
67 (method git-fetch)
68 (uri (git-reference
69 (url "https://evilpiepirate.org/git/bcachefs-tools.git")
70 (commit commit)))
71 (file-name (git-file-name name version))
72 (sha256
73 (base32 "10pafvaxg1lvwnqjv3a4rsi96bghbpcsgh3vhqilndi334k3b0hd"))))
74 (build-system gnu-build-system)
75 (arguments
76 `(#:make-flags
77 (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
78 "INITRAMFS_DIR=$(PREFIX)/share/initramfs-tools"
79 "CC=gcc"
80 "PYTEST=pytest")
81 #:phases
82 (modify-phases %standard-phases
83 (delete 'configure)) ; no configure script
84 #:tests? #f)) ; XXX 6 valgrind tests fail
85 (native-inputs
86 `(("pkg-config" ,pkg-config)
87
88 ;; For tests.
89 ("python-pytest" ,python-pytest)
90 ("valgrind" ,valgrind)))
91 (inputs
92 `(("keyutils" ,keyutils)
93 ("libaio" ,libaio)
94 ("libscrypt" ,libscrypt)
95 ("libsodium" ,libsodium)
96 ("liburcu" ,liburcu)
97 ("util-linux" ,util-linux) ; lib{blkid,uuid}
98 ("lz4" ,lz4)
99 ("zlib" ,zlib)
100 ("zstd:lib" ,zstd "lib")))
101 (home-page "https://bcachefs.org/")
102 (synopsis "Tools to create and manage bcachefs file systems")
103 (description
104 "The bcachefs-tools are command-line utilities for creating, checking,
105 and otherwise managing bcachefs file systems.
106
107 Bcachefs is a @acronym{CoW, copy-on-write} file system supporting native
108 encryption, compression, snapshots, and (meta)data checksums. It can use
109 multiple block devices for replication and/or performance, similar to RAID.
110
111 In addition, bcachefs provides all the functionality of bcache, a block-layer
112 caching system, and lets you assign different roles to each device based on its
113 performance and other characteristics.")
114 (license license:gpl2+))))
115
116 (define-public httpfs2
117 (package
118 (name "httpfs2")
119 (version "0.1.5")
120 (source
121 (origin
122 (method url-fetch)
123 (uri (string-append "mirror://sourceforge/httpfs/httpfs2/"
124 "httpfs2-" version ".tar.gz"))
125 (sha256
126 (base32
127 "1h8ggvhw30n2r6w11n1s458ypggdqx6ldwd61ma4yd7binrlpjq1"))))
128 (build-system gnu-build-system)
129 (native-inputs
130 `(("asciidoc" ,asciidoc)
131 ("docbook-xml" ,docbook-xml)
132 ("libxml2" ,libxml2)
133 ("libxslt" ,libxslt)
134 ("pkg-config" ,pkg-config)))
135 (inputs
136 `(("fuse" ,fuse)
137 ("gnutls" ,gnutls)))
138 (arguments
139 `(#:phases
140 (modify-phases %standard-phases
141 (delete 'configure) ; no configure script
142 (replace 'install
143 ;; There's no ‘install’ target. Install all variants manually.
144 (lambda* (#:key outputs #:allow-other-keys)
145 (let* ((out (assoc-ref outputs "out"))
146 (bin (string-append out "/bin"))
147 (man1 (string-append out "/share/man/man1")))
148 (mkdir-p bin)
149 (mkdir-p man1)
150 (for-each
151 (lambda (variant)
152 (let ((man1-page (string-append variant ".1")))
153 (install-file variant bin)
154 (install-file man1-page man1)))
155 (list "httpfs2"
156 "httpfs2-mt"
157 "httpfs2-ssl"
158 "httpfs2-ssl-mt")))
159 #t)))
160 #:make-flags (list "CC=gcc")
161 #:parallel-build? #f ; can result in missing man pages
162 #:tests? #f)) ; no tests
163 (home-page "https://sourceforge.net/projects/httpfs/")
164 (synopsis "Mount remote files over HTTP")
165 (description "httpfs2 is a @code{fuse} file system for mounting any
166 @dfn{HyperText} (HTTP or HTTPS) URL. It uses HTTP/1.1 byte ranges to request
167 arbitrary bytes from the web server, without needing to download the entire
168 file. This is particularly useful with large archives such as ZIP files and
169 ISO images when you only need to inspect their contents or extract specific
170 files. Since the HTTP protocol itself has no notion of directories, only a
171 single file can be mounted.")
172 (license license:gpl2+)))
173
174 (define-public jfsutils
175 (package
176 (name "jfsutils")
177 (version "1.1.15")
178 (source
179 (origin
180 (method url-fetch)
181 (uri (string-append "http://jfs.sourceforge.net/project/pub/jfsutils-"
182 version ".tar.gz"))
183 (sha256
184 (base32 "0kbsy2sk1jv4m82rxyl25gwrlkzvl3hzdga9gshkxkhm83v1aji4"))
185 (patches (search-patches "jfsutils-add-sysmacros.patch"
186 "jfsutils-include-systypes.patch"))))
187 (build-system gnu-build-system)
188 (inputs
189 `(("util-linux" ,util-linux)))
190 (home-page "http://jfs.sourceforge.net/home.html")
191 (synopsis "Utilities for managing JFS file systems")
192 (description
193 "The JFSutils are a collection of utilities for managing the @acronym{JFS,
194 Journaled File System}, a 64-bit journaling file system created by IBM and later
195 ported to the kernel Linux. The following commands are available:
196 @enumerate
197 @item @command{fsck.jfs}: check and repair a JFS file system or replay its
198 transaction log.
199 @item @command{logdump}: dump the JFS journal log.
200 @item @command{logredo}: replay the JFS journal log.
201 @item @command{mkfs.jfs}: create a new JFS file system.
202 @item @command{xchklog}: save a JFS fsck log to a file.
203 @item @command{xchkdmp}: dump the contents of such a log file.
204 @item @command{xpeek}: a JFS file system editor with a shell-like interface.
205 @end enumerate\n")
206 (license license:gpl3+))) ; no explicit version given
207
208 (define-public jfsutils/static
209 (static-package
210 (package
211 (inherit jfsutils)
212 (name "jfsutils-static")
213 (inputs
214 `(("util-linux:static" ,util-linux "static")
215 ,@(package-inputs jfsutils))))))
216
217 (define-public jfs_fsck/static
218 (package
219 (name "jfs_fsck-static")
220 (version (package-version jfsutils))
221 (source #f)
222 (build-system trivial-build-system)
223 (arguments
224 `(#:modules ((guix build utils))
225 #:builder
226 (begin
227 (use-modules (guix build utils)
228 (ice-9 ftw)
229 (srfi srfi-26))
230 (let* ((jfsutils (assoc-ref %build-inputs "jfsutils"))
231 (fsck "jfs_fsck")
232 (out (assoc-ref %outputs "out"))
233 (sbin (string-append out "/sbin")))
234 (mkdir-p sbin)
235 (with-directory-excursion sbin
236 (install-file (string-append jfsutils "/sbin/" fsck)
237 ".")
238 (remove-store-references fsck)
239 (chmod fsck #o555))
240 #t))))
241 (inputs
242 `(("jfsutils" ,jfsutils/static)))
243 (home-page (package-home-page jfsutils))
244 (synopsis "Statically-linked jfs_fsck command from jfsutils")
245 (description "This package provides statically-linked jfs_fsck command taken
246 from the jfsutils package. It is meant to be used in initrds.")
247 (license (package-license jfsutils))))
248
249 (define-public disorderfs
250 (package
251 (name "disorderfs")
252 (version "0.5.6")
253 (source
254 (origin
255 (method git-fetch)
256 (uri (git-reference
257 (url "https://salsa.debian.org/reproducible-builds/disorderfs.git")
258 (commit version)))
259 (file-name (git-file-name name version))
260 (sha256
261 (base32
262 "1zn2ydap8k9fwjl3ivgrg6l32s5p4ik6ca6j1idp7c77znlv6cpp"))))
263 (build-system gnu-build-system)
264 (native-inputs
265 `(("pkg-config" ,pkg-config)))
266 (inputs
267 `(("fuse" ,fuse)
268 ("attr" ,attr)))
269 (arguments
270 `(#:phases (modify-phases %standard-phases
271 (delete 'configure)) ; no configure script
272 #:make-flags (let ((out (assoc-ref %outputs "out")))
273 (list (string-append "PREFIX=" out)))
274 #:test-target "test"
275 ;; FIXME: Tests require 'run-parts' which is not in Guix yet.
276 #:tests? #f))
277 (home-page "https://github.com/ReproducibleBuilds/disorderfs")
278 (synopsis "FUSE file system that introduces non-determinism")
279 (description
280 "An overlay FUSE file system that introduces non-determinism
281 into file system metadata. For example, it can randomize the order
282 in which directory entries are read. This is useful for detecting
283 non-determinism in the build process.")
284 (license license:gpl3+)))
285
286 (define-public glusterfs
287 (package
288 (name "glusterfs")
289 (version "7.0")
290 (source
291 (origin
292 (method url-fetch)
293 (uri (string-append "https://download.gluster.org/pub/gluster/glusterfs/"
294 (version-major version) "/"
295 (version-major+minor version) "/"
296 "glusterfs-" version ".tar.gz"))
297 (sha256
298 (base32
299 "0yzhx710ypj0j3m5dcgmmgvkp7p0rmmp2p7ld0axrm4vpwc2b1wa"))))
300 (build-system gnu-build-system)
301 (arguments
302 `(#:configure-flags
303 (let ((out (assoc-ref %outputs "out"))
304 (p2 (assoc-ref %build-inputs "python-2")))
305 (list (string-append "PYTHON=" p2 "/bin/python")
306 (string-append "--with-initdir=" out "/etc/init.d")
307 (string-append "--with-mountutildir=" out "/sbin")
308 "--enable-cmocka" ; unit tests
309 ;; "--enable-debug" ; debug build options
310 ;; "--enable-asan" ; Address Sanitizer
311 ;; "--enable-tsan" ; ThreadSanitizer
312 ))
313 #:phases
314 (modify-phases %standard-phases
315 (add-before 'configure 'autogen
316 (lambda _ (invoke "./autogen.sh"))))))
317 (native-inputs
318 `(("pkg-config" ,pkg-config)
319 ("libtirpc", libtirpc)
320 ("rpcsvc-proto", rpcsvc-proto)
321 ("python-2" ,python-2) ; must be version 2
322 ("flex" ,flex)
323 ("bison" ,bison)
324 ("libtool" ,libtool)
325 ("autoconf" ,autoconf)
326 ("automake" ,automake)
327 ("cmocka" ,cmocka)))
328 (inputs
329 `(("acl" ,acl)
330 ("fuse", fuse)
331 ("openssl" ,openssl)
332 ("liburcu" ,liburcu)
333 ("libuuid" ,util-linux)
334 ("libxml2" ,libxml2)
335 ("readline" ,readline)
336 ("zlib" ,zlib)
337 ("libaio", libaio)
338 ("rdma-core", rdma-core)))
339 (home-page "https://www.gluster.org")
340 (synopsis "Distributed file system")
341 (description "GlusterFS is a distributed scalable network file system
342 suitable for data-intensive tasks such as cloud storage and media streaming.
343 It allows rapid provisioning of additional storage based on your storage
344 consumption needs. It incorporates automatic failover as a primary feature.
345 All of this is accomplished without a centralized metadata server.")
346 ;; The user may choose either LGPLv3+ or GPLv2 only.
347 (license (list license:lgpl3+ license:gpl2+))))
348
349 (define-public curlftpfs
350 (package
351 (name "curlftpfs")
352 (version "0.9.2")
353 (source
354 (origin
355 (method url-fetch)
356 (uri (string-append "mirror://sourceforge/curlftpfs/curlftpfs/" version
357 "/curlftpfs-" version ".tar.gz"))
358 (sha256
359 (base32
360 "0n397hmv21jsr1j7zx3m21i7ryscdhkdsyqpvvns12q7qwwlgd2f"))))
361 (build-system gnu-build-system)
362 (arguments
363 `(#:phases
364 (modify-phases %standard-phases
365 (add-after 'unpack 'fix-test
366 (lambda _
367 ;; One of the 512-Byte block counts is definitely wrong.
368 ;; See <https://sourceforge.net/p/curlftpfs/bugs/73/>.
369 (substitute* "tests/ftpfs-ls_unittest.c"
370 (("4426192") "12814800"))
371 #t)))))
372 (inputs
373 `(("curl" ,curl)
374 ("glib" ,glib)
375 ("fuse" ,fuse)))
376 (native-inputs
377 `(("pkg-config" ,pkg-config)))
378 (home-page "http://curlftpfs.sourceforge.net/")
379 (synopsis "Mount remote file systems over FTP")
380 (description
381 "This is a file system client based on the FTP File Transfer Protocol.")
382 (license license:gpl2+)))
383
384 (define-public libnfs
385 (package
386 (name "libnfs")
387 (version "3.0.0")
388 (source (origin
389 (method git-fetch)
390 (uri (git-reference
391 (url "https://github.com/sahlberg/libnfs.git")
392 (commit (string-append "libnfs-" version))))
393 (file-name (git-file-name name version))
394 (sha256
395 (base32
396 "115p55y2cbs92z5lmcnjx1v29lwinpgq4sha9v1kq1vd8674h404"))))
397 (build-system gnu-build-system)
398 (home-page "https://github.com/sahlberg/libnfs")
399 (native-inputs
400 `(("autoconf" ,autoconf)
401 ("automake" ,automake)
402 ("libtool" ,libtool)
403 ("pkg-config" ,pkg-config)))
404 (synopsis "Client library for accessing NFS shares")
405 (description "LIBNFS is a client library for accessing NFS shares over a
406 network. LIBNFS offers three different APIs, for different use :
407
408 @enumerate
409 @item RAW, a fully asynchronous low level RPC library for NFS protocols. This
410 API provides very flexible and precise control of the RPC issued.
411 @item NFS ASYNC, a fully asynchronous library for high level vfs functions
412 @item NFS SYNC, a synchronous library for high level vfs functions.
413 @end enumerate\n")
414 (license (list license:lgpl2.1+ ; library
415 license:gpl3+ ; tests
416 license:bsd-3 ; copied nsf4 files
417 ))))
418
419 (define-public apfs-fuse
420 (let ((commit "c7036a3030d128bcecefc1eabc47c039ccfdcec9")
421 (revision "0"))
422 (package
423 (name "apfs-fuse")
424 (version (git-version "0.0.0" revision commit))
425 (source (origin
426 (method git-fetch)
427 (uri (git-reference
428 (url "https://github.com/sgan81/apfs-fuse")
429 (recursive? #t) ; for lzfse
430 (commit commit)))
431 (sha256
432 (base32
433 "1akd4cx1f9cyq6sfk9ybv4chhjwjlnqi8ic4z5ajnd5x0g76nz3r"))
434 (file-name (git-file-name name version))))
435 (build-system cmake-build-system)
436 (arguments
437 `(#:tests? #f ; No test suite
438 #:phases
439 (modify-phases %standard-phases
440 ;; No 'install' target in CMakeLists.txt
441 (replace 'install
442 (lambda* (#:key outputs #:allow-other-keys)
443 (let* ((out (assoc-ref outputs "out"))
444 (bin (string-append out "/bin"))
445 (lib (string-append out "/lib"))
446 (doc (string-append out "/share/doc/"
447 (string-append ,name "-" ,version))))
448 (install-file "apfs-dump" bin)
449 (install-file "apfs-dump-quick" bin)
450 (install-file "apfs-fuse" bin)
451 (install-file "libapfs.a" lib)
452 #t))))))
453 (inputs
454 `(("bzip2" ,bzip2)
455 ("fuse" ,fuse)
456 ("zlib" ,zlib)))
457 (synopsis "Read-only FUSE driver for the APFS file system")
458 (description "APFS-FUSE is a read-only FUSE driver for the @dfn{Apple File
459 System} (APFS). It is currently in an experimental state — it may not be able
460 to read all files, and it does not support all the compression methods in
461 APFS.")
462 (home-page "https://github.com/sgan81/apfs-fuse")
463 (license license:gpl2+))))
464
465 (define-public zfs
466 (package
467 (name "zfs")
468 (version "0.8.2")
469 (outputs '("out" "module" "src"))
470 (source
471 (origin
472 (method url-fetch)
473 (uri (string-append "https://github.com/zfsonlinux/zfs/releases"
474 "/download/zfs-" version
475 "/zfs-" version ".tar.gz"))
476 (sha256
477 (base32
478 "1f7aig15q3z832pr2n48j3clafic2yk1vvqlh28vpklfghjqwq27"))))
479 (build-system linux-module-build-system)
480 (arguments
481 `(;; The ZFS kernel module should not be downloaded since the license
482 ;; terms don't allow for distributing it, only building it locally.
483 #:substitutable? #f
484 ;; Tests cannot run in an unprivileged build environment.
485 #:tests? #f
486 #:phases
487 (modify-phases %standard-phases
488 (add-after 'configure 'really-configure
489 (lambda* (#:key outputs inputs #:allow-other-keys)
490 (let ((out (assoc-ref outputs "out")))
491 (substitute* "configure"
492 (("-/bin/sh") (string-append "-" (which "sh")))
493 ((" /bin/sh") (string-append " " (which "sh"))))
494 (invoke "./configure"
495 "--with-config=all"
496 (string-append "--prefix=" out)
497 (string-append "--with-dracutdir=" out "/lib/dracut")
498 (string-append "--with-udevdir=" out "/lib/udev")
499 (string-append "--with-mounthelperdir=" out "/sbin")
500 (string-append "--with-linux="
501 (assoc-ref inputs "linux-module-builder")
502 "/lib/modules/build")))))
503 (add-after 'unpack 'patch-source
504 (lambda* (#:key inputs outputs #:allow-other-keys)
505 (let ((out (assoc-ref outputs "out"))
506 (src (assoc-ref outputs "src"))
507 (util-linux (assoc-ref inputs "util-linux"))
508 (nfs-utils (assoc-ref inputs "nfs-utils")))
509 (substitute* "module/zfs/zfs_ctldir.c"
510 (("/usr/bin/env\", \"umount")
511 (string-append util-linux "/bin/umount\", \"-n"))
512 (("/usr/bin/env\", \"mount")
513 (string-append util-linux "/bin/mount\", \"-n")))
514 (substitute* "lib/libzfs/libzfs_mount.c"
515 (("/bin/mount") (string-append util-linux "/bin/mount"))
516 (("/bin/umount") (string-append util-linux "/bin/umount")))
517 (substitute* "lib/libshare/nfs.c"
518 (("/usr/sbin/exportfs")
519 (string-append nfs-utils "/sbin/exportfs")))
520 (substitute* "config/zfs-build.m4"
521 (("\\$sysconfdir/init.d") (string-append out "/etc/init.d")))
522 (substitute* '("etc/zfs/Makefile.am"
523 "cmd/zed/Makefile.am")
524 (("\\$\\(sysconfdir)") (string-append out "/etc")))
525 (substitute* "cmd/vdev_id/vdev_id"
526 (("PATH=/bin:/sbin:/usr/bin:/usr/sbin")
527 (string-append "PATH="
528 (dirname (which "chmod")) ":"
529 (dirname (which "grep")) ":"
530 (dirname (which "sed")) ":"
531 (dirname (which "gawk")))))
532 (substitute* "contrib/pyzfs/Makefile.in"
533 ((".*install-lib.*") ""))
534 (substitute* '("Makefile.am" "Makefile.in")
535 (("\\$\\(prefix)/src") (string-append src "/src"))))
536 #t))
537 (replace 'build
538 (lambda _ (invoke "make")))
539 (replace 'install
540 (lambda* (#:key outputs inputs native-inputs #:allow-other-keys)
541 (let* ((out (assoc-ref outputs "out"))
542 (moddir (assoc-ref outputs "module"))
543 (kmod (assoc-ref (or native-inputs inputs) "kmod")))
544 (invoke "make" "install"
545 (string-append "DEFAULT_INITCONF_DIR=" out "/etc/default")
546 (string-append "DEPMOD=" kmod "/bin/depmod")
547 (string-append "INSTALL_PATH=" out)
548 (string-append "INSTALL_MOD_PATH=" moddir)
549 "INSTALL_MOD_STRIP=1")
550 (install-file "contrib/bash_completion.d/zfs"
551 (string-append out "/share/bash-completion/completions"))
552 (symlink "../share/pkgconfig/" (string-append out "/lib/pkgconfig"))
553 #t))))))
554 (native-inputs
555 `(("attr" ,attr)
556 ("pkg-config" ,pkg-config)))
557 (inputs
558 `(("eudev" ,eudev)
559 ("libaio" ,libaio)
560 ("libtirpc" ,libtirpc)
561 ("nfs-utils" ,nfs-utils)
562 ("openssl" ,openssl)
563 ("python" ,python)
564 ("python-cffi" ,python-cffi)
565 ("util-linux" ,util-linux)
566 ("zlib" ,zlib)))
567 (home-page "https://zfsonlinux.org/")
568 (synopsis "Native ZFS on Linux")
569 (description
570 "ZFS on Linux is an advanced file system and volume manager which was
571 originally developed for Solaris and is now maintained by the OpenZFS
572 community.")
573 (license license:cddl1.0)))