Merge branch 'master' into staging
[jackhill/guix/guix.git] / gnu / packages / aspell.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2014, 2015, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2015, 2016 Alex Kost <alezost@gmail.com>
4 ;;; Copyright © 2016 John Darrington <jmd@gnu.org>
5 ;;; Copyright © 2016, 2017, 2019 Efraim Flashner <efraim@flashner.co.il>
6 ;;; Copyright © 2016 Christopher Andersson <christopher@8bits.nu>
7 ;;; Copyright © 2016 Theodoros Foradis <theodoros@foradis.org>
8 ;;; Copyright © 2016, 2017, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
9 ;;; Copyright © 2019 Jens Mølgaard <jens@zete.tk>
10 ;;; Copyright © 2020 Timotej Lazar <timotej.lazar@araneo.si>
11 ;;;
12 ;;; This file is part of GNU Guix.
13 ;;;
14 ;;; GNU Guix is free software; you can redistribute it and/or modify it
15 ;;; under the terms of the GNU General Public License as published by
16 ;;; the Free Software Foundation; either version 3 of the License, or (at
17 ;;; your option) any later version.
18 ;;;
19 ;;; GNU Guix is distributed in the hope that it will be useful, but
20 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
21 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
22 ;;; GNU General Public License for more details.
23 ;;;
24 ;;; You should have received a copy of the GNU General Public License
25 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
26
27 (define-module (gnu packages aspell)
28 #:use-module (guix packages)
29 #:use-module (guix download)
30 #:use-module (guix build-system gnu)
31 #:use-module (guix licenses)
32 #:use-module (guix utils)
33 #:use-module (gnu packages)
34 #:use-module (gnu packages base)
35 #:use-module (gnu packages compression)
36 #:use-module (gnu packages perl)
37 #:use-module (ice-9 match))
38
39 (define-public aspell
40 (package
41 (name "aspell")
42 (version "0.60.6.1")
43 (source
44 (origin
45 (method url-fetch)
46 (uri (string-append "mirror://gnu/aspell/aspell-"
47 version ".tar.gz"))
48 (sha256
49 (base32
50 "1qgn5psfyhbrnap275xjfrzppf5a83fb67gpql0kfqv37al869gm"))
51 (patches (search-patches "aspell-default-dict-dir.patch"
52 "aspell-gcc-compat.patch"))))
53 (build-system gnu-build-system)
54 (arguments
55 `(#:phases
56 (modify-phases %standard-phases
57 (add-before 'build 'set-filter-path
58 (lambda* (#:key outputs #:allow-other-keys)
59 ;; Change the default value of 'filter-path' so that filters such
60 ;; as 'tex-filter.so' can be found. By default none of the
61 ;; filters would be found.
62 (let* ((out (assoc-ref outputs "out"))
63 (libdir (string-append out "/lib/aspell-"
64 ,(version-major+minor version))))
65 (substitute* "common/config.cpp"
66 (("\"filter-path(.*)DICT_DIR" _ middle)
67 (string-append "\"filter-path" middle
68 "\"" libdir "\"")))
69 #t)))
70 (add-after 'install 'wrap-aspell
71 (lambda* (#:key outputs #:allow-other-keys)
72 (let ((bin/aspell (string-append (assoc-ref outputs "out")
73 "/bin/aspell")))
74 (wrap-program bin/aspell
75 '("ASPELL_CONF" "" =
76 ("${ASPELL_CONF:-\"dict-dir ${GUIX_PROFILE:-$HOME/.guix-profile}/lib/aspell\"}")))
77 #t))))))
78 (inputs `(("perl" ,perl)))
79
80 (native-search-paths
81 ;; This is a Guix-specific environment variable that takes a single
82 ;; entry, not an actual search path.
83 (list (search-path-specification
84 (variable "ASPELL_DICT_DIR")
85 (separator #f)
86 (files '("lib/aspell")))))
87
88 (home-page "http://aspell.net/")
89 (synopsis "Spell checker")
90 (description
91 "Aspell is a spell-checker which can be used either as a library or as
92 a standalone program. Notable features of Aspell include its full support of
93 documents written in the UTF-8 encoding and its ability to use multiple
94 dictionaries, including personal ones.")
95 (license lgpl2.1+)))
96
97 ;;;
98 ;;; Dictionaries.
99 ;;;
100 ;;; Use 'export ASPELL_CONF="dict-dir $HOME/.guix-profile/lib/aspell"' to use
101 ;;; them, or set the Guix-specific 'ASPELL_DICT_DIR', or just do nothing (as
102 ;;; long as 'HOME' is set, that's fine!).
103 ;;;
104
105 (define* (aspell-dictionary dict-name full-name
106 #:key version sha256 (prefix "aspell6-"))
107 (package
108 (name (string-append
109 "aspell-dict-"
110 ;; Downcase and replace underscore in package names
111 ;; to follow Guix naming conventions.
112 (string-map (match-lambda
113 (#\_ #\-)
114 (chr chr))
115 (string-downcase dict-name))))
116 (version version)
117 (source (origin
118 (method url-fetch)
119 (uri (string-append "mirror://gnu/aspell/dict/" dict-name
120 "/" prefix dict-name "-"
121 version ".tar.bz2"))
122 (sha256 sha256)))
123 (build-system gnu-build-system)
124 (arguments
125 `(#:phases
126 (modify-phases %standard-phases
127 (replace 'configure
128 (lambda* (#:key outputs #:allow-other-keys)
129 (let ((out (assoc-ref outputs "out")))
130 (invoke "./configure")))))
131 #:make-flags
132 (let ((out (assoc-ref %outputs "out")))
133 (list (string-append "dictdir=" out "/lib/aspell")
134 (string-append "datadir=" out "/lib/aspell")))
135 #:tests? #f))
136 (native-inputs `(("aspell" ,aspell)
137 ("which" ,which)))
138 (synopsis (string-append full-name " dictionary for GNU Aspell")) ; XXX: i18n
139 (description
140 "This package provides a dictionary for the GNU Aspell spell checker.")
141 (license gpl2+)
142 (home-page "http://aspell.net/")))
143
144
145 (define-public aspell-dict-ar
146 (aspell-dictionary "ar" "Arabic"
147 #:version "1.2-0"
148 #:prefix "aspell6-"
149 #:sha256
150 (base32
151 "1avw40bp8yi5bnkq64ihm2rldgw34lk89yz281q9bmndh95a47h4")))
152
153 (define-public aspell-dict-be
154 (aspell-dictionary "be" "Belarusian"
155 #:version "0.01"
156 #:prefix "aspell5-"
157 #:sha256
158 (base32
159 "1svls9p7rsfi3hs0afh0cssj006qb4v1ik2yzqgj8hm10c6as2sm")))
160
161 (define-public aspell-dict-ca
162 (let ((version "2.5.0")
163 (sha256
164 (base32 "0kbi8fi7a1bys31kfqrlh332gyik0cfdmxgl7n15sa9c305rkgwq")))
165 (package
166 (inherit (aspell-dictionary "ca" "Catalan"
167 #:version version
168 #:sha256 sha256))
169 (source
170 (origin
171 (method url-fetch)
172 (uri (string-append "https://www.softcatala.org/pub/softcatala/aspell/"
173 version "/aspell6-ca-" version ".tar.bz2"))
174 (sha256 sha256)))
175 (home-page "https://www.softcatala.org/pub/softcatala/aspell/"))))
176
177 (define-public aspell-dict-de
178 (aspell-dictionary "de" "German"
179 #:version "20161207-7-0"
180 #:sha256
181 (base32
182 "0wamclvp66xfmv5wff96v6gdlnfv4y8lx3f8wvxyzm5imwgms4n2")))
183
184 (define-public aspell-dict-da
185 (aspell-dictionary "da" "Danish"
186 #:version "1.4.42-1"
187 #:prefix "aspell5-"
188 #:sha256
189 (base32
190 "1hfkmiyhgrx5lgrb2mffjbdn1hivrm73wcg7x0iid74p2yb0fjpp")))
191
192 (define-public aspell-dict-el
193 (aspell-dictionary "el" "Greek"
194 #:version "0.08-0"
195 #:prefix "aspell6-"
196 #:sha256
197 (base32
198 "1ljcc30zg2v2h3w5h5jr5im41mw8jbsgvvhdd2cii2yzi8d0zxja")))
199
200 (define-public aspell-dict-en
201 (aspell-dictionary "en" "English"
202 #:version "2019.10.06-0"
203 #:sha256
204 (base32
205 "1zai9wrqwgb9z9vfgb22qhrvxvg73jg0ix44j1khm2f6m96lncr4")))
206
207 (define-public aspell-dict-eo
208 (aspell-dictionary "eo" "Esperanto"
209 #:version "2.1.20000225a-2"
210 #:sha256
211 (base32
212 "09vf0mbiicbmyb4bwb7v7lgpabnylg0wy7m3hlhl5rjdda6x3lj1")))
213
214 (define-public aspell-dict-es
215 (aspell-dictionary "es" "Spanish"
216 #:version "1.11-2"
217 #:sha256
218 (base32
219 "1k5g328ac1hdpp6fsg57d8md6i0aqcwlszp3gbmp5706wyhpydmd")))
220
221 (define-public aspell-dict-fi
222 (aspell-dictionary "fi" "Finnish"
223 #:version "0.7-0"
224 #:prefix "aspell6-"
225 #:sha256
226 (base32
227 "07d5s08ba4dd89cmwy9icc01i6fjdykxlb9ravmhdrhi8mxz1mzq")))
228
229 (define-public aspell-dict-fr
230 (aspell-dictionary "fr" "French"
231 #:version "0.50-3"
232 #:prefix "aspell-"
233 #:sha256
234 (base32
235 "14ffy9mn5jqqpp437kannc3559bfdrpk7r36ljkzjalxa53i0hpr")))
236
237 (define-public aspell-dict-grc
238 (aspell-dictionary "grc" "Ancient Greek"
239 #:version "0.02-0"
240 #:sha256
241 (base32
242 "1zxr8958v37v260fkqd4pg37ns5h5kyqm54hn1hg70wq5cz8h512")))
243
244 (define-public aspell-dict-he
245 (aspell-dictionary "he" "Hebrew"
246 #:version "1.0-0"
247 #:sha256
248 (base32
249 "13bhbghx5b8g0119g3wxd4n8mlf707y41vlf59irxjj0kynankfn")))
250
251 (define-public aspell-dict-hi
252 (aspell-dictionary "hi" "Hindi"
253 #:version "0.02-0"
254 #:prefix "aspell6-"
255 #:sha256
256 (base32
257 "0drs374qz4419zx1lf2k281ydxf2750jk5ailafj1x0ncz27h1ys")))
258
259 (define-public aspell-dict-it
260 (let ((version "2.4-20070901-0")
261 (sha256
262 (base32 "0d6ypii3jblprpibazb6ypady536jz62rwxlss1x1raq07rhvvqn")))
263 (package
264 (inherit (aspell-dictionary "it" "Italian"
265 #:version version
266 #:sha256 sha256))
267
268 ;; The version hosted at <https://ftp.gnu.org/gnu/aspell/dict> is even
269 ;; more out of date.
270 (source
271 (origin
272 (method url-fetch)
273 (uri (string-append "mirror://sourceforge/linguistico/"
274 "Dizionario%20italiano%20per%20Aspell/" version "/"
275 "aspell6-it-" version ".tar.bz2"))
276 (sha256 sha256)))
277 (home-page
278 "http://linguistico.sourceforge.net/pages/dizionario_italiano.html"))))
279
280 (define-public aspell-dict-mi
281 (aspell-dictionary "mi" "Maori"
282 #:version "0.50-0"
283 #:sha256
284 (base32
285 "12bxplpd348yx8d2q8qvahi9dlp7qf28qmanzhziwc7np8rixvmy")))
286
287 (define-public aspell-dict-nl
288 (aspell-dictionary "nl" "Dutch"
289 #:version "0.50-2"
290 #:prefix "aspell-"
291 #:sha256
292 (base32
293 "0ffb87yjsh211hllpc4b9khqqrblial4pzi1h9r3v465z1yhn3j4")))
294
295 (define-public aspell-dict-nn
296 (aspell-dictionary "nn" "Norwegian Nynorsk"
297 #:version "0.50.1-1"
298 #:sha256
299 (base32
300 "0w2k5l5rbqpliripgqwiqixz5ghnjf7i9ggbrc4ly4vy1ia10rmc")))
301
302 (define-public aspell-dict-pt-br
303 (aspell-dictionary "pt_BR" "Brazilian Portuguese"
304 #:version "20131030-12-0"
305 #:sha256
306 (base32
307 "1xqlpk21s93c6blkdnpk7l62q9fxjvzdv2x86chl8p2x1gdrj3gb")))
308
309 (define-public aspell-dict-pt-pt
310 (aspell-dictionary "pt_PT" "Portuguese"
311 #:version "20190329-1-0"
312 #:sha256
313 (base32
314 "0ld0d0ily4jqifjfsxfv4shbicz6ymm2gk56fq9gbzra1j4qnw75")))
315
316 (define-public aspell-dict-ru
317 (aspell-dictionary "ru" "Russian"
318 #:version "0.99f7-1"
319 #:sha256
320 (base32
321 "0ip6nq43hcr7vvzbv4lwwmlwgfa60hrhsldh9xy3zg2prv6bcaaw")))
322
323 (define-public aspell-dict-sl
324 (aspell-dictionary "sl" "Slovenian"
325 #:version "0.50-0"
326 #:prefix "aspell-"
327 #:sha256
328 (base32
329 "1l9kc5g35flq8kw9jhn2n0bjb4sipjs4qkqzgggs438kywkx2rp5")))
330
331 (define-public aspell-dict-sv
332 (aspell-dictionary "sv" "Swedish"
333 #:version "0.51-0"
334 #:prefix "aspell-"
335 #:sha256
336 (base32
337 "02jwkjhr32kvyibnyzgx3smbnm576jwdzg3avdf6zxwckhy5fw4v")))
338
339 (define-public aspell-dict-uk
340 (aspell-dictionary "uk" "Ukrainian"
341 #:version "1.4.0-0"
342 #:sha256
343 (base32
344 "137i4njvnslab6l4s291s11xijr5jsy75lbdph32f9y183lagy9m")))
345
346 \f
347 ;;;
348 ;;; Hunspell packages made from the Aspell word lists.
349 ;;;
350
351 (define* (aspell-word-list language synopsis
352 #:optional
353 (nick (string-map (lambda (chr)
354 (if (char=? #\_ chr)
355 #\-
356 chr))
357 (string-downcase language))))
358 (package
359 (name (string-append "hunspell-dict-" nick))
360 (version "2018.04.16")
361 (source (origin
362 (method url-fetch)
363 (uri (string-append
364 "http://downloads.sourceforge.net/wordlist/scowl-"
365 version ".tar.gz"))
366 (sha256
367 (base32
368 "11lkrnhwrf5mvrrq45k4mads3n9aswgac8dc25ba61c75alxb5rs"))))
369 (native-inputs
370 `(("tar" ,tar)
371 ("gzip" ,gzip)
372 ("perl" ,perl)
373 ("aspell" ,aspell)))
374 (build-system gnu-build-system)
375 (arguments
376 `(#:phases
377 (modify-phases %standard-phases
378 (delete 'configure)
379 (delete 'check)
380 (replace 'build
381 (lambda _
382 (substitute* "speller/make-hunspell-dict"
383 (("zip -9 .*$")
384 "return\n"))
385 (mkdir "speller/hunspell")
386
387 ;; XXX: This actually builds all the dictionary variants.
388 (invoke "make" "-C" "speller" "hunspell")))
389 (replace 'install
390 (lambda* (#:key outputs #:allow-other-keys)
391 (let* ((out (assoc-ref %outputs "out"))
392 (hunspell (string-append out "/share/hunspell"))
393 (myspell (string-append out "/share/myspell"))
394 (doc (string-append out "/share/doc/"
395 ,name))
396 (dot-dic ,(string-append "speller/" language ".dic")))
397 (mkdir-p myspell)
398
399 ;; Usually there's only a 'LANGUAGE.dic' file, but for the "en"
400 ;; dictionary, there no 'en.dic'. Instead, there's a set of
401 ;; 'en*.dic' files, hence the 'find-files' call below.
402 (if (file-exists? dot-dic)
403 (install-file dot-dic hunspell)
404 (for-each (lambda (dic)
405 (install-file dic hunspell))
406 (find-files "speller"
407 ,(string-append language ".*\\.dic$"))))
408
409 (install-file ,(string-append "speller/" language ".aff")
410 hunspell)
411 (symlink hunspell (string-append myspell "/dicts"))
412 (for-each (lambda (file)
413 (install-file file doc))
414 (find-files "."
415 "^(Copyright|.*\\.(txt|org|md))$"))
416 #t))))))
417 (synopsis synopsis)
418 (description
419 "This package provides a dictionary for the Hunspell spell-checking
420 library.")
421 (home-page "http://wordlist.aspell.net/")
422 (license (non-copyleft "file://Copyright"
423 "Word lists come from several sources, all
424 under permissive licensing terms. See the 'Copyright' file."))))
425
426 (define-syntax define-word-list-dictionary
427 (syntax-rules (synopsis)
428 ((_ name language (synopsis text))
429 (define-public name
430 (aspell-word-list language text)))
431 ((_ name language nick (synopsis text))
432 (define-public name
433 (aspell-word-list language text nick)))))
434
435 (define-word-list-dictionary hunspell-dict-en
436 "en"
437 (synopsis "Hunspell dictionary for English"))
438
439 (define-word-list-dictionary hunspell-dict-en-au
440 "en_AU"
441 (synopsis "Hunspell dictionary for Australian English"))
442
443 (define-word-list-dictionary hunspell-dict-en-ca
444 "en_CA"
445 (synopsis "Hunspell dictionary for Canadian English"))
446
447 (define-word-list-dictionary hunspell-dict-en-gb
448 "en_GB-ise" "en-gb"
449 (synopsis "Hunspell dictionary for British English, with -ise endings"))
450
451 (define-word-list-dictionary hunspell-dict-en-gb-ize
452 "en_GB-ize"
453 (synopsis "Hunspell dictionary for British English, with -ize endings"))
454
455 (define-word-list-dictionary hunspell-dict-en-us
456 "en_US"
457 (synopsis "Hunspell dictionary for United States English"))