gnu: Add node-env-variable.
[jackhill/guix/guix.git] / gnu / packages / node-xyz.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages node-xyz)
20 #:use-module ((guix licenses) #:prefix license:)
21 #:use-module (guix packages)
22 #:use-module (guix git-download)
23 #:use-module (guix build-system node))
24
25 (define-public node-env-variable
26 (package
27 (name "node-env-variable")
28 (version "0.0.4")
29 (source
30 (origin
31 (method git-fetch)
32 (uri (git-reference
33 (url "https://github.com/bigpipe/env-variable")
34 (commit version)))
35 (file-name (git-file-name name version))
36 (sha256
37 (base32
38 "0nnpxjxfhy4na7fixb7p3ww6ard5xgggfm83b78i333867r4gmsq"))))
39 (build-system node-build-system)
40 (arguments '(#:tests? #f)) ; No tests.
41 (home-page "https://github.com/bigpipe/env-variable")
42 (synopsis "Environment variables for Node with fallbacks")
43 (description "This package provides environment variables with
44 @code{process.env}, @code{window.name}, @code{location.hash} and
45 @code{localStorage} fallbacks.")
46 (license license:expat)))