gnu: Add new package barcode
[jackhill/guix/guix.git] / gnu / packages / aidc.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 John Darringon <jmd@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages aidc)
20 #:use-module (gnu packages)
21 #:use-module ((guix licenses)
22 #:renamer (symbol-prefix-proc 'license:))
23 #:use-module (guix packages)
24 #:use-module (guix download)
25 #:use-module (guix build-system gnu))
26
27
28 (define-public barcode
29 (package
30 (name "barcode")
31 (version "0.99")
32 (source (origin
33 (method url-fetch)
34 (uri (string-append "mirror://gnu/barcode/barcode-"
35 version ".tar.xz"))
36 (sha256 (base32
37 "1indapql5fjz0bysyc88cmc54y8phqrbi7c76p71fgjp45jcyzp8"))))
38 (build-system gnu-build-system)
39 (synopsis "Convert text strings to printed bars in various standards")
40 (description "GNU Barcode is a flexible tool to produce printed barcodes
41 from text strings. It supports a variety of encoding standards and sizing
42 measurements. Barcodes can be output in PostScript or Encapsulated PostScript
43 formats.")
44 (license license:gpl3+)
45 (home-page "http://www.gnu.org/software/barcode/")))