Merge branch 'master' into staging
[jackhill/guix/guix.git] / gnu / packages / storage.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2017, 2018 Marius Bakke <mbakke@fastmail.com>
3 ;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages storage)
21 #:use-module (guix download)
22 #:use-module ((guix licenses) #:prefix license:)
23 #:use-module (guix packages)
24 #:use-module (guix utils)
25 #:use-module (guix build-system cmake)
26 #:use-module (gnu packages)
27 #:use-module (gnu packages admin)
28 #:use-module (gnu packages assembly)
29 #:use-module (gnu packages authentication)
30 #:use-module (gnu packages bdw-gc)
31 #:use-module (gnu packages boost)
32 #:use-module (gnu packages check)
33 #:use-module (gnu packages compression)
34 #:use-module (gnu packages crypto)
35 #:use-module (gnu packages cryptsetup)
36 #:use-module (gnu packages curl)
37 #:use-module (gnu packages databases)
38 #:use-module (gnu packages disk)
39 #:use-module (gnu packages gcc)
40 #:use-module (gnu packages gnuzilla)
41 #:use-module (gnu packages gperf)
42 #:use-module (gnu packages jemalloc)
43 #:use-module (gnu packages linux)
44 #:use-module (gnu packages lua)
45 #:use-module (gnu packages openldap)
46 #:use-module (gnu packages perl)
47 #:use-module (gnu packages pkg-config)
48 #:use-module (gnu packages python)
49 #:use-module (gnu packages python-xyz)
50 #:use-module (gnu packages tls)
51 #:use-module (gnu packages web)
52 #:use-module (gnu packages xml))
53
54 (define-public ceph
55 (package
56 (name "ceph")
57 (version "13.2.5")
58 (source (origin
59 (method url-fetch)
60 (uri (string-append "https://download.ceph.com/tarballs/ceph-"
61 version ".tar.gz"))
62 (sha256
63 (base32
64 "0jbs6l763clbqnq2s5jksn44yf71rhcnk85cw64fqvmv0r4ch71n"))
65 (patches
66 (search-patches "ceph-skip-unittest_blockdev.patch"
67 "ceph-skip-collect-sys-info-test.patch"
68 "ceph-detect-rocksdb.patch"
69 "ceph-volume-respect-PATH.patch"
70 "ceph-disable-cpu-optimizations.patch"))
71 (modules '((guix build utils)))
72 (snippet
73 '(begin
74 (for-each delete-file-recursively
75 '(;; TODO: Unbundle these:
76 ;"src/isa-l"
77 ;"src/lua"
78 ;"src/googletest"
79 ;"src/xxHash"
80 ;"src/zstd"
81 ;"src/civetweb"
82 "src/test/downloads"
83 "src/rapidjson"
84 "src/spdk"
85 "src/rocksdb"
86 "src/boost"))
87 #t))))
88 (build-system cmake-build-system)
89 (arguments
90 `(#:configure-flags
91 (let* ((out (assoc-ref %outputs "out"))
92 (lib (assoc-ref %outputs "lib"))
93 (libdir (string-append lib "/lib")))
94 (list (string-append "-DCMAKE_INSTALL_PREFIX=" out)
95 (string-append "-DCMAKE_INSTALL_LIBDIR=" libdir)
96 (string-append "-DCMAKE_INSTALL_INCLUDEDIR="
97 lib "/include")
98 ;; We need both libdir and libdir/ceph in RUNPATH.
99 (string-append "-DCMAKE_INSTALL_RPATH="
100 libdir ";" libdir "/ceph")
101 (string-append "-DCMAKE_INSTALL_SYSCONFDIR=" out "/etc")
102 (string-append "-DCMAKE_INSTALL_MANDIR=" out "/share/man")
103 (string-append "-DCMAKE_INSTALL_DOCDIR=" out "/share/ceph/doc")
104 (string-append "-DCMAKE_INSTALL_LIBEXECDIR=" out "/libexec")
105 (string-append "-DKEYUTILS_INCLUDE_DIR="
106 (assoc-ref %build-inputs "keyutils") "/include")
107 (string-append "-DXFS_INCLUDE_DIR="
108 (assoc-ref %build-inputs "xfsprogs") "/include")
109 "-DCMAKE_INSTALL_LOCALSTATEDIR=/var"
110 "-DENABLE_SHARED=ON"
111 "-DWITH_SYSTEM_ROCKSDB=ON"
112 "-DWITH_SYSTEM_BOOST=ON"
113 "-DWITH_PYTHON3=ON"
114 ;; TODO: Enable these when available in Guix.
115 "-DWITH_MGR_DASHBOARD_FRONTEND=OFF" ;requires node + nodeenv
116 "-DWITH_BABELTRACE=OFF"
117 "-DWITH_LTTNG=OFF"
118 "-DWITH_SPDK=OFF"
119 "-DWITH_XIO=OFF"
120 ;; Use jemalloc instead of tcmalloc.
121 "-DALLOCATOR=jemalloc"))
122 ;; FIXME: Some of the tests leak Btrfs subvolumes on Btrfs. See
123 ;; <https://bugs.gnu.org/29674> for details. Disable tests until
124 ;; resolved.
125 #:tests? #f
126 #:phases
127 (modify-phases %standard-phases
128 (add-after 'unpack 'patch-source
129 (lambda* (#:key outputs #:allow-other-keys)
130 (let ((out (assoc-ref outputs "out"))
131 (lib (assoc-ref outputs "lib")))
132
133 (substitute* "cmake/modules/Distutils.cmake"
134 ;; Prevent creation of Python eggs.
135 (("setup.py install")
136 "setup.py install --single-version-externally-managed --root=/"))
137
138 (substitute* (find-files "src/pybind" "^setup\\.py$")
139 ;; Here we inject an extra line to the `setup.py' of the
140 ;; Python C libraries so RUNPATH gets set up correctly.
141 (("^([[:blank:]]+)extra_compile_args=(.*)$" _ indent args)
142 (string-append indent "extra_compile_args=" args
143 indent "extra_link_args=['-Wl,-rpath="
144 lib "/lib'],\n")))
145
146 (substitute* "src/ceph-disk/tox.ini"
147 ;; Disable flake8 test since it complains about too long lines.
148 (("envlist = flake8,py27") "envlist = py27"))
149
150 (substitute* "src/ceph-detect-init/tox.ini"
151 ;; Disable python3 tests until we at least get py2 working.
152 (("envlist = pep8,py27,py3") "envlist = pep8,py27"))
153
154 (substitute* "src/key_value_store/kv_flat_btree_async.cc"
155 (("/usr/include/") ""))
156
157 (substitute* "src/test/test_subprocess.cc"
158 (("/bin/sh") (which "sh")))
159 (substitute* "qa/standalone/special/ceph_objectstore_tool.py"
160 (("/bin/rm") (which "rm")))
161 (substitute* "src/ceph-disk/ceph_disk/main.py"
162 (("/bin/mount") "mount")
163 (("/bin/umount") "umount")
164 (("/sbin/blkid") (which "blkid"))
165 (("'cryptsetup'") (string-append "'" (which "cryptsetup") "'"))
166 (("'sgdisk'") (string-append "'" (which "sgdisk") "'"))
167 (("'parted'") (string-append "'" (which "parted") "'"))
168 (("'udevadm'") (string-append "'" (which "udevadm") "'")))
169
170 (substitute* "udev/50-rbd.rules"
171 (("/usr/bin/ceph-rbdnamer")
172 (string-append out "/bin/ceph-rbdnamer")))
173 (substitute* "udev/60-ceph-by-parttypeuuid.rules"
174 (("/sbin/blkid") (which "blkid")))
175 (substitute* "udev/95-ceph-osd.rules"
176 (("/usr/sbin/ceph-disk")
177 (string-append out "/bin/ceph-disk")))
178
179 (substitute* "src/test/run-cli-tests"
180 ;; Use our python-cram instead of the (un)bundled one.
181 (("CRAM_BIN=.*$")
182 (string-append "CRAM_BIN=" (which "cram") "\n")))
183
184 ;; Disable tests that are known to fail.
185 ;; TODO: The majority of these fail because
186 ;; 'qa/workunits/ceph-helpers.sh' expects to find
187 ;; /tmp/ceph-disk-virtualenv/bin/ceph-disk, but somehow
188 ;; src/ceph-disk/CMakeLists.txt fails to create it.
189 (substitute* "src/test/CMakeLists.txt"
190 ;; FIXME: These tests fails because `ceph-disk'
191 ;; is not available.
192 (("^add_ceph_test\\(test-ceph-helpers\\.sh.*$") "\n")
193 (("^add_ceph_test\\(test_pidfile\\.sh.*$") "\n")
194 ;; XXX Why does this fail.
195 (("^add_ceph_test\\(cephtool-test-mon\\.sh.*$") "\n")
196 ;; This fails due to missing '/etc/fstab'.
197 (("^add_ceph_test\\(cephtool-test-rados\\.sh.*$") "\n")
198 ;; `Bad messages to stderr: OSD has the store locked'
199 (("^add_ceph_test\\(ceph_objectstore_tool\\.py.*$") "\n")
200 ;; The bundled python-cram fork needs patching to work on
201 ;; guix, and the system version does not support --error-dir.
202 ;; https://bitbucket.org/brodie/cram/issues/9
203 (("^add_ceph_test\\(run-cli-tests.*$") "\n")
204 ;; FIXME: tox/virtualenv/pip does not discover the
205 ;; required packages and tries to go online.
206 (("^add_test\\(NAME run-tox-ceph-disk.*$") "\n")
207 (("^add_test\\(NAME run-tox-ceph-detect-init.*$") "\n")
208 ;; Also remove from the set_property block.
209 (("run-tox-ceph-disk") "")
210 (("run-tox-ceph-detect-init") ""))
211 ;; TODO: This also seems to fail because of /etc/os-release.
212 ;; How to make src/common/util.cc behave without it.
213 (substitute* "src/test/crush/CMakeLists.txt"
214 (("^add_ceph_test\\(crush-classes\\.sh.*$") "\n"))
215 ;; More 'ceph-disk' issues here.. :-(
216 (substitute* "src/test/erasure-code/CMakeLists.txt"
217 (("^add_ceph_test\\(test-erasure-code-plugins\\.sh.*$") "\n")
218 (("^add_ceph_test\\(test-erasure-code\\.sh.*$") "\n")
219 (("^add_ceph_test\\(test-erasure-eio\\.sh.*$") "\n"))
220 (substitute* "src/test/libradosstriper/CMakeLists.txt"
221 (("^add_ceph_test\\(rados-striper\\.sh.*$") "\n"))
222 (substitute* "src/test/mon/CMakeLists.txt"
223 (("^add_ceph_test\\(osd-crush\\.sh.*$") "\n")
224 (("^add_ceph_test\\(test_pool_quota\\.sh.*$") "\n")
225 (("^add_ceph_test\\(osd-pool-create\\.sh.*$") "\n"))
226 (substitute* "src/test/osd/CMakeLists.txt"
227 (("^add_ceph_test\\(osd-bench\\.sh.*$") "\n")
228 (("^add_ceph_test\\(osd-config\\.sh.*$") "\n")
229 (("add_ceph_test\\(osd-dup\\.sh.*$") "\n")
230 (("^add_ceph_test\\(osd-markdown\\.sh.*$") "\n")
231 (("^add_ceph_test\\(osd-reactivate\\.sh.*$") "\n")
232 (("^add_ceph_test\\(osd-reuse-id\\.sh.*$") "\n")
233 (("^add_ceph_test\\(osd-scrub-repair\\.sh.*$") "\n")
234 (("^add_ceph_test\\(osd-scrub-snaps\\.sh.*$") "\n")
235 (("^add_ceph_test\\(osd-copy-from\\.sh.*$") "\n")
236 (("^add_ceph_test\\(osd-fast-mark-down\\.sh.*$") "\n"))
237 #t)))
238 (add-before 'configure 'gcc-workaround
239 (lambda _
240 (unsetenv "C_INCLUDE_PATH")
241 (unsetenv "CPLUS_INCLUDE_PATH")
242 #t))
243 (add-before 'check 'set-check-environment
244 (lambda _
245 ;; Run tests in parallel.
246 (setenv "CTEST_PARALLEL_LEVEL"
247 (number->string (parallel-job-count)))
248 ;; `pip' requires write access in $HOME.
249 (setenv "HOME" "/tmp")
250 #t))
251 (add-before 'install 'set-install-environment
252 (lambda* (#:key outputs #:allow-other-keys)
253 (let* ((out (assoc-ref outputs "out"))
254 (py2sitedir
255 (string-append out "/lib/python2.7/site-packages"))
256 (py3sitedir
257 (string-append out "/lib/python"
258 ,(version-major+minor
259 (package-version python))
260 "/site-packages")))
261 ;; The Python install scripts refuses to function if
262 ;; the install directory is not on PYTHONPATH.
263 (setenv "PYTHONPATH"
264 (string-append py2sitedir ":" py3sitedir ":"
265 (getenv "PYTHONPATH")))
266 #t)))
267 (add-after 'install 'wrap-python-scripts
268 (lambda* (#:key inputs outputs #:allow-other-keys)
269 (let* ((out (assoc-ref outputs "out"))
270 (scripts '("ceph" "ceph-mgr" "ceph-volume"
271 "ceph-detect-init"
272 "ceph-disk")) ;deprecated
273 (prettytable (assoc-ref inputs "python2-prettytable"))
274 (six (assoc-ref inputs "python2-six"))
275 (sitedir (lambda (package)
276 (string-append package
277 "/lib/python2.7/site-packages")))
278 (PYTHONPATH (string-append
279 (sitedir out) ":"
280 (sitedir six) ":"
281 (sitedir prettytable))))
282 (for-each (lambda (executable)
283 (wrap-program (string-append out "/bin/" executable)
284 `("PYTHONPATH" ":" prefix (,PYTHONPATH))))
285 scripts)
286 #t))))))
287 (outputs
288 '("out" "lib"))
289 (native-inputs
290 `(("gcc" ,gcc-7) ;7 or later is required
291 ("gperf" ,gperf)
292 ("pkg-config" ,pkg-config)
293 ("python-cython" ,python-cython)
294 ("python-sphinx" ,python-sphinx)
295 ("yasm" ,yasm)
296
297 ;; For tests.
298 ("inetutils" ,inetutils)
299 ("jq" ,jq)
300 ("perl" ,perl)
301 ("xmlstarlet" ,xmlstarlet)
302 ("python2-cram" ,python2-cram)
303 ("python2-virtualenv" ,python2-virtualenv)
304
305 ;; These dependencies are taken from test-requirements.txt
306 ;; of ceph-disk and ceph-detect-init. The latter can also
307 ;; test against python3, but let's try to get python2 tests
308 ;; working first since that is the default.
309 ("python2-configobj" ,python2-configobj)
310 ("python2-coverage" ,python2-coverage)
311 ("python2-discover" ,python2-discover)
312 ("python2-fixtures" ,python2-fixtures)
313 ("python2-flake8" ,python2-flake8)
314 ("python2-mock" ,python2-mock)
315 ("python2-nose" ,python2-nose)
316 ("python2-pip" ,python2-pip)
317 ("python2-pytest" ,python2-pytest)
318 ("python2-subunit" ,python2-subunit)
319 ("python2-testrepository" ,python2-testrepository)
320 ("python2-testtools" ,python2-testtools)
321 ("python2-tox" ,python2-tox)))
322 (inputs
323 `(("boost" ,boost)
324 ("curl" ,curl)
325 ("cryptsetup" ,cryptsetup)
326 ("expat" ,expat)
327 ("fcgi" ,fcgi)
328 ("fuse" ,fuse)
329 ("gptfdisk" ,gptfdisk)
330 ("jemalloc" ,jemalloc)
331 ("keyutils" ,keyutils)
332 ("leveldb" ,leveldb)
333 ("libaio" ,libaio)
334 ("libatomic-ops" ,libatomic-ops)
335 ("lua" ,lua)
336 ("lz4" ,lz4)
337 ("oath-toolkit" ,oath-toolkit)
338 ("openldap" ,openldap)
339 ("openssl" ,openssl)
340 ("nss" ,nss)
341 ("parted" ,parted)
342 ("python@2" ,python-2)
343 ("python2-prettytable" ,python2-prettytable) ;used by ceph_daemon.py
344 ("python2-six" ,python2-six) ;for ceph-mgr + plugins
345 ("python@3" ,python-3)
346 ("rapidjson" ,rapidjson)
347 ("rocksdb" ,rocksdb)
348 ("snappy" ,snappy)
349 ("udev" ,eudev)
350 ("util-linux" ,util-linux)
351 ("xfsprogs" ,xfsprogs)
352 ("zlib" ,zlib)))
353 (home-page "https://ceph.com/")
354 (synopsis "Distributed object store and file system")
355 (description
356 "Ceph is a distributed storage system designed for reliability and
357 performance. It provides network-based block devices (RBD), a POSIX
358 compliant file system (CephFS), and offers compatibility with various
359 storage protocols (S3, NFS, and others) through the RADOS gateway.")
360 ;; The Ceph libraries are LGPL2.1 and most of the utilities fall under
361 ;; GPL2. The installed erasure code plugins are BSD-3 licensed and do
362 ;; not use the GPL code. The source archive includes a number of files
363 ;; carrying other licenses; consult COPYING for more information. Note
364 ;; that COPYING does not cover third-party bundled software.
365 (license (list license:lgpl2.1 license:gpl2 ;some files are 'or later'
366 license:cc-by-sa3.0 ;documentation
367 license:bsd-3 ;isa-l,jerasure,++
368 license:expat)))) ;civetweb,java bindings