Merge branch 'version-1.2.0'
[jackhill/guix/guix.git] / gnu / packages / mpd.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014, 2015 David Thompson <dthompson2@worcester.edu>
3 ;;; Copyright © 2014 Andreas Enge <andreas@enge.fr>
4 ;;; Copyright © 2014 Cyrill Schenkel <cyrill.schenkel@gmail.com>
5 ;;; Copyright © 2014 Ian Denhardt <ian@zenhack.net>
6 ;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
7 ;;; Copyright © 2016, 2018, 2019, 2020 Leo Famulari <leo@famulari.name>
8 ;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
9 ;;; Copyright © 2019 Evan Straw <evan.straw99@gmail.com>
10 ;;; Copyright © 2020 Ricardo Wurmus <rekado@elephly.net>
11 ;;; Copyright © 2020 Lars-Dominik Braun <lars@6xq.net>
12 ;;; Copyright © 2020 Simon Streit <simon@netpanic.org>
13 ;;;
14 ;;; This file is part of GNU Guix.
15 ;;;
16 ;;; GNU Guix is free software; you can redistribute it and/or modify it
17 ;;; under the terms of the GNU General Public License as published by
18 ;;; the Free Software Foundation; either version 3 of the License, or (at
19 ;;; your option) any later version.
20 ;;;
21 ;;; GNU Guix is distributed in the hope that it will be useful, but
22 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
23 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
24 ;;; GNU General Public License for more details.
25 ;;;
26 ;;; You should have received a copy of the GNU General Public License
27 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
28
29 (define-module (gnu packages mpd)
30 #:use-module (gnu packages)
31 #:use-module ((guix licenses) #:prefix license:)
32 #:use-module (guix packages)
33 #:use-module (guix download)
34 #:use-module (guix git-download)
35 #:use-module (guix utils)
36 #:use-module (guix build-system cmake)
37 #:use-module (guix build-system gnu)
38 #:use-module (guix build-system meson)
39 #:use-module (guix build-system python)
40 #:use-module (gnu packages audio)
41 #:use-module (gnu packages autotools)
42 #:use-module (gnu packages avahi)
43 #:use-module (gnu packages base)
44 #:use-module (gnu packages boost)
45 #:use-module (gnu packages cdrom)
46 #:use-module (gnu packages gettext)
47 #:use-module (gnu packages gnome)
48 #:use-module (gnu packages gnupg)
49 #:use-module (gnu packages gtk)
50 #:use-module (gnu packages icu4c)
51 #:use-module (gnu packages libusb)
52 #:use-module (gnu packages readline)
53 #:use-module (gnu packages check)
54 #:use-module (gnu packages compression)
55 #:use-module (gnu packages curl)
56 #:use-module (gnu packages documentation)
57 #:use-module (gnu packages glib)
58 #:use-module (gnu packages linux)
59 #:use-module (gnu packages mp3)
60 #:use-module (gnu packages ncurses)
61 #:use-module (gnu packages pcre)
62 #:use-module (gnu packages pkg-config)
63 #:use-module (gnu packages python)
64 #:use-module (gnu packages python-xyz)
65 #:use-module (gnu packages pulseaudio)
66 #:use-module (gnu packages qt)
67 #:use-module (gnu packages sphinx)
68 #:use-module (gnu packages sqlite)
69 #:use-module (gnu packages video)
70 #:use-module (gnu packages xiph))
71
72 (define-public libmpdclient
73 (package
74 (name "libmpdclient")
75 (version "2.19")
76 (source (origin
77 (method url-fetch)
78 (uri
79 (string-append "https://musicpd.org/download/libmpdclient/"
80 (car (string-split version #\.))
81 "/libmpdclient-" version ".tar.xz"))
82 (sha256
83 (base32
84 "12d1fzlkcnjw4ayk2wp11vhglfcvr5k02arzdbkhiavq496av2hm"))))
85 (build-system meson-build-system)
86 (native-inputs
87 `(("pkg-config" ,pkg-config)
88
89 ;; For building HTML documentation.
90 ("doxygen" ,doxygen)
91
92 ;; For tests.
93 ("check" ,check)))
94 (arguments
95 `(#:configure-flags
96 (list "-Ddocumentation=true"
97 "-Dtest=true")))
98 (synopsis "Music Player Daemon client library")
99 (description "A stable, documented, asynchronous API library for
100 interfacing MPD in the C, C++ & Objective C languages.")
101 (home-page "https://www.musicpd.org/libs/libmpdclient/")
102 (license license:bsd-3)))
103
104 (define-public mpd
105 (package
106 (name "mpd")
107 (version "0.22.3")
108 (source (origin
109 (method url-fetch)
110 (uri
111 (string-append "https://musicpd.org/download/mpd/"
112 (version-major+minor version)
113 "/mpd-" version ".tar.xz"))
114 (sha256
115 (base32
116 "1kvcarqijyw07bdqszjsn62plmncaid5az0q542p6rsygc1i501k"))))
117 (build-system meson-build-system)
118 (arguments
119 `(#:configure-flags '("-Ddocumentation=enabled")))
120 (inputs `(("ao" ,ao)
121 ("alsa-lib" ,alsa-lib)
122 ("avahi" ,avahi)
123 ("boost" ,boost)
124 ("curl" ,curl)
125 ("ffmpeg" ,ffmpeg)
126 ("flac" ,flac)
127 ("glib" ,glib)
128 ("icu4c" ,icu4c)
129 ;; The LAME decoder comes from FFmpeg, but is added here so that
130 ;; configure picks up the LAME encoder.
131 ("lame" ,lame)
132 ("libid3tag" ,libid3tag)
133 ("libmpdclient" ,libmpdclient)
134 ("libsamplerate" ,libsamplerate)
135 ("libsndfile" ,libsndfile)
136 ("libvorbis" ,libvorbis)
137 ("opus" ,opus)
138 ("pulseaudio" ,pulseaudio)
139 ("sqlite" ,sqlite)
140 ("zlib" ,zlib)))
141 (native-inputs `(("pkg-config" ,pkg-config)
142 ("python-sphinx" ,python-sphinx)))
143 ;; Missing optional inputs:
144 ;; libyajl
145 ;; libcdio_paranoia
146 ;; libmms
147 ;; libadplug
148 ;; libaudiofile
149 ;; faad2
150 ;; fluidsynth
151 ;; libgme
152 ;; libshout
153 ;; libmpg123
154 ;; libmodplug
155 ;; libmpcdec
156 ;; libsidplay2
157 ;; libwavpack
158 ;; libwildmidi
159 ;; libtwolame
160 ;; libroar
161 ;; libjack
162 ;; OpenAL
163 (synopsis "Music Player Daemon")
164 (description "Music Player Daemon (MPD) is a flexible, powerful,
165 server-side application for playing music. Through plugins and libraries it
166 can play a variety of sound files while being controlled by its network
167 protocol.")
168 (home-page "https://www.musicpd.org/")
169 (license license:gpl2)))
170
171 (define-public mpd-mpc
172 (package
173 (name "mpd-mpc")
174 (version "0.33")
175 (source (origin
176 (method url-fetch)
177 (uri
178 (string-append "https://www.musicpd.org/download/mpc/"
179 (car (string-split version #\.))
180 "/mpc-" version ".tar.xz"))
181 (sha256
182 (base32
183 "15hjpzqs83v1zx49x8nkpwy9hpl1jxd55z1w50vm82gm32zcqh2g"))))
184 (build-system meson-build-system)
185 (inputs `(("libmpdclient" ,libmpdclient)))
186 (native-inputs
187 `(("pkg-config" ,pkg-config)
188 ("python-sphinx" ,python-sphinx)))
189 (synopsis "Music Player Daemon client")
190 (description "MPC is a minimalist command line interface to MPD, the music
191 player daemon.")
192 (home-page "https://www.musicpd.org/clients/mpc/")
193 (license license:gpl2)))
194
195 (define-public ncmpc
196 (package
197 (name "ncmpc")
198 (version "0.42")
199 (source (origin
200 (method url-fetch)
201 (uri
202 (string-append "http://musicpd.org/download/ncmpc/"
203 (version-major version)
204 "/ncmpc-" version ".tar.xz"))
205 (sha256
206 (base32
207 "0kfdyvqd2dfrxll5bla8mm10xvpngshlmyjf6wic4wbafqflgxx5"))))
208 (build-system meson-build-system)
209 (arguments
210 `(#:configure-flags
211 ;; Otherwise, they are installed incorrectly, in
212 ;; '$out/share/man/man/man1'.
213 (list (string-append "-Dmandir=" (assoc-ref %outputs "out")
214 "/share"))))
215 (inputs `(("boost" ,boost)
216 ("pcre" ,pcre)
217 ("libmpdclient" ,libmpdclient)
218 ("ncurses" ,ncurses)))
219 (native-inputs `(("gettext" ,gettext-minimal) ; for xgettext
220 ("pkg-config" ,pkg-config)
221 ("python-sphinx" ,python-sphinx)))
222 (synopsis "Curses Music Player Daemon client")
223 (description "ncmpc is a fully featured MPD client, which runs in a
224 terminal using ncurses.")
225 (home-page "https://www.musicpd.org/clients/ncmpc/")
226 (license license:gpl2)))
227
228 (define-public ncmpcpp
229 (package
230 (name "ncmpcpp")
231 (version "0.8.2")
232 (source (origin
233 (method url-fetch)
234 (uri
235 (string-append "https://ncmpcpp.rybczak.net/stable/ncmpcpp-"
236 version ".tar.bz2"))
237 (sha256
238 (base32
239 "0m0mjb049sl62vx13h9waavysa30mk0rphacksnvf94n13la62v5"))))
240 (build-system gnu-build-system)
241 (inputs `(("libmpdclient" ,libmpdclient)
242 ("boost" ,boost)
243 ("readline" ,readline)
244 ("ncurses" ,ncurses)
245 ("taglib" ,taglib)
246 ("icu4c" ,icu4c)
247 ("curl" ,curl)))
248 (native-inputs
249 `(("pkg-config" ,pkg-config)))
250 (arguments
251 '(#:configure-flags
252 '("BOOST_LIB_SUFFIX=" "--with-taglib" "--enable-clock")))
253 (synopsis "Featureful ncurses based MPD client inspired by ncmpc")
254 (description "Ncmpcpp is an mpd client with a UI very similar to ncmpc,
255 but it provides new useful features such as support for regular expressions
256 for library searches, extended song format, items filtering, the ability to
257 sort playlists, and a local file system browser.")
258 (home-page "https://ncmpcpp.rybczak.net/")
259 (license license:gpl2+)))
260
261 (define-public mpdscribble
262 (package
263 (name "mpdscribble")
264 (version "0.23")
265 (source (origin
266 (method url-fetch)
267 (uri (string-append "http://www.musicpd.org/download/mpdscribble/"
268 version "/mpdscribble-" version ".tar.xz"))
269 (sha256
270 (base32
271 "0s66zqscb44p88cl3kcv5jkjcqsskcnrv7xgrjhzrchf2kcpwf53"))))
272 (build-system meson-build-system)
273 (inputs `(("boost" ,boost)
274 ("curl" ,curl)
275 ("libgcrypt" ,libgcrypt)
276 ("libmpdclient" ,libmpdclient)))
277 (native-inputs `(("pkg-config" ,pkg-config)))
278 (synopsis "MPD client for track scrobbling")
279 (description "mpdscribble is a Music Player Daemon client which submits
280 information about tracks being played to a scrobbler, such as Libre.FM.")
281 (home-page "https://www.musicpd.org/clients/mpdscribble/")
282 (license license:gpl2+)))
283
284 (define-public python-mpd2
285 (package
286 (name "python-mpd2")
287 (version "0.5.5")
288 (source (origin
289 (method url-fetch)
290 (uri (pypi-uri "python-mpd2" version))
291 (sha256
292 (base32
293 "0laypd7h1j14b4vrmiayqlzdsh2j5hc3zv4l0fqvbrbw9y6763ii"))))
294 (build-system python-build-system)
295 (arguments
296 '(#:phases
297 (modify-phases %standard-phases
298 (replace 'check
299 (lambda _ (invoke "python" "mpd_test.py"))))))
300 (native-inputs `(("python-mock" ,python-mock)))
301 (home-page "https://github.com/Mic92/python-mpd2")
302 (synopsis "Python MPD client library")
303 (description "Python-mpd2 is a Python library which provides a client
304 interface for the Music Player Daemon.")
305 (license license:lgpl3+)))
306
307 (define-public python2-mpd2
308 (package-with-python2 python-mpd2))
309
310 (define-public sonata
311 (package
312 (name "sonata")
313 (version "1.7b1")
314 (source (origin
315 (method git-fetch)
316 (uri (git-reference
317 (url "https://github.com/multani/sonata")
318 (commit (string-append "v" version))))
319 (file-name (git-file-name name version))
320 (sha256
321 (base32
322 "1npbxlrg6k154qybfd250nq2p96kxdsdkj9wwnp93gljnii3g8wh"))))
323 (build-system python-build-system)
324 (arguments
325 `(#:modules ((guix build gnu-build-system)
326 (guix build python-build-system)
327 ((guix build glib-or-gtk-build-system) #:prefix glib-or-gtk:)
328 (guix build utils))
329 #:imported-modules (,@%gnu-build-system-modules
330 (guix build python-build-system)
331 (guix build glib-or-gtk-build-system))
332 #:phases
333 (modify-phases %standard-phases
334 (add-after 'install 'glib-or-gtk-wrap
335 (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-wrap))
336 (add-after 'install 'wrap-sonata
337 (lambda* (#:key outputs #:allow-other-keys)
338 (let ((out (assoc-ref outputs "out"))
339 (gi-typelib-path (getenv "GI_TYPELIB_PATH")))
340 (wrap-program (string-append out "/bin/sonata")
341 `("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path))))
342 #t)))))
343 (native-inputs
344 `(("gettext" ,gettext-minimal)))
345 (inputs
346 `(("python-mpd2" ,python-mpd2)
347 ("gtk+" ,gtk+)
348 ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
349 ("gobject-introspection" ,gobject-introspection)
350 ("adwaita-icon-theme" ,adwaita-icon-theme)
351 ("python-pygobject" ,python-pygobject)))
352 (synopsis "Elegant client for the Music Player Daemon")
353 (description "Sonata is an elegant graphical client for the Music Player
354 Daemon (MPD). It supports playlists, multiple profiles (connecting to different
355 MPD servers, search and multimedia key support.")
356 (home-page "https://www.nongnu.org/sonata/")
357 (license license:gpl3+)))
358
359 (define-public ashuffle
360 (package
361 (name "ashuffle")
362 (version "2.0.2")
363 (source (origin
364 (method git-fetch)
365 (uri (git-reference
366 (url "https://github.com/joshkunz/ashuffle")
367 (commit (string-append "v" version))))
368 (file-name (git-file-name name version))
369 (sha256
370 (base32
371 "11aa95cg0yca2m2d00sar6wr14g3lc7cfm9bin1h7lk7asdm8azp"))))
372 (native-inputs `(("pkg-config" ,pkg-config)))
373 (inputs `(("libmpdclient" ,libmpdclient)))
374 (build-system meson-build-system)
375 (home-page "https://github.com/joshkunz/ashuffle")
376 (synopsis "Automatic library-wide shuffle for mpd")
377 (description "ashuffle is an application for automatically shuffling your
378 MPD library in a similar way to many other music players' 'shuffle library'
379 feature. ashuffle works like any other MPD client, and can be used alongside
380 other MPD frontends.")
381 (license license:expat)))
382
383 (define-public mpdris2
384 (package
385 (name "mpdris2")
386 (version "0.8")
387 (source (origin
388 (method git-fetch)
389 (uri (git-reference
390 (url "https://github.com/eonpatapon/mpDris2")
391 (commit version)))
392 (file-name (git-file-name name version))
393 (sha256
394 (base32
395 "048b8acsd1b8kcxzd9fsh5p9g2an9c4rznicfcpyrsjz5syv894h"))))
396 (build-system gnu-build-system)
397 ;; Manually wrap the binary, because we’re not using python-build-system.
398 (arguments
399 '(#:phases
400 (modify-phases %standard-phases
401 (add-after 'install 'wrap-program
402 (lambda* (#:key inputs outputs #:allow-other-keys)
403 (let ((out (assoc-ref outputs "out"))
404 (python-path (getenv "PYTHONPATH")))
405 (wrap-program (string-append out "/bin/mpDris2")
406 `("PYTHONPATH" ":" prefix (,python-path)))
407 #t))))))
408 (inputs
409 `(("python-mpd2" ,python-mpd2)
410 ("python-dbus" ,python-dbus)
411 ("python-pygobject" ,python-pygobject)
412 ("python" ,python))) ; Sets PYTHONPATH.
413 ;; For bootstrapping.
414 (native-inputs
415 `(("autoconf" ,autoconf)
416 ("automake" ,automake)
417 ("gettext" ,gettext-minimal)
418 ("which" ,which)
419 ("intltool" ,intltool)))
420 (synopsis "MPRIS V2.1 support for MPD")
421 (description "Client for the Music Player Daemon providing MPRIS 2
422 support")
423 (home-page "https://github.com/eonpatapon/mpDris2")
424 (license license:gpl3+)))
425
426 (define-public cantata
427 (package
428 (name "cantata")
429 (version "2.4.2")
430 (source (origin
431 (method url-fetch)
432 (uri (string-append "https://github.com/CDrummond/"
433 "cantata/releases/download/v" version "/"
434 "cantata-" version ".tar.bz2"))
435 (sha256
436 (base32
437 "10pcrpmb4n1mkgr21xd580nrbmh57q7s72cbs1zay847hc65vliy"))))
438 (build-system cmake-build-system)
439 (arguments
440 `(#:tests? #f)) ; No test suite
441 (native-inputs
442 `(("pkg-config" ,pkg-config)))
443 (inputs
444 `(("eudev", eudev)
445 ("ffmpeg" ,ffmpeg)
446 ("libcdio-paranoia" ,libcdio-paranoia)
447 ("libebur128" ,libebur128)
448 ("libmtp" ,libmtp)
449 ("mpg123" ,mpg123)
450 ("qtbase" ,qtbase)
451 ("qtmultimedia" ,qtmultimedia)
452 ("qtsvg" ,qtsvg)
453 ("taglib" ,taglib)
454 ("zlib" ,zlib)))
455 (synopsis "Graphical MPD Client")
456 (description "Cantata is a graphical client for the Music Player Daemon
457 (MPD), using the Qt5 toolkit. Its user interface is highly customizable,
458 supporting multiple collections, ratings, and dynamic playlists. A local cache
459 of the music library will be created to provide a hierarchy of albums and
460 artists along with albumart.")
461 (home-page "https://github.com/cdrummond/cantata")
462 (license license:gpl3+)))