Merge branch 'master' into staging
[jackhill/guix/guix.git] / gnu / packages / patches / combinatorial-blas-io-fix.patch
1 IO not appropriate in the context of a sorting routine, and in any case the
2 proper headers are not included, so gcc emits an undefined symbol error.
3 Remove the "printf" statement.
4
5 --- CombBLAS_beta_16_2/usort/include/usort/seqUtils.tcc
6 +++ CombBLAS_beta_16_2/usort/include/usort/seqUtils.tcc
7 @@ -142,7 +142,6 @@
8 }
9 if ( (a[nmax]==a[nmin]) && (ctr==0) )
10 {
11 - printf("All the numbers are identical, the list is sorted\n");
12 return;
13 }
14