gnu: libretro-lowresnx: Update to 1.2.
[jackhill/guix/guix.git] / gnu / packages / gnu-pw-mgr.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Eric Bavier <bavier@member.fsf.org>
3 ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
4 ;;; Copyright © 2016, 2018, 2020 Efraim Flashner <efraim@flashner.co.il>
5 ;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
6 ;;;
7 ;;; This file is part of GNU Guix.
8 ;;;
9 ;;; GNU Guix is free software; you can redistribute it and/or modify it
10 ;;; under the terms of the GNU General Public License as published by
11 ;;; the Free Software Foundation; either version 3 of the License, or (at
12 ;;; your option) any later version.
13 ;;;
14 ;;; GNU Guix is distributed in the hope that it will be useful, but
15 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
16 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
17 ;;; GNU General Public License for more details.
18 ;;;
19 ;;; You should have received a copy of the GNU General Public License
20 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
21
22 (define-module (gnu packages gnu-pw-mgr)
23 #:use-module (guix packages)
24 #:use-module (guix licenses)
25 #:use-module (guix download)
26 #:use-module (guix build-system gnu)
27 #:use-module (gnu packages)
28 #:use-module (gnu packages base)
29 #:use-module (gnu packages autogen))
30
31 (define-public gnu-pw-mgr
32 (package
33 (name "gnu-pw-mgr")
34 (version "2.7.4")
35 (source
36 (origin
37 (method url-fetch)
38 (uri (string-append "mirror://gnu/gnu-pw-mgr/gnu-pw-mgr-"
39 version ".tar.xz"))
40 (sha256
41 (base32 "0fhwvsmsqpw0vnivarfg63l8pgwqfv7d5wi6l80jpb41dj6qpjz8"))))
42 (build-system gnu-build-system)
43 (arguments
44 '(#:phases
45 (modify-phases %standard-phases
46 (add-after 'patch-source-shebangs 'patch-more-shebangs
47 (lambda _
48 (substitute* "tests/dom.test"
49 (("/usr/bin/printf") (which "printf")))
50 #t))
51 (add-before 'check 'pre-check
52 (lambda _
53 ;; In the build environment, there is no /dev/tty.
54 (substitute* "tests/base.test"
55 (("/dev/tty") "/dev/null"))
56 #t)))))
57 (native-inputs
58 `(("which" ,which)))
59 (home-page "https://www.gnu.org/software/gnu-pw-mgr/")
60 (synopsis "Retrieve login credentials without recording passwords")
61 (description
62 "This program is designed to make it easy to reconstruct difficult
63 passwords when they are needed while limiting the risk of attack. The
64 user of this program inputs a self-defined transformation of a web
65 site URL and obtains the password and user name hint for that web
66 site.")
67 (license gpl3+)))