gnu: libretro-lowresnx: Update to 1.2.
[jackhill/guix/guix.git] / gnu / packages / flex.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012, 2013, 2014, 2019 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages flex)
21 #:use-module (guix licenses)
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (guix build-system gnu)
25 #:use-module (guix utils)
26 #:use-module (gnu packages)
27 #:use-module (gnu packages m4)
28 #:use-module (gnu packages man)
29 #:use-module (gnu packages bison)
30 #:use-module (srfi srfi-1))
31
32 (define-public flex
33 (package
34 (name "flex")
35 (version "2.6.4")
36 (source (origin
37 (method url-fetch)
38 (uri (string-append
39 "https://github.com/westes/flex"
40 "/releases/download/v" version "/"
41 "flex-" version ".tar.gz"))
42 (sha256
43 (base32
44 "15g9bv236nzi665p9ggqjlfn4dwck5835vf0bbw2cz7h5c1swyp8"))))
45 (build-system gnu-build-system)
46 (inputs
47 (let ((bison-for-tests
48 (package
49 (inherit bison)
50 (arguments
51 ;; Disable tests, since they require flex.
52 (substitute-keyword-arguments (package-arguments bison)
53 ((#:tests? _ #f) #f)))
54 (inputs (alist-delete "flex" (package-inputs bison))))))
55 `(("bison" ,bison-for-tests))))
56 ;; m4 is not present in PATH when cross-building
57 (native-inputs
58 `(("help2man" ,help2man)
59 ("m4" ,m4)))
60 (propagated-inputs `(("m4" ,m4)))
61 (home-page "https://github.com/westes/flex")
62 (synopsis "Fast lexical analyser generator")
63 (description
64 "Flex is a tool for generating scanners. A scanner, sometimes
65 called a tokenizer, is a program which recognizes lexical patterns in
66 text. The flex program reads user-specified input files, or its standard
67 input if no file names are given, for a description of a scanner to
68 generate. The description is in the form of pairs of regular expressions
69 and C code, called rules. Flex generates a C source file named,
70 \"lex.yy.c\", which defines the function yylex(). The file \"lex.yy.c\"
71 can be compiled and linked to produce an executable. When the executable
72 is run, it analyzes its input for occurrences of text matching the
73 regular expressions for each rule. Whenever it finds a match, it
74 executes the corresponding C code.")
75 (license (non-copyleft "file://COPYING"
76 "See COPYING in the distribution."))))