gnu: libretro-lowresnx: Update to 1.2.
[jackhill/guix/guix.git] / gnu / packages / ed.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
3 ;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
4 ;;; Copyright © 2016, 2019 Efraim Flashner <efraim@flashner.co.il>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages ed)
22 #:use-module (guix licenses)
23 #:use-module (guix packages)
24 #:use-module (guix download)
25 #:use-module (guix build-system gnu)
26 #:use-module (gnu packages compression))
27
28 (define-public ed
29 (package
30 (name "ed")
31 (version "1.16")
32 (source (origin
33 (method url-fetch)
34 (uri (string-append "mirror://gnu/ed/ed-"
35 version ".tar.lz"))
36 (sha256
37 (base32
38 "0b4b1lwizvng9bvpcjnmpj2i80xz9xw2w8nfff27b2h4mca7mh6g"))))
39 (build-system gnu-build-system)
40 (native-inputs `(("lzip" ,lzip)))
41 (arguments
42 '(#:configure-flags '("CC=gcc")
43 #:phases
44 (modify-phases %standard-phases
45 (add-before 'patch-source-shebangs 'patch-test-suite
46 (lambda _
47 (substitute* "testsuite/check.sh"
48 (("/bin/sh") (which "sh")))
49 #t)))))
50 (home-page "https://www.gnu.org/software/ed/")
51 (synopsis "Line-oriented text editor")
52 (description
53 "Ed is a line-oriented text editor: rather than offering an overview of
54 a document, ed performs editing one line at a time. It can be executed both
55 interactively and via shell scripts. Its method of command input allows
56 complex tasks to be performed in an automated way. GNU ed offers several
57 extensions over the standard utility.")
58 (license gpl3+)))