gnu: libretro-lowresnx: Update to 1.2.
[jackhill/guix/guix.git] / gnu / packages / dunst.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015, 2017, 2018 Alex Kost <alezost@gmail.com>
3 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
4 ;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
5 ;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
6 ;;; Copyright © 2021 Alexandru-Sergiu Marton <brown121407@posteo.ro>
7 ;;;
8 ;;; This file is part of GNU Guix.
9 ;;;
10 ;;; GNU Guix is free software; you can redistribute it and/or modify it
11 ;;; under the terms of the GNU General Public License as published by
12 ;;; the Free Software Foundation; either version 3 of the License, or (at
13 ;;; your option) any later version.
14 ;;;
15 ;;; GNU Guix is distributed in the hope that it will be useful, but
16 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
17 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
18 ;;; GNU General Public License for more details.
19 ;;;
20 ;;; You should have received a copy of the GNU General Public License
21 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
22
23 (define-module (gnu packages dunst)
24 #:use-module (guix packages)
25 #:use-module (guix git-download)
26 #:use-module (guix build-system gnu)
27 #:use-module (guix utils)
28 #:use-module ((guix licenses) #:prefix license:)
29 #:use-module (gnu packages base)
30 #:use-module (gnu packages freedesktop)
31 #:use-module (gnu packages glib)
32 #:use-module (gnu packages gnome)
33 #:use-module (gnu packages gtk)
34 #:use-module (gnu packages perl)
35 #:use-module (gnu packages pkg-config)
36 #:use-module (gnu packages xorg))
37
38 (define-public dunst
39 (package
40 (name "dunst")
41 (version "1.6.1")
42 (source (origin
43 (method git-fetch)
44 (uri (git-reference
45 (url "https://github.com/dunst-project/dunst")
46 (commit (string-append "v" version))))
47 (file-name (git-file-name name version))
48 (sha256
49 (base32
50 "0lga1kj2vjbj9g9rl93nivngjmk5fkxdxwal8w96x9whwk9jvdga"))))
51 (build-system gnu-build-system)
52 (arguments
53 `(#:tests? #f ; no check target
54 #:make-flags (list (string-append "CC=" ,(cc-for-target))
55 (string-append "PREFIX=" %output)
56 (string-append "SYSCONFDIR=" %output "/etc")
57 ;; Otherwise it tries to install service file
58 ;; to "dbus" store directory.
59 (string-append "SERVICEDIR_DBUS=" %output
60 "/share/dbus-1/services")
61 "dunstify")
62 #:phases (modify-phases %standard-phases
63 (delete 'configure))))
64 (native-inputs
65 `(("pkg-config" ,pkg-config)
66 ("perl" ,perl) ; for pod2man
67 ("which" ,which)))
68 (inputs
69 `(("dbus" ,dbus)
70 ("gdk-pixbuf" ,gdk-pixbuf+svg) ; for svg support
71 ("glib" ,glib)
72 ("cairo" ,cairo)
73 ("pango" ,pango)
74 ("libnotify" ,libnotify) ; for dunstify
75 ("libx11" ,libx11)
76 ("libxscrnsaver" ,libxscrnsaver)
77 ("libxinerama" ,libxinerama)
78 ("libxrandr" ,libxrandr)
79 ("libxdg-basedir" ,libxdg-basedir)
80 ("wayland" ,wayland))) ; for wayland support
81 (home-page "https://dunst-project.org/")
82 (synopsis "Customizable and lightweight notification daemon")
83 (description
84 "Dunst is a highly configurable and minimalistic notification daemon.
85 It provides @code{org.freedesktop.Notifications} D-Bus service, so it is
86 started automatically on the first call via D-Bus.")
87 (license license:bsd-3)))