gnu: conkey: Update to 1.11.2.
[jackhill/guix/guix.git] / gnu / packages / conky.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Siniša Biđin <sinisa@bidin.eu>
3 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
4 ;;; Copyright © 2019 Pierre Neidhardt <mail@ambrevar.xyz>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages conky)
22 #:use-module (guix packages)
23 #:use-module (guix utils)
24 #:use-module (guix download)
25 #:use-module (guix git-download)
26 #:use-module (guix build-system cmake)
27 #:use-module ((guix licenses) #:prefix license:)
28 #:use-module (gnu packages curl)
29 #:use-module (gnu packages fontutils)
30 #:use-module (gnu packages image)
31 #:use-module (gnu packages lua)
32 #:use-module (gnu packages ncurses)
33 #:use-module (gnu packages pkg-config)
34 #:use-module (gnu packages xorg))
35
36 (define-public conky
37 (package
38 (name "conky")
39 (home-page "https://github.com/brndnmtthws/conky")
40 (version "1.11.2")
41 (source
42 (origin
43 (method git-fetch)
44 (uri (git-reference
45 (url home-page)
46 (commit (string-append "v" version))))
47 (file-name (string-append name "-" version ".tar.gz"))
48 (sha256
49 (base32 "0yalcpwx85smh6nnvxxsgqi344nk7jzlkkam7yjghm87df4v7xmx"))))
50 (build-system cmake-build-system)
51 (arguments
52 `(#:tests? #f ; there are no tests
53 #:configure-flags
54 (list "-DRELEASE=true")
55 #:phases
56 (modify-phases %standard-phases
57 (add-after 'unpack 'add-freetype-to-search-path
58 (lambda* (#:key inputs #:allow-other-keys)
59 (substitute* "cmake/ConkyPlatformChecks.cmake"
60 (("set\\(INCLUDE_SEARCH_PATH")
61 (string-append
62 "set(INCLUDE_SEARCH_PATH "
63 (assoc-ref inputs "freetype") "/include/freetype2 ")))
64 #t))
65 (replace 'install
66 (lambda* (#:key outputs #:allow-other-keys)
67 (let* ((out (assoc-ref outputs "out"))
68 (bin (string-append out "/bin")))
69 (install-file "src/conky" bin))
70 #t)))))
71 (inputs
72 `(("freetype" ,freetype)
73 ("imlib2" ,imlib2)
74 ("libx11" ,libx11)
75 ("libxdamage" ,libxdamage)
76 ("libxext" ,libxext)
77 ("libxft" ,libxft)
78 ("libxinerama" ,libxinerama)
79 ("lua" ,lua)
80 ("ncurses" ,ncurses)
81 ("curl" ,curl)))
82 (native-inputs
83 `(("pkg-config" ,pkg-config)))
84 (synopsis "Lightweight system monitor for X")
85 (description
86 "Conky is a lightweight system monitor for X that displays operating
87 system statistics (CPU, disk, and memory usage, etc.) and more on the
88 desktop.")
89 (license license:gpl3+)))