gnu: libdvdcss: Update to 1.4.3.
[jackhill/guix/guix.git] / gnu / packages / uucp.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages uucp)
20 #:use-module (guix licenses)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu))
24
25 (define-public uucp
26 (package
27 (name "uucp")
28 (version "1.07")
29 (source (origin
30 (method url-fetch)
31 (uri (string-append "mirror://gnu/uucp/uucp-"
32 version ".tar.gz"))
33 (sha256
34 (base32
35 "0b5nhl9vvif1w3wdipjsk8ckw49jj1w85xw1mmqi3zbcpazia306"))))
36 (build-system gnu-build-system)
37 (arguments
38 '(#:phases
39 (modify-phases %standard-phases
40 (replace 'configure
41 (lambda* (#:key outputs #:allow-other-keys)
42 ;; The old 'configure' script doesn't support the arguments
43 ;; that we pass by default.
44 (setenv "CONFIG_SHELL" (which "sh"))
45 (let ((out (assoc-ref outputs "out")))
46 (invoke "./configure"
47 (string-append "--prefix=" out)
48 (string-append "--infodir=" out
49 "/share/info"))))))))
50 (home-page "https://www.gnu.org/software/uucp/uucp.html")
51 (synopsis "UUCP protocol implementation")
52 (description
53 "Taylor UUCP is the GNU implementation of UUCP (Unix-to-Unix Copy), a
54 set of utilities for remotely transferring files, email and net news
55 between computers.")
56 (license gpl2+)))