gnu: libdvdcss: Update to 1.4.3.
[jackhill/guix/guix.git] / gnu / packages / unrtf.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2015 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
4 ;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages unrtf)
22 #:use-module (guix licenses)
23 #:use-module (guix packages)
24 #:use-module (guix download)
25 #:use-module (guix build-system gnu)
26 #:use-module (guix gexp)
27 #:use-module (gnu packages)
28 #:use-module (gnu packages autotools)
29 #:use-module (gnu packages m4)
30 #:use-module (gnu packages base))
31
32 (define-public unrtf
33 (package
34 (name "unrtf")
35 (version "0.21.10")
36 (source (origin
37 (method url-fetch)
38 (uri (string-append "mirror://gnu/unrtf/unrtf-"
39 version ".tar.gz"))
40 (sha256
41 (base32
42 "1bil6z4niydz9gqm2j861dkxmqnpc8m7hvidsjbzz7x63whj17xl"))))
43 (build-system gnu-build-system)
44 (home-page "https://www.gnu.org/software/unrtf/")
45 (synopsis "Convert Rich Text Format documents to other formats")
46 (description
47 "GNU UnRTF converts text documents from RTF to HTML, LaTeX, or troff.
48 It supports changes in font characteristics, underlines and strikethroughs,
49 superscripts and subscripts, and more.")
50 (license gpl3+)))