gnu: libdvdcss: Update to 1.4.3.
[jackhill/guix/guix.git] / gnu / packages / terraform.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2018 Christopher Baines <mail@cbaines.net>
3 ;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages terraform)
21 #:use-module ((guix licenses) #:prefix license:)
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (guix git-download)
25 #:use-module (guix build-system go))
26
27 (define-public terraform-docs
28 (package
29 (name "terraform-docs")
30 (version "0.6.0")
31 (source (origin
32 (method git-fetch)
33 (uri (git-reference
34 (url "https://github.com/segmentio/terraform-docs")
35 (commit (string-append "v" version))))
36 (file-name (git-file-name name version))
37 (sha256
38 (base32
39 "1p6prhjf82qnhf1zwl9h92j4ds5g383a6g9pwwnqbc3wdwy5zx7d"))))
40 (build-system go-build-system)
41 (arguments
42 '(#:import-path "github.com/segmentio/terraform-docs"))
43 (synopsis "Generate documentation from Terraform modules")
44 (description
45 "The @code{terraform-docs} utility can generate documentation describing
46 the inputs and outputs for modules of the Terraform infrastructure management
47 tool. These can be shown, or written to a file in JSON or Markdown formats.")
48 (home-page "https://github.com/segmentio/terraform-docs")
49 (license license:expat)))