gnu: libdvdcss: Update to 1.4.3.
[jackhill/guix/guix.git] / gnu / packages / rush.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2016 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages rush)
20 #:use-module (guix packages)
21 #:use-module (guix download)
22 #:use-module (guix build-system gnu)
23 #:use-module (guix licenses)
24 #:use-module (gnu packages))
25
26 (define-public rush
27 (package
28 (name "rush")
29 (version "2.1")
30 (source (origin
31 (method url-fetch)
32 (uri (string-append "mirror://gnu/rush/rush-"
33 version ".tar.gz"))
34 (sha256
35 (base32
36 "17i4mggr3rnfz0xbhqvd86jqva40c535fhlwkb2l4hjcbpg8blcf"))))
37 (build-system gnu-build-system)
38 (home-page "https://www.gnu.org/software/rush/")
39 (synopsis "Restricted user (login) shell")
40 (description
41 "GNU Rush is a restricted user shell, for systems on which users are to
42 be provided with only limited functionality or resources. Administrators set
43 user rights via a configuration file which can be used to limit, for example,
44 the commands that can be executed, CPU time, or virtual memory usage.")
45 (license gpl3+)))