gnu: libdvdcss: Update to 1.4.3.
[jackhill/guix/guix.git] / gnu / packages / pumpio.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 David Thompson <davet@gnu.org>
3 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
4 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages pumpio)
22 #:use-module (guix licenses)
23 #:use-module (guix packages)
24 #:use-module (guix download)
25 #:use-module (guix git-download)
26 #:use-module (guix build-system gnu)
27 #:use-module (gnu packages aspell)
28 #:use-module (gnu packages qt)
29 #:use-module (gnu packages web))
30
31 (define-public pumpa
32 (package
33 (name "pumpa")
34 (version "0.9.3")
35 (source (origin
36 (method git-fetch) ; no source tarballs
37 (uri (git-reference
38 (url "git://pumpa.branchable.com/")
39 (commit (string-append "v" version))))
40 (sha256
41 (base32
42 "14072vis539zjgryjr5a77j2cprxii5znyg3p01qbb11lijk9nj7"))
43 (file-name (string-append name "-" version "-checkout"))))
44 (build-system gnu-build-system)
45 (arguments
46 '(#:phases
47 (modify-phases %standard-phases
48 (replace 'configure
49 (lambda* (#:key inputs outputs #:allow-other-keys)
50 ;; Fix dependency tests.
51 (substitute* "pumpa.pro"
52 (("/usr/include/tidy\\.h")
53 (string-append (assoc-ref inputs "tidy")
54 "/include/tidy.h"))
55 (("/usr/include/aspell.h")
56 (string-append (assoc-ref inputs "aspell")
57 "/include/aspell.h")))
58 ;; Run qmake with proper installation prefix.
59 (let ((prefix (string-append "PREFIX="
60 (assoc-ref outputs "out"))))
61 (invoke "qmake" prefix))
62 #t)))))
63 (inputs
64 `(("aspell" ,aspell)
65 ("qtbase" ,qtbase)
66 ("tidy" ,tidy)))
67 (synopsis "Qt-based pump.io client")
68 (description "Pumpa is a simple pump.io client written in C++ and Qt.")
69 (home-page "https://pumpa.branchable.com/")
70 (license gpl3+)))