gnu: libdvdcss: Update to 1.4.3.
[jackhill/guix/guix.git] / gnu / packages / perl-web.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
3 ;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages perl-web)
21 #:use-module ((guix licenses) #:prefix license:)
22 #:use-module (gnu packages)
23 #:use-module (guix packages)
24 #:use-module (gnu packages perl)
25 #:use-module (gnu packages perl-check)
26 #:use-module (guix download)
27 #:use-module (guix build-system perl)
28 #:use-module (gnu packages web))
29
30 (define-public perl-mojolicious
31 (package
32 (name "perl-mojolicious")
33 (version "7.59")
34 (source
35 (origin
36 (method url-fetch)
37 (uri (string-append "mirror://cpan/authors/id/S/SR/SRI/Mojolicious-"
38 version ".tar.gz"))
39 (sha256
40 (base32
41 "11whfrbafj191ahbhlhadws0vkg9kmvqswzkvswgwajhr1x678rh"))))
42 (build-system perl-build-system)
43 (home-page "https://mojolicious.org/")
44 (synopsis "Real-time web framework")
45 (description "Back in the early days of the web, many people learned Perl
46 because of a wonderful Perl library called @code{CGI}. It was simple enough
47 to get started without knowing much about the language and powerful enough to
48 keep you going, learning by doing was much fun. While most of the techniques
49 used are outdated now, the idea behind it is not. Mojolicious is a new
50 endeavor to implement this idea using modern technologies.")
51 (license license:artistic2.0)))
52
53 (define-public perl-uri-db
54 (package
55 (name "perl-uri-db")
56 (version "0.19")
57 (source
58 (origin
59 (method url-fetch)
60 (uri (string-append
61 "mirror://cpan/authors/id/D/DW/DWHEELER/URI-db-"
62 version
63 ".tar.gz"))
64 (sha256
65 (base32
66 "0n56xxlw7c39pfar0dxckr9mbmp6yrzk53ic0cb24raiykm9v6f4"))))
67 (build-system perl-build-system)
68 (native-inputs
69 `(("perl-module-build" ,perl-module-build)))
70 (propagated-inputs
71 `(("perl-uri" ,perl-uri)
72 ("perl-uri-nested" ,perl-uri-nested)))
73 (home-page "https://metacpan.org/release/URI-db")
74 (synopsis "Handle database URIs")
75 (description
76 "This module defines a format for database URIs, and provides a @{URI}
77 class to handle these.")
78 (license license:perl-license)))
79
80 (define-public perl-uri-escape
81 (package
82 (name "perl-uri-escape")
83 (version "1.76")
84 (source
85 (origin
86 (method url-fetch)
87 (uri (string-append "mirror://cpan/authors/id/O/OA/OALDERS/URI-"
88 version ".tar.gz"))
89 (sha256
90 (base32
91 "0gj1aj18k43kmzc3y1zhj5giinf8rksacf757r475xfna0fqxjdj"))))
92 (build-system perl-build-system)
93 (native-inputs
94 `(("perl-test-needs" ,perl-test-needs)))
95 (home-page "https://github.com/libwww-perl/URI")
96 (synopsis "Percent-encode and percent-decode unsafe characters")
97 (description "This module provides functions to percent-encode and
98 percent-decode URI strings as defined by RFC 3986. Percent-encoding URI's is
99 informally called URI escaping. This is the terminology used by this module,
100 which predates the formalization of the terms by the RFC by several years.")
101 (license license:perl-license)))
102
103 (define-public perl-uri-nested
104 (package
105 (name "perl-uri-nested")
106 (version "0.10")
107 (source
108 (origin
109 (method url-fetch)
110 (uri (string-append
111 "mirror://cpan/authors/id/D/DW/DWHEELER/URI-Nested-"
112 version
113 ".tar.gz"))
114 (sha256
115 (base32
116 "1bzg6f11m8wfnmycflvp858rs99xknsx8hkip0xcdfjzlqwi75z1"))))
117 (build-system perl-build-system)
118 (native-inputs
119 `(("perl-module-build" ,perl-module-build)))
120 (propagated-inputs
121 `(("perl-uri" ,perl-uri)))
122 (home-page "https://metacpan.org/release/URI-Nested")
123 (synopsis "Nested URIs")
124 (description
125 "@code{URI::Nested} provides support for nested URIs, where the scheme is
126 a prefix, and the remainder of the URI is another URI.")
127 (license license:perl-license)))