gnu: libdvdcss: Update to 1.4.3.
[jackhill/guix/guix.git] / gnu / packages / musl.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2016 Vincent Legoll <vincent.legoll@gmail.com>
3 ;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
4 ;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages musl)
22 #:use-module (guix download)
23 #:use-module (guix packages)
24 #:use-module (guix build-system gnu)
25 #:use-module ((guix licenses) #:prefix license:)
26 #:use-module (gnu packages))
27
28 (define-public musl
29 (package
30 (name "musl")
31 (version "1.2.2")
32 (source (origin
33 (method url-fetch)
34 (uri (string-append "https://www.musl-libc.org/releases/"
35 "musl-" version ".tar.gz"))
36 (sha256
37 (base32
38 "1p8r6bac64y98ln0wzmnixysckq3crca69ys7p16sy9d04i975lv"))))
39 (build-system gnu-build-system)
40 (arguments
41 `(#:tests? #f ; musl has no tests
42 #:configure-flags
43 (list "--disable-gcc-wrapper")))
44 (synopsis "Small C standard library")
45 (description "musl is a simple and lightweight C standard library. It
46 strives to be correct in the sense of standards-conformance and safety.")
47 (home-page "https://musl.libc.org")
48 ;; Musl as a whole is released under the Expat license. Parts of it are
49 ;; derived from various third-party projects that are released under
50 ;; non-copyleft licenses. See the COPYRIGHT file for details.
51 (license license:expat)))