gnu: libdvdcss: Update to 1.4.3.
[jackhill/guix/guix.git] / gnu / packages / freeipmi.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2015, 2016, 2017, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
4 ;;; Copyright © 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages freeipmi)
22 #:use-module (guix packages)
23 #:use-module (guix licenses)
24 #:use-module (guix download)
25 #:use-module (guix build-system gnu)
26 #:use-module (gnu packages gnupg))
27
28 (define-public freeipmi
29 (package
30 (name "freeipmi")
31 (version "1.6.7")
32 (source (origin
33 (method url-fetch)
34 (uri (string-append "mirror://gnu/freeipmi/freeipmi-"
35 version ".tar.gz"))
36 (sha256
37 (base32
38 "1gyyx99q02p3v2nqm3h53mkjd33l0hrapwg4alg6qr9k74qik1dv"))))
39 (build-system gnu-build-system)
40 (arguments
41 '(#:configure-flags '("--disable-static")))
42 (inputs
43 `(("libgcrypt" ,libgcrypt)))
44 (home-page "https://www.gnu.org/software/freeipmi/")
45 (synopsis "Platform management, including sensor and power monitoring")
46 (description
47 "GNU FreeIPMI is a collection of in-band and out-of-band IPMI software
48 in accordance with the IPMI v1.5/2.0 specification. These programs provide a
49 set of interfaces for platform management. Common functionality includes
50 sensor monitoring, system event monitoring, power control and
51 serial-over-LAN.")
52 (license gpl3+)))