gnu: libdvdcss: Update to 1.4.3.
[jackhill/guix/guix.git] / gnu / packages / distributed.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2019 Brant Gardner <brantcgardner@brantware.com>
3 ;;; Copyright © 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
4 ;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages distributed)
22 #:use-module (guix packages)
23 #:use-module (guix utils)
24 #:use-module (guix download)
25 #:use-module (guix git-download)
26 #:use-module (guix build-system gnu)
27 #:use-module ((guix licenses) #:prefix license:)
28 #:use-module (gnu packages)
29 #:use-module (gnu packages autotools)
30 #:use-module (gnu packages base)
31 #:use-module (gnu packages compression)
32 #:use-module (gnu packages databases)
33 #:use-module (gnu packages pkg-config)
34 #:use-module (gnu packages tls)
35 #:use-module (gnu packages curl)
36 #:use-module (gnu packages wxwidgets)
37 #:use-module (gnu packages gnome)
38 #:use-module (gnu packages gtk)
39 #:use-module (gnu packages perl)
40 #:use-module (gnu packages sqlite)
41 #:use-module (gnu packages python)
42 #:use-module (gnu packages python-xyz))
43
44 (define-public boinc-client
45 (package
46 (name "boinc-client")
47 (version "7.16.6")
48 (source (origin
49 (method git-fetch)
50 (uri (git-reference
51 (url "https://github.com/boinc/boinc")
52 (commit (string-append "client_release/"
53 (version-major+minor version)
54 "/" version))))
55 (file-name (git-file-name "boinc" version))
56 (sha256
57 (base32
58 "00xpzxxnki9hsf2vg9p67dk9ilw9ychpgm09fp3c41zyylb33ml5"))))
59 (build-system gnu-build-system)
60 (arguments '(#:configure-flags '("--disable-server")))
61 (inputs `(("openssl" ,openssl)
62 ("curl" ,curl)
63 ("wxwidgets" ,wxwidgets)
64 ("gtk+" ,gtk+)
65 ("gdk-pixbuf" ,gdk-pixbuf)
66 ("libnotify" ,libnotify)
67 ("sqlite" ,sqlite)
68 ("python" ,python)
69 ("python-pyserial" ,python-pyserial)))
70 (native-inputs
71 `(("autoconf" ,autoconf)
72 ("automake" ,automake)
73 ("libtool" ,libtool)
74 ("pkg-config" ,pkg-config)))
75 (synopsis "Help cutting-edge science research using your computer")
76 (description "BOINC is a platform for high-throughput computing on a large
77 scale (thousands or millions of computers). It can be used for volunteer
78 computing (using consumer devices) or grid computing (using organizational
79 resources). It supports virtualized, parallel, and GPU-based applications.")
80 (home-page "https://boinc.berkeley.edu/")
81 ;; BOINC is distributed as LGPL3+, with some individual modules under GPL3+.
82 (license (list license:lgpl3+ license:gpl3+))))
83
84 (define-public boinc-server
85 (package (inherit boinc-client)
86 (name "boinc-server")
87 (arguments '(#:configure-flags '("--disable-client" "--disable-manager")
88 #:parallel-build? #f
89 #:tests? #f)) ; FIXME: Looks like bad test syntax in the
90 ; source package, 2 tests fail. Disable for
91 ; now.
92 (inputs `(("openssl" ,openssl)
93 ("curl" ,curl)
94 ("mariadb:dev" ,mariadb "dev")
95 ("zlib" ,zlib)))
96 (propagated-inputs `(("python" ,python-wrapper)
97 ("perl" ,perl)))))