gnu: libdvdcss: Update to 1.4.3.
[jackhill/guix/guix.git] / gnu / packages / dav.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015, 2016, 2017 Leo Famulari <leo@famulari.name>
3 ;;; Copyright © 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
4 ;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
5 ;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
6 ;;;
7 ;;; This file is part of GNU Guix.
8 ;;;
9 ;;; GNU Guix is free software; you can redistribute it and/or modify it
10 ;;; under the terms of the GNU General Public License as published by
11 ;;; the Free Software Foundation; either version 3 of the License, or (at
12 ;;; your option) any later version.
13 ;;;
14 ;;; GNU Guix is distributed in the hope that it will be useful, but
15 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
16 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
17 ;;; GNU General Public License for more details.
18 ;;;
19 ;;; You should have received a copy of the GNU General Public License
20 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
21
22 (define-module (gnu packages dav)
23 #:use-module (guix build-system python)
24 #:use-module (guix download)
25 #:use-module (guix licenses)
26 #:use-module (guix packages)
27 #:use-module (guix git-download)
28 #:use-module (gnu packages)
29 #:use-module (gnu packages check)
30 #:use-module (gnu packages python)
31 #:use-module (gnu packages python-check)
32 #:use-module (gnu packages python-crypto)
33 #:use-module (gnu packages python-web)
34 #:use-module (gnu packages python-xyz)
35 #:use-module (gnu packages sphinx)
36 #:use-module (gnu packages time)
37 #:use-module (gnu packages xml))
38
39 (define-public radicale
40 (package
41 (name "radicale")
42 (version "3.0.6")
43 (source
44 (origin
45 ;; There are no tests in the PyPI tarball.
46 (method git-fetch)
47 (uri (git-reference
48 (url "https://github.com/Kozea/Radicale")
49 (commit version)))
50 (file-name (git-file-name name version))
51 (sha256
52 (base32 "1xlsvrmx6jhi71j6j8z9sli5vwxasivzjyqf8zq8r0l5p7350clf"))))
53 (build-system python-build-system)
54 (native-inputs
55 `(("python-pytest" ,python-pytest)
56 ("python-pytest-cov" ,python-pytest-cov)
57 ("python-pytest-flake8" ,python-pytest-flake8)
58 ("python-pytest-isort" ,python-pytest-isort)
59 ("python-pytest-runner" ,python-pytest-runner)
60 ("python-waitress" ,python-waitress)))
61 (propagated-inputs
62 `(("python-dateutil" ,python-dateutil)
63 ("python-defusedxml" ,python-defusedxml)
64 ("python-passlib" ,python-passlib)
65 ("python-vobject" ,python-vobject)))
66 (synopsis "Basic CalDAV and CardDAV server")
67 (description "Radicale is a CalDAV and CardDAV server for UNIX-like
68 platforms. Calendars and address books are available for both local and remote
69 access, possibly limited through authentication policies. They can be viewed
70 and edited by calendar and contact clients on mobile phones or computers.
71
72 Radicale intentionally does not fully comply with the CalDAV and CardDAV RFCs.
73 Instead, it supports the CalDAV and CardDAV implementations of popular
74 clients.")
75 (home-page "https://radicale.org/")
76 (license gpl3+)))
77
78 (define-public xandikos
79 (package
80 (name "xandikos")
81 (version "0.2.3")
82 (source
83 (origin
84 (method url-fetch)
85 (uri (pypi-uri "xandikos" version))
86 (sha256
87 (base32 "13ikmcja9p42azb5ccqj2bw98zybna6zlflj10hqy0kvbib70l94"))))
88 (build-system python-build-system)
89 (propagated-inputs
90 `(("python-aiohttp" ,python-aiohttp)
91 ("python-defusedxml" ,python-defusedxml)
92 ("python-dulwich" ,python-dulwich)
93 ("python-icalendar" ,python-icalendar)
94 ("python-jinja2" ,python-jinja2)
95 ("python-multidict" ,python-multidict)))
96 (home-page "https://www.xandikos.org/")
97 (synopsis "Lightweight CalDAV/CardDAV server")
98 (description
99 "Xandikos is a lightweight yet complete CardDAV/CalDAV server that backs
100 onto a Git repository.
101
102 Features:
103
104 @itemize
105 @item Easy to set up
106 @item Share calendars (events, todo items, journal entries) via CalDAV and
107 contacts (vCard) via CardDAV
108 @item Automatically keep history and back up changes in Git
109 @item Supports synchronization extensions for CalDAV/CardDAV for quick and
110 efficient syncing
111 @item Automatically keep history and back up
112 @item Works with all tested CalDAV and CardDAV clients
113 @end itemize")
114 (license gpl3+)))
115
116 (define-public vdirsyncer
117 (package
118 (name "vdirsyncer")
119 ;; When updating, check whether python-click-5 can be removed entirely.
120 (version "0.16.8")
121 (source (origin
122 (method url-fetch)
123 (uri (pypi-uri name version))
124 (sha256
125 (base32
126 "1i8kp9j99rs8xdhrc1vx749zd9wznlzj0pb3s05xdm71a8pl5nxz"))))
127 (build-system python-build-system)
128 (arguments
129 `(#:tests? #f ; The test suite is very flakey.
130 #:phases (modify-phases %standard-phases
131 (replace 'check
132 (lambda* (#:key inputs outputs tests? #:allow-other-keys)
133 (add-installed-pythonpath inputs outputs)
134 (setenv "DETERMINISTIC_TESTS" "true")
135 (setenv "DAV_SERVER" "radicale")
136 (setenv "REMOTESTORAGE_SERVER" "skip")
137 (if tests?
138 (invoke "make" "test")
139 #t)))
140 (add-after 'unpack 'patch-version-call
141 (lambda _
142 (substitute* "docs/conf.py"
143 (("^release.*") (string-append "release = '" ,version "'\n")))
144 #t))
145 (add-after 'install 'manpage
146 (lambda* (#:key inputs outputs #:allow-other-keys)
147 (invoke "make" "--directory=docs/" "man")
148 (install-file
149 "docs/_build/man/vdirsyncer.1"
150 (string-append
151 (assoc-ref outputs "out")
152 "/share/man/man1"))
153 #t)))))
154 (native-inputs
155 `(("python-setuptools-scm" ,python-setuptools-scm)
156 ("python-sphinx" ,python-sphinx)
157 ;; Required for testing
158 ("python-hypothesis" ,python-hypothesis)
159 ("python-pytest" ,python-pytest)
160 ("python-pytest-localserver" ,python-pytest-localserver)
161 ("python-pytest-subtesthack" ,python-pytest-subtesthack)
162 ("python-urllib3" ,python-urllib3)
163 ("python-wsgi-intercept" ,python-wsgi-intercept)
164 ("radicale" ,radicale)))
165 (inputs
166 `(;; XXX https://github.com/mitsuhiko/click/issues/200
167 ("python-click" ,python-click-5)))
168 (propagated-inputs
169 `(("python-atomicwrites" ,python-atomicwrites)
170 ("python-click-log" ,python-click-log)
171 ("python-click-threading" ,python-click-threading)
172 ("python-requests-toolbelt" ,python-requests-toolbelt)))
173 (synopsis "Synchronize calendars and contacts")
174 (description "Vdirsyncer synchronizes your calendars and addressbooks
175 between two storage locations. The most popular purpose is to
176 synchronize a CalDAV or CardDAV server with a local folder or file. The
177 local data can then be accessed via a variety of programs, none of which
178 have to know or worry about syncing to a server.")
179 (home-page "https://github.com/pimutils/vdirsyncer")
180 (license bsd-3)))