gnu: libdvdcss: Update to 1.4.3.
[jackhill/guix/guix.git] / gnu / packages / datamash.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014, 2018 Eric Bavier <bavier@member.fsf.org>
3 ;;; Copyright © 2016, 2017, 2018, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages datamash)
21 #:use-module (guix packages)
22 #:use-module (guix licenses)
23 #:use-module (guix download)
24 #:use-module (guix build-system gnu)
25 #:use-module (gnu packages)
26 #:use-module (gnu packages perl)
27 #:use-module (gnu packages base))
28
29 (define-public datamash
30 (package
31 (name "datamash")
32 (version "1.7")
33 (source
34 (origin
35 (method url-fetch)
36 (uri (string-append "mirror://gnu/datamash/datamash-"
37 version ".tar.gz"))
38 (sha256
39 (base32
40 "1cxdlhgz3wzjqlq8bgwad93fgqymk2abbldfzw1ffnhcp4mmjjjp"))))
41 (native-inputs
42 `(("which" ,which) ;for tests
43 ("perl" ,perl))) ;for help2man
44 (build-system gnu-build-system)
45 (home-page "https://www.gnu.org/software/datamash/")
46 (synopsis "Scriptable statistics and data calculation")
47 (description
48 "Perform basic numeric, textual and statistical operations on plain text
49 files. Designed to work within standard pipelines without additional code.")
50 (license gpl3+)))