gnu: libdvdcss: Update to 1.4.3.
[jackhill/guix/guix.git] / gnu / packages / cppi.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages cppi)
20 #:use-module (guix packages)
21 #:use-module (guix download)
22 #:use-module (guix build-system gnu)
23 #:use-module (guix licenses))
24
25 (define-public cppi
26 (package
27 (name "cppi")
28 (version "1.18")
29 (source (origin
30 (method url-fetch)
31 (uri (string-append "mirror://gnu/cppi/cppi-"
32 version ".tar.xz"))
33 (sha256
34 (base32
35 "1jk42cjaggk71rimjnx3qpmb6hivps0917vl3z7wbxk3i2whb98j"))))
36 (build-system gnu-build-system)
37 (home-page "https://www.gnu.org/software/cppi/")
38 (synopsis "Indent C preprocessor directives to reflect nesting and more")
39 (description
40 "GNU Cppi processes C source code files to properly indent the
41 preprocessor directives to reflect their nesting. It also performs other
42 standardizations, such as correcting the number of spaces between directives
43 and the text following them.")
44 (license gpl3+)))