gnu: libdvdcss: Update to 1.4.3.
[jackhill/guix/guix.git] / gnu / packages / cpio.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
3 ;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages cpio)
21 #:use-module (guix licenses)
22 #:use-module (gnu packages)
23 #:use-module (gnu packages autotools)
24 #:use-module (guix packages)
25 #:use-module (guix download)
26 #:use-module (guix build-system gnu))
27
28 (define-public cpio
29 (package
30 (name "cpio")
31 (version "2.13")
32 (source (origin
33 (method url-fetch)
34 (uri (string-append "mirror://gnu/cpio/cpio-"
35 version ".tar.bz2"))
36 (sha256
37 (base32
38 "0vbgnhkawdllgnkdn6zn1f56fczwk0518krakz2qbwhxmv2vvdga"))))
39 (build-system gnu-build-system)
40 (home-page "https://www.gnu.org/software/cpio/")
41 (synopsis "Manage cpio and tar file archives")
42 (description
43 "GNU cpio copies files into or out of cpio or tar archives. Indeed,
44 many formats are supported, including legacy formats. The format is
45 determined automatically by the program and is handled appropriately.
46 Furthermore, the location of the archive is not important. It can be another
47 file on the drive, a tape, or data on a pipe.")
48 (license gpl3+)))