gnu: libdvdcss: Update to 1.4.3.
[jackhill/guix/guix.git] / gnu / packages / autogen.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2014 Eric Bavier <bavier@member.fsf.org>
3 ;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
4 ;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
5 ;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
6 ;;;
7 ;;; This file is part of GNU Guix.
8 ;;;
9 ;;; GNU Guix is free software; you can redistribute it and/or modify it
10 ;;; under the terms of the GNU General Public License as published by
11 ;;; the Free Software Foundation; either version 3 of the License, or (at
12 ;;; your option) any later version.
13 ;;;
14 ;;; GNU Guix is distributed in the hope that it will be useful, but
15 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
16 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
17 ;;; GNU General Public License for more details.
18 ;;;
19 ;;; You should have received a copy of the GNU General Public License
20 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
21
22 (define-module (gnu packages autogen)
23 #:use-module (guix packages)
24 #:use-module (guix licenses)
25 #:use-module (guix download)
26 #:use-module (guix build-system gnu)
27 #:use-module (gnu packages)
28 #:use-module (gnu packages perl)
29 #:use-module (gnu packages pkg-config)
30 #:use-module (gnu packages base)
31 #:use-module (gnu packages guile))
32
33 (define-public autogen
34 (package
35 (name "autogen")
36 (version "5.18.16")
37 (source
38 (origin
39 (method url-fetch)
40 (uri (string-append "mirror://gnu/autogen/rel" version
41 "/autogen-" version ".tar.xz"))
42 (sha256
43 (base32 "16mlbdys8q4ckxlvxyhwkdnh1ay9f6g0cyp1kylkpalgnik398gq"))))
44 (build-system gnu-build-system)
45 (native-inputs `(("pkg-config" ,pkg-config)
46 ("which" ,which)))
47 (inputs `(("guile" ,guile-2.2)
48 ("perl" ,perl))) ; for doc generator mdoc
49 (arguments
50 '(#:configure-flags
51 ;; XXX Needed to build 5.18.16. ./configure fails without it:
52 ;; “Something went wrong bootstrapping makefile fragments for
53 ;; automatic dependency tracking. Try re-running configure with […]”
54 (list "--disable-dependency-tracking")
55
56 ;; XXX: Parallel tests may cause an indefinite hang with GNU Make 4.3.
57 #:parallel-tests? #f
58
59 #:phases
60 (modify-phases %standard-phases
61 (add-before 'patch-source-shebangs 'patch-test-scripts
62 (lambda _
63 (let ((sh (which "sh")))
64 (substitute*
65 (append (find-files "agen5/test" "\\.test$")
66 (find-files "autoopts/test" "\\.(test|in)$"))
67 (("/bin/sh") sh))
68 #t))))))
69 (home-page "https://www.gnu.org/software/autogen/")
70 (synopsis "Automated program generator")
71 (description
72 "AutoGen is a program to ease the maintenance of programs that contain
73 large amounts of repetitive text. It automates the construction of these
74 sections of the code, simplifying the task of keeping the text in sync. It
75 also includes an add-on package called AutoOpts, which is specialized for the
76 maintenance and documentation of program options.")
77 (license gpl3+)))