gnu: squirrel: Build from a source archive instead of a Git checkout.
[jackhill/guix/guix.git] / gnu / packages / squirrel.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2019 Li-cheng (Andy) Tai <atai@atai.org>
3 ;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages squirrel)
20 #:use-module (gnu packages)
21 #:use-module (gnu packages cmake)
22 #:use-module (guix build-system cmake)
23 #:use-module (guix download)
24 #:use-module ((guix licenses) #:prefix license:)
25 #:use-module (guix build utils)
26 #:use-module (guix packages)
27 #:use-module (guix utils))
28
29 (define-public squirrel
30 (package
31 (name "squirrel")
32 (version "3.1")
33 (source (origin
34 (method url-fetch)
35 (uri (string-append "mirror://sourceforge/squirrel/squirrel3/"
36 "squirrel " version " stable/squirrel_"
37 (string-join (string-split version #\.) "_")
38 "_stable.tar.gz"))
39 (file-name (string-append name "-" version ".tar.gz"))
40 (sha256
41 (base32
42 "1jyh1523zrrnh9swanfrda0s14mvwc9431dh07g0nx74hbxsfia8"))))
43 (build-system cmake-build-system)
44 (arguments
45 '(#:tests? #f)) ; no tests
46 (native-inputs
47 `(("cmake" ,cmake)))
48 (home-page "https://squirrel-lang.org/")
49 (synopsis "High level imperative, object-oriented programming language")
50 (description
51 "Squirrel is a high level imperative, object-oriented programming
52 language, designed to be a light-weight scripting language that fits in the
53 size, memory bandwidth, and real-time requirements of applications like video
54 games.")
55 (license license:expat)))