Merge branch 'master' into staging
[jackhill/guix/guix.git] / gnu / packages / python-check.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2019 Ricardo Wurmus <rekado@elephly.net>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages python-check)
20 #:use-module (gnu packages)
21 #:use-module (gnu packages check)
22 #:use-module (gnu packages python-web)
23 #:use-module (gnu packages python-xyz)
24 #:use-module (guix utils)
25 #:use-module ((guix licenses) #:prefix license:)
26 #:use-module (guix packages)
27 #:use-module (guix download)
28 #:use-module (guix build-system python))
29
30 (define-public python-coveralls
31 (package
32 (name "python-coveralls")
33 (version "1.5.1")
34 (source
35 (origin
36 (method url-fetch)
37 (uri (pypi-uri "coveralls" version))
38 (sha256
39 (base32
40 "0vfdny96gcq05qk5wxdbfxfaaprdk7c9q2pqvg7ac5l9sf48wqxb"))))
41 (build-system python-build-system)
42 (propagated-inputs
43 `(("python-coverage" ,python-coverage)
44 ("python-docopt" ,python-docopt)
45 ("python-pyyaml" ,python-pyyaml)
46 ("python-requests" ,python-requests)
47 ("python-sh" ,python-sh)
48 ("python-urllib3" ,python-urllib3)))
49 (native-inputs
50 `(("python-mock" ,python-mock)
51 ("python-pytest" ,python-pytest)))
52 (home-page "https://github.com/coveralls-clients/coveralls-python")
53 (synopsis "Show coverage stats online via coveralls.io")
54 (description
55 "Coveralls.io is a service for publishing code coverage statistics online.
56 This package provides seamless integration with coverage.py (and thus pytest,
57 nosetests, etc...) in Python projects.")
58 (license license:expat)))