Merge branch 'master' into staging
[jackhill/guix/guix.git] / gnu / packages / cdrom.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2014, 2015, 2018 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2013, 2014 Andreas Enge <andreas@enge.fr>
4 ;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
5 ;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
6 ;;; Copyright © 2015, 2016, 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
7 ;;; Copyright © 2016 Alex Kost <alezost@gmail.com>
8 ;;; Copyright © 2016 Marius Bakke <mbakke@fastmail.com>
9 ;;; Copyright © 2017 John Darrington <jmd@gnu.org>
10 ;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
11 ;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
12 ;;; Copyright © 2017 Nils Gillmann <ng0@n0.is>
13 ;;; Copyright © 2018 Oleg Pykhalov <go.wigust@gmail.com>
14 ;;; Copyright © 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
15 ;;; Copyright © 2019 Eric Bavier <bavier@member.fsf.org>
16 ;;;
17 ;;; This file is part of GNU Guix.
18 ;;;
19 ;;; GNU Guix is free software; you can redistribute it and/or modify it
20 ;;; under the terms of the GNU General Public License as published by
21 ;;; the Free Software Foundation; either version 3 of the License, or (at
22 ;;; your option) any later version.
23 ;;;
24 ;;; GNU Guix is distributed in the hope that it will be useful, but
25 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
26 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
27 ;;; GNU General Public License for more details.
28 ;;;
29 ;;; You should have received a copy of the GNU General Public License
30 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
31
32 (define-module (gnu packages cdrom)
33 #:use-module (guix download)
34 #:use-module (guix git-download)
35 #:use-module (guix packages)
36 #:use-module ((guix licenses) #:select (lgpl2.1+ gpl2 gpl2+ gpl3+ cddl1.0))
37 #:use-module (guix build-system cmake)
38 #:use-module (guix build-system gnu)
39 #:use-module (guix build-system glib-or-gtk)
40 #:use-module (guix gexp)
41 #:use-module (gnu packages)
42 #:use-module (gnu packages acl)
43 #:use-module (gnu packages audio)
44 #:use-module (gnu packages bison)
45 #:use-module (gnu packages compression)
46 #:use-module (gnu packages flex)
47 #:use-module (gnu packages fontutils)
48 #:use-module (gnu packages gettext)
49 #:use-module (gnu packages docbook)
50 #:use-module (gnu packages xml)
51 #:use-module (gnu packages gtk)
52 #:use-module (gnu packages glib)
53 #:use-module (gnu packages m4)
54 #:use-module (gnu packages man)
55 #:use-module (gnu packages mp3)
56 #:use-module (gnu packages music)
57 #:use-module (gnu packages ncurses)
58 #:use-module (gnu packages elf)
59 #:use-module (gnu packages wxwidgets)
60 #:use-module (gnu packages linux)
61 #:use-module (gnu packages pkg-config)
62 #:use-module (gnu packages readline)
63 #:use-module (gnu packages base)
64 #:use-module (gnu packages perl)
65 #:use-module (gnu packages perl-web)
66 #:use-module (gnu packages python)
67 #:use-module (gnu packages image)
68 #:use-module (gnu packages photo)
69 #:use-module (gnu packages video)
70 #:use-module (gnu packages wget)
71 #:use-module (gnu packages xiph))
72
73 (define-public libcddb
74 (package
75 (name "libcddb")
76 (version "1.3.2")
77 (source (origin
78 (method url-fetch)
79 (uri (string-append "mirror://sourceforge/libcddb/libcddb/" version
80 "/libcddb-" version ".tar.bz2"))
81 (sha256
82 (base32
83 "0fr21a7vprdyy1bq6s99m0x420c9jm5fipsd63pqv8qyfkhhxkim"))))
84 (build-system gnu-build-system)
85 (arguments '(#:tests? #f)) ; tests rely on access to external servers
86 (home-page "http://libcddb.sourceforge.net/")
87 (synopsis "C library to access data on a CDDB server")
88 (description
89 "Libcddb is a C library to access data on a CDDB server (freedb.org). It
90 allows you to:
91
92 1. search the database for possible CD matches;
93
94 2. retrieve detailed information about a specific CD;
95
96 3. submit new CD entries to the database.
97
98 Libcddb supports both the custom CDDB protocol and tunnelling the query and
99 read operations over plain HTTP. It is also possible to use an HTTP proxy
100 server. If you want to speed things up, you can make use of the built-in
101 caching facility provided by the library.")
102 (license lgpl2.1+)))
103
104 (define-public libcdio
105 (package
106 (name "libcdio")
107 (version "2.0.0")
108 (source (origin
109 (method url-fetch)
110 (uri (string-append "mirror://gnu/libcdio/libcdio-"
111 version ".tar.bz2"))
112 (sha256
113 (base32
114 "0jr8ppdm80c533nzmrpz3iffnpc6nhvsria1di9f4jg1l19a03fd"))))
115 (build-system gnu-build-system)
116 (inputs
117 `(("ncurses" ,ncurses)
118 ("libcddb" ,libcddb)))
119 (native-inputs
120 `(("help2man" ,help2man)
121 ("pkg-config" ,pkg-config)))
122 (home-page "https://www.gnu.org/software/libcdio/")
123 (synopsis "CD Input and Control library")
124 (description
125 "The GNU Compact Disc Input and Control Library (libcdio) is a library
126 for CD-ROM and CD image file access. It allows the developer to add CD
127 access to an application without having to worry about the OS- and
128 device-dependent properties of CD-ROM or the specific details of CD image
129 formats. It includes pycdio, a Python interface to libcdio, and
130 libcdio-paranoia, a library providing jitter-free and error-free audio
131 extraction from CDs.")
132 (license gpl3+)))
133
134 (define-public libcdio-paranoia
135 (package
136 (name "libcdio-paranoia")
137 (version "10.2+0.94+2")
138 (source (origin
139 (method url-fetch)
140 (uri (string-append "mirror://gnu/libcdio/libcdio-paranoia-"
141 version ".tar.gz"))
142 (sha256
143 (base32
144 "0h8rr1ir05r29rgawa1ccw335668k4s3zq4yg9095svyx7n843yn"))))
145 (build-system gnu-build-system)
146 (native-inputs `(("pkg-config" ,pkg-config)))
147 (propagated-inputs `(("libcdio" ,libcdio)))
148 (home-page "https://www.gnu.org/software/libcdio/")
149 (synopsis "Jitter- and error-tolerant CD audio extraction")
150 (description
151 "libcdio-paranoia is an implementation of CD paranoia libraries based on
152 libcdio.")
153 (license gpl3+)))
154
155 (define-public xorriso
156 (package
157 (name "xorriso")
158 (version "1.5.0")
159 (source (origin
160 (method url-fetch)
161 (uri (string-append "mirror://gnu/xorriso/xorriso-"
162 version ".tar.gz"))
163 (sha256
164 (base32
165 "0aq6lvlwlkxz56l5sbvgycr6j5c82ch2bv6zrnc2345ibfpafgx9"))))
166 (build-system gnu-build-system)
167 (inputs
168 `(("acl" ,acl)
169 ("readline" ,readline)
170 ("zlib" ,zlib)))
171 (home-page "https://www.gnu.org/software/xorriso/")
172 (synopsis "Create, manipulate, burn ISO-9660 file systems")
173 (description
174 "GNU Xorriso is a tool for copying files to and from ISO 9660 Rock
175 Ridge, a.k.a. Compact Disc File System, file systems and it allows
176 session-wise manipulation of them. It features a formatter and burner for
177 CD, DVD and BD. It can operate on existing ISO images or it can create new
178 ones. xorriso can then be used to copy files directly into or out of ISO
179 files.")
180 (license gpl3+)))
181
182 (define-public cdparanoia
183 (package
184 (name "cdparanoia")
185 (version "10.2")
186 (source (origin
187 (method url-fetch)
188 (uri (string-append "http://downloads.xiph.org/releases/"
189 "cdparanoia/cdparanoia-III-"
190 version ".src.tgz"))
191 (sha256
192 (base32
193 "1pv4zrajm46za0f6lv162iqffih57a8ly4pc69f7y0gfyigb8p80"))
194 (patches (search-patches "cdparanoia-fpic.patch"))
195 (modules '((guix build utils)))
196 (snippet
197 '(begin
198 ;; Make libraries respect LDFLAGS.
199 (substitute* '("paranoia/Makefile.in" "interface/Makefile.in")
200 (("-Wl,-soname") "$(LDFLAGS) -Wl,-soname"))
201 #t))))
202 (build-system gnu-build-system)
203 (arguments
204 `(#:tests? #f ; there is no check target
205 #:configure-flags ; Add $libdir to the RUNPATH of all the executables.
206 (list (string-append "LDFLAGS=-Wl,-rpath=" %output "/lib"))))
207 (home-page "http://www.xiph.org/paranoia/")
208 (synopsis "Audio CD reading utility")
209 (description "Cdparanoia retrieves audio tracks from CDDA capable CDROM
210 drives. The data can be saved to a file or directed to standard output
211 in WAV, AIFF, AIFF-C or raw format. Most ATAPI, SCSI and several
212 proprietary CDROM drive makes are supported; cdparanoia can determine if the
213 target drive is CDDA capable. In addition to simple reading, cdparanoia adds
214 extra-robust data verification, synchronization, error handling and scratch
215 reconstruction capability.")
216 (license gpl2))) ; libraries under lgpl2.1
217
218 (define-public cdrtools
219 (package
220 (name "cdrtools")
221 (version "3.01")
222 (source (origin
223 (method url-fetch)
224 (uri (string-append
225 "mirror://sourceforge/cdrtools/cdrtools-" version ".tar.bz2"))
226 (sha256
227 (base32
228 "03w6ypsmwwy4d7vh6zgwpc60v541vc5ywp8bdb758hbc4yv2wa7d"))
229 (modules '((guix build utils)))
230 (snippet
231 '(begin
232 ;; By default 'cdda2wav --help' would print a string like
233 ;; "Version 3.01_linux_4.19.10-gnu_x86_64_x86_64". Change
234 ;; it to not capture the kernel version of the build
235 ;; machine, to allow for reproducible builds.
236 (substitute* "cdda2wav/local.cnf.in"
237 (("^VERSION_OS=.*")
238 (string-append
239 "actual_os := $(shell uname -o)\n"
240 "actual_arch := $(shell uname -m)\n"
241 "VERSION_OS = _$(actual_os)_$(actual_arch)\n")))
242 #t))
243 (patches (search-patches "cdrtools-3.01-mkisofs-isoinfo.patch"))))
244 (build-system gnu-build-system)
245 ;; XXX cdrtools bundles a modified, relicensed early version of cdparanoia.
246 (inputs
247 `(("linux-headers" ,linux-libre-headers)))
248 (arguments
249 `(#:make-flags
250 (list "RM=rm" "LN=ln" "SYMLINK=ln -s"
251 "CONFIG_SHELL=sh" "CCOM=gcc"
252 (string-append "INS_BASE=" (assoc-ref %outputs "out"))
253 (string-append "INS_RBASE=" (assoc-ref %outputs "out")))
254 #:phases
255 (modify-phases %standard-phases
256 (delete 'configure)
257 (add-before 'build 'set-linux-headers
258 (lambda _
259 (substitute* "autoconf/configure"
260 (("/usr/src/linux")
261 (assoc-ref %build-inputs "linux-headers")))
262 #t))
263 (add-before 'build 'substitute-dirs
264 (lambda _
265 (substitute* (append (find-files "DEFAULTS" "^Defaults\\.")
266 (find-files "DEFAULTS_ENG" "^Defaults\\.")
267 (find-files "TEMPLATES" "^Defaults\\."))
268 (("/opt/schily") (assoc-ref %outputs "out")))
269 #t)))
270 #:tests? #f)) ; no tests
271 (synopsis "Command line utilities to manipulate and burn CD/DVD/BD images")
272 (description "cdrtools is a collection of command line utilities to create
273 CD's, DVD's or Blue Ray discs. The most important components are
274 @command{cdrecord}, a burning program, @command{cdda2wav}, a CD audio ripper
275 which uses libparanoia, and @command{mkisofs}, which can create various disc
276 images.")
277 (home-page "http://cdrtools.sourceforge.net/private/cdrecord.html")
278
279 ;; mkisofs is GPL, the other programs are CDDL.
280 (license (list cddl1.0 gpl2))))
281
282 (define-public dvd+rw-tools
283 (package
284 (name "dvd+rw-tools")
285 (version "7.1")
286 (source (origin
287 (method url-fetch)
288 (uri (string-append
289 "http://fy.chalmers.se/~appro/linux/DVD+RW/tools/dvd+rw-tools-"
290 version ".tar.gz"))
291 (sha256
292 (base32
293 "1jkjvvnjcyxpql97xjjx0kwvy70kxpiznr2zpjy2hhci5s10zmpq"))
294 (patches (search-patches "dvd+rw-tools-add-include.patch"))))
295 (build-system gnu-build-system)
296 (inputs
297 `(("cdrtools" ,cdrtools)))
298 (native-inputs
299 `(("m4" ,m4)))
300 (arguments
301 `(#:tests? #f ; No tests.
302 #:phases
303 (modify-phases %standard-phases
304 (add-after 'unpack 'fix-glibc-compatability
305 (lambda* (#:key inputs #:allow-other-keys)
306 ;; We use sed --in-place because substitute* cannot handle the
307 ;; character encoding used by growisofs.c.
308 (invoke "sed" "-i" "-e"
309 (string-append
310 "s,<sys/stat.h>,"
311 "<sys/stat.h>\\\n#include <sys/sysmacros.h>,")
312 "growisofs.c")))
313 (replace 'configure
314 (lambda _ (setenv "prefix" (assoc-ref %outputs "out")) #t))
315 (add-before 'build 'embed-mkisofs
316 (lambda* (#:key inputs #:allow-other-keys)
317 ;; We use sed --in-place because substitute* cannot handle the
318 ;; character encoding used by growisofs.c.
319 (invoke "sed" "-i" "-e"
320 (string-append
321 "s,\"mkisofs\","
322 "\"" (which "mkisofs") "\",")
323 "growisofs.c"))))))
324 (home-page "http://fy.chalmers.se/~appro/linux/DVD+RW/")
325 (synopsis "DVD and Blu-ray Disc burning tools")
326 (description "dvd+rw-tools, mostly known for its command
327 @command{growisofs}, is a collection of DVD and Blu-ray Disc burning tools.
328 It requires another program, such as @command{mkisofs}, @command{genisoimage},
329 or @command{xorrisofs} to create ISO 9660 images.")
330 (license gpl2)))
331
332 (define-public dvdisaster
333 (package
334 (name "dvdisaster")
335 (version "0.79.5")
336 (source (origin
337 (method url-fetch)
338 (uri (string-append "http://dvdisaster.net/downloads/dvdisaster-"
339 version ".tar.bz2"))
340 (sha256
341 (base32
342 "0f8gjnia2fxcbmhl8b3qkr5b7idl8m855dw7xw2fnmbqwvcm6k4w"))))
343 (build-system gnu-build-system)
344 (inputs
345 `(("gtk+" ,gtk+-2)))
346 (native-inputs
347 `(("gettext" ,gettext-minimal)
348 ("pkg-config" ,pkg-config)
349 ("which" ,which)))
350 (arguments
351 `(;; Parallel builds appear to be unsafe, see
352 ;; <http://hydra.gnu.org/build/49331/nixlog/1/raw>.
353 #:parallel-build? #f
354 #:phases
355 (modify-phases %standard-phases
356 (replace 'check
357 (lambda _
358 (with-directory-excursion "regtest"
359 (substitute* "common.bash"
360 (("ISODIR=/var/tmp/regtest") "ISODIR=/tmp"))
361 (for-each invoke (find-files "." "rs.*\\.bash")))
362 #t))
363 (add-after 'install 'install-desktop
364 (lambda* (#:key outputs #:allow-other-keys)
365 (let* ((datadir (string-append (assoc-ref outputs "out") "/share")))
366 (substitute* "contrib/dvdisaster.desktop"
367 (("dvdisaster48.png") "dvdisaster.png"))
368 (install-file "contrib/dvdisaster.desktop"
369 (string-append datadir "/applications"))
370 (for-each
371 (lambda (png)
372 (let* ((size (substring png
373 (string-index png char-set:digit)
374 (string-rindex png #\.)))
375 (icondir (string-append datadir "/icons/"
376 size "x" size "/apps")))
377 (mkdir-p icondir)
378 (copy-file png (string-append icondir "/dvdisaster.png"))))
379 (find-files "contrib" "dvdisaster[0-9]*\\.png"))
380 (mkdir-p (string-append datadir "/pixmaps"))
381 (copy-file "contrib/dvdisaster48.xpm"
382 (string-append datadir "/pixmaps/dvdisaster.xpm"))
383 #t))))))
384 (home-page "http://dvdisaster.net/en/index.html")
385 (synopsis "Error correcting codes for optical media images")
386 (description "Optical media (CD,DVD,BD) keep their data only for a
387 finite time (typically for many years). After that time, data loss develops
388 slowly with read errors growing from the outer media region towards the
389 inside.
390
391 Dvdisaster stores data on CD/DVD/BD (supported media) in a way that it is
392 fully recoverable even after some read errors have developed. This enables
393 you to rescue the complete data to a new medium.
394
395 Data loss is prevented by using error correcting codes. Error correction
396 data is either added to the medium or kept in separate error correction
397 files. Dvdisaster works at the image level so that the recovery does not
398 depend on the file system of the medium. The maximum error correction
399 capacity is user-selectable.")
400 (license gpl2+)))
401
402 (define-public dvdstyler
403 (package
404 (name "dvdstyler")
405 (version "3.0.4")
406 (source
407 (origin
408 (method url-fetch)
409 (uri (string-append "mirror://sourceforge/dvdstyler/dvdstyler/"
410 version "/DVDStyler-" version ".tar.bz2"))
411 (sha256
412 (base32
413 "0lwc0hn94m9r8fi07sjqz3fr618l6lnw3zsakxw7nlgnxbjsk7pi"))))
414 (build-system gnu-build-system)
415 (arguments
416 `(#:configure-flags
417 (list (string-append "XMLTO="
418 (assoc-ref %build-inputs "xmlto")
419 "/bin/xmlto --searchpath "
420 (assoc-ref %build-inputs "docbook-xsl")
421 "/xml/xsl/docbook-xsl-" ,(package-version docbook-xsl)
422 "/htmlhelp:"
423 (assoc-ref %build-inputs "docbook-xml")
424 "/xml/dtd/docbook"))
425 #:phases
426 (modify-phases %standard-phases
427 (add-after 'install 'wrap-program
428 (lambda* (#:key inputs outputs #:allow-other-keys)
429 (wrap-program (string-append (assoc-ref outputs "out") "/bin/dvdstyler")
430 `("PATH" ":" prefix
431 (,(string-join
432 (map (lambda (in) (string-append (assoc-ref inputs in) "/bin"))
433 '("cdrtools" "dvdauthor" "dvd+rw-tools" "ffmpeg"))
434 ":"))))
435 #t)))
436 #:tests? #f)) ; No tests.
437 (inputs ; TODO package bundled wxvillalib
438 `(("wxwidgets" ,wxwidgets-3.1)
439 ("wssvg" ,wxsvg)
440 ("dbus" ,dbus)
441 ("cdrtools" ,cdrtools)
442 ("dvd+rw-tools" ,dvd+rw-tools)
443 ("dvdauthor" ,dvdauthor)
444 ("eudev" ,eudev)
445 ("fontconfig" ,fontconfig)
446 ("libexif" ,libexif)
447 ("libjpeg" ,libjpeg)
448 ("ffmpeg" ,ffmpeg-3.4)))
449 (native-inputs
450 `(("pkg-config" ,pkg-config)
451 ("flex" ,flex)
452 ("python" ,python-2)
453 ("xmlto" ,xmlto)
454 ("gettext" ,gnu-gettext)
455 ("docbook-xml" ,docbook-xml)
456 ("docbook-xsl" ,docbook-xsl)
457 ("zip" ,zip)))
458 (synopsis "DVD authoring application")
459 (description "DVDStyler is a DVD authoring application which allows users
460 to burn video files in many formats to DVD discs, complete with individually
461 designed menus. It can be used to create professional-looking DVD's with
462 custom buttons, backgrounds and animations, from within a user-friendly
463 graphical interface.")
464 (home-page "https://www.dvdstyler.org")
465 (license gpl2)))
466
467 (define-public libcue
468 (package
469 (name "libcue")
470 (version "2.2.1")
471 (source (origin
472 (method git-fetch)
473 (uri (git-reference
474 (url "https://github.com/lipnitsk/libcue.git")
475 (commit (string-append "v" version))))
476 (file-name (git-file-name name version))
477 (sha256
478 (base32
479 "1iqw4n01rv2jyk9lksagyxj8ml0kcfwk67n79zy1r6zv1xfp5ywm"))))
480 (build-system cmake-build-system)
481 (arguments
482 `(#:configure-flags '("-DBUILD_SHARED_LIBS=ON")))
483 (native-inputs
484 `(("bison" ,bison)
485 ("flex" ,flex)))
486 (home-page "https://github.com/lipnitsk/libcue")
487 (synopsis "C library to parse cue sheets")
488 (description "Libcue is a C library to parse so-called @dfn{cue sheets}
489 which contain meta-data for CD/DVD tracks. It provides an API to manipulate
490 the data.")
491 (license gpl2+)))
492
493 (define-public cd-discid
494 (package
495 (name "cd-discid")
496 (version "1.4")
497 (home-page "http://linukz.org/cd-discid.shtml")
498 (source (origin
499 (method url-fetch)
500 (uri (string-append "http://linukz.org/download/cd-discid-"
501 version ".tar.gz"))
502 (sha256
503 (base32
504 "0qrcvn7227qaayjcd5rm7z0k5q89qfy5qkdgwr5pd7ih0va8rmpz"))
505 (modules '((guix build utils)))
506 (snippet
507 '(begin
508 (substitute* "Makefile"
509 (("/usr/bin/install")
510 "install"))
511 #t))))
512 (build-system gnu-build-system)
513 (arguments
514 '(#:tests? #f
515 #:phases (modify-phases %standard-phases (delete 'configure))
516 #:make-flags (list "CC=gcc"
517 (string-append "PREFIX="
518 (assoc-ref %outputs "out")))))
519 (synopsis "Get CDDB discid information from an audio CD")
520 (description
521 "cd-discid is a command-line tool to retrieve CDDB discid information
522 from an audio CD.")
523 (license gpl2+)))
524
525 (define-public abcde
526 (package
527 (name "abcde")
528 (version "2.9.2")
529 (home-page "https://abcde.einval.com/")
530 (source (origin
531 (method url-fetch)
532 (uri (string-append home-page "/download/abcde-"
533 version ".tar.gz"))
534 (sha256
535 (base32
536 "13c5yvp87ckqgha160ym5rdr1a4divgvyqbjh0yb6ffclip6qd9l"))
537 (modules '((guix build utils)))
538 (snippet
539 `(begin
540 (substitute* "Makefile"
541 ;; Fix abcde 2.9.2 still thinking it's 2.9.1.
542 ;; XXX This will be fixed in the next release.
543 (("(abcde_version = abcde-)(2.9.1)" _ good bad)
544 (string-append good ,version))
545 (("/usr/bin/install")
546 "install")
547 (("^etcdir = .*$")
548 (string-append "etcdir = $(prefix)/etc\n")))
549 #t))))
550 (build-system gnu-build-system)
551 (arguments
552 '(#:phases
553 (modify-phases %standard-phases
554 (replace 'configure
555 (lambda* (#:key outputs inputs #:allow-other-keys)
556 (substitute* "Makefile"
557 (("^prefix = .*$")
558 (string-append "prefix = "
559 (assoc-ref outputs "out")
560 "\n"))
561 (("^sysconfdir = .*$")
562 (string-append "sysconfdir = "
563 (assoc-ref outputs "out")
564 "/etc/\n")))
565 #t))
566 (add-after 'install 'wrap
567 (lambda* (#:key inputs outputs #:allow-other-keys)
568 (let ((wget (assoc-ref inputs "wget"))
569 (vorbis (assoc-ref inputs "vorbis-tools"))
570 (parano (assoc-ref inputs "cdparanoia"))
571 (which (assoc-ref inputs "which"))
572 (discid (assoc-ref inputs "cd-discid"))
573 (perl-discid (assoc-ref inputs "perl-musicbrainz-discid"))
574 (perl-ws (assoc-ref inputs "perl-webservice-musicbrainz"))
575 (perl-mojo (assoc-ref inputs "perl-mojolicious"))
576 (flac (assoc-ref inputs "flac"))
577 (out (assoc-ref outputs "out")))
578 (define (wrap file)
579 (wrap-program file
580 `("PATH" ":" prefix
581 (,(string-append out "/bin:"
582 wget "/bin:"
583 flac "/bin:"
584 which "/bin:"
585 vorbis "/bin:"
586 discid "/bin:"
587 parano "/bin")))
588 `("PERL5LIB" ":" prefix
589 (,(string-append perl-discid
590 "/lib/perl5/site_perl:"
591 perl-ws
592 "/lib/perl5/site_perl:"
593 perl-mojo
594 "/lib/perl5/site_perl")))))
595
596 (for-each wrap
597 (find-files (string-append out "/bin")
598 ".*")))
599 #t)))
600 #:tests? #f)) ; no test target
601
602 (inputs `(("wget" ,wget)
603 ("which" ,which)
604 ("cdparanoia" ,cdparanoia)
605 ("cd-discid" ,cd-discid)
606 ("vorbis-tools" ,vorbis-tools)
607 ("flac" ,flac)
608
609 ("perl-musicbrainz-discid" ,perl-musicbrainz-discid)
610 ("perl-webservice-musicbrainz" ,perl-webservice-musicbrainz)
611 ("perl-mojolicious" ,perl-mojolicious) ;indirect dependency
612
613 ;; A couple of Python and Perl scripts are included.
614 ("python" ,python)
615 ("perl" ,perl)))
616
617 (synopsis "Command-line audio CD ripper")
618 (description
619 "abcde is a front-end command-line utility (actually, a shell script)
620 that grabs tracks off a CD, encodes them to Ogg/Vorbis, MP3, FLAC, Ogg/Speex
621 and/or MPP/MP+ (Musepack) format, and tags them, all in one go.")
622 (license gpl2+)))
623
624 (define-public geteltorito
625 (package
626 (name "geteltorito")
627 (version "0.6")
628 (home-page
629 "https://userpages.uni-koblenz.de/~krienke/ftp/noarch/geteltorito/")
630 (source (origin
631 (method url-fetch)
632 (uri (string-append home-page name "-" version ".tar.gz"))
633 (sha256
634 (base32
635 "1gkbm9ahj2mgqrkrfpibzclsriqgsbsvjh19fr815vpd9f6snkxv"))))
636 (build-system gnu-build-system)
637 (arguments
638 `(#:tests? #f ; No tests.
639 #:phases
640 (modify-phases %standard-phases
641 (delete 'configure)
642 (delete 'build)
643 (replace 'install
644 (lambda* (#:key outputs #:allow-other-keys)
645 (let ((out (assoc-ref outputs "out")))
646 (install-file "geteltorito"
647 (string-append out "/bin"))))))))
648 (inputs `(("perl" ,perl)))
649 (synopsis "Extract the boot image from a CD-ROM")
650 (description
651 "@command{geteltorito} can extract the initial/default boot
652 image from CDs (and ISOs) that follow the El Torito specification
653 for bootable CD-ROMs.
654
655 Image data is written to standard output by default and all other
656 information is written to standard error.")
657 (license gpl2+)))
658
659 (define-public asunder
660 (package
661 (name "asunder")
662 (version "2.8")
663 (source (origin
664 (method url-fetch)
665 (uri
666 (string-append "http://www.littlesvr.ca/asunder/releases/asunder-"
667 version
668 ".tar.bz2"))
669 (sha256
670 (base32
671 "1nq9kd4rd4k2kibf57gdbm0zw2gxa234vvvdhxkm8g5bhx5h3iyq"))))
672 (build-system glib-or-gtk-build-system)
673 (arguments
674 '(#:out-of-source? #f
675 #:phases (modify-phases %standard-phases
676 (add-after 'install 'wrap
677 (lambda* (#:key inputs outputs #:allow-other-keys)
678 (let ((program (string-append (assoc-ref outputs "out")
679 "/bin/asunder")))
680 (define (bin-directory input-name)
681 (string-append (assoc-ref inputs input-name) "/bin"))
682 (wrap-program program
683 `("PATH" ":" prefix
684 ,(map bin-directory (list "cdparanoia"
685 "lame"
686 "vorbis-tools"
687 "flac"
688 "opus-tools"
689 "wavpack"))))))))))
690 (native-inputs `(("intltool" ,intltool)
691 ("pkg-config" ,pkg-config)))
692 ;; TODO: Add the necessary packages for Musepack encoding.
693 (inputs `(("gtk+-2" ,gtk+-2)
694 ("glib" ,glib)
695 ("libcddb" ,libcddb)
696 ("cdparanoia" ,cdparanoia)
697 ("lame" ,lame)
698 ("vorbis-tools" ,vorbis-tools)
699 ("flac" ,flac)
700 ("opus-tools" ,opus-tools)
701 ("wavpack" ,wavpack)))
702 (home-page "http://www.littlesvr.ca/asunder/")
703 (synopsis "Graphical audio CD ripper and encoder")
704 (description
705 "Asunder is a graphical audio CD ripper and encoder. It can save audio
706 tracks as WAV, MP3, Ogg Vorbis, FLAC, Opus, Wavpack, and Musepack. It can use
707 CDDB to name and tag each track automatically, and it allows for each track to
708 be by a different artist. Asunder can encode to multiple formats in one
709 session, and it can create M3U playlists.")
710 (license gpl2)))
711
712 (define-public ripit
713 (package
714 (name "ripit")
715 (version "3.9.0")
716 (source (origin
717 (method url-fetch)
718 (uri (string-append "http://www.suwald.com/ripit/ripit-"
719 version ".tar.gz"))
720 (sha256
721 (base32
722 "0ap71x477jy9c4jiqazb3y45hxdxm3jbq24x05g3vjyqzigi4x1b"))))
723 (build-system gnu-build-system)
724 (arguments
725 `(#:tests? #f ; No test suite.
726 #:phases
727 (modify-phases %standard-phases
728 (delete 'configure)
729 (add-after 'unpack 'patch-usr-bin-install
730 (lambda* (#:key inputs outputs #:allow-other-keys)
731 (substitute* "Makefile"
732 (("/usr/bin/install") (string-append
733 (assoc-ref inputs "coreutils")
734 "/bin/install"))
735 (("\\$\\(DESTDIR\\)/usr/local") (assoc-ref outputs "out"))
736 (("../../etc") "etc")))))))
737 (native-inputs
738 `(("coreutils" ,coreutils)))
739 (inputs
740 `(("perl" ,perl)))
741 (propagated-inputs
742 `(("cdparanoia" ,cdparanoia)
743 ("flac" ,flac)
744 ("vorbis-tools" ,vorbis-tools)
745 ("wavpack" ,wavpack)
746 ("perl-cddb-get" ,perl-cddb-get)))
747 (home-page "http://www.suwald.com/ripit/about.php")
748 (synopsis "Command-line program to extract audio CDs")
749 (description "RipIT is used to extract audio from CDs.")
750 (license gpl2)))
751
752 (define-public ccd2cue
753 (package
754 (name "ccd2cue")
755 (version "0.5")
756 (source
757 (origin
758 (method url-fetch)
759 (uri (string-append
760 "mirror://gnu/ccd2cue/ccd2cue-" version
761 ".tar.gz"))
762 (sha256
763 (base32
764 "1icrkg25hwx4gsn3dski2172ia4ywjh8m1sa17zmjclnrgdwy9c7"))))
765 (build-system gnu-build-system)
766 (synopsis "CCD to CUE sheet conversion")
767 (description
768 "GNU ccd2cue is a preprocessor for CD burning software that allows
769 the conversion of the proprietary CCD format to the CUE format, which
770 is well-supported by free software. These files are commonly
771 distributed with CD images and are used to describe how tracks are
772 laid out on the image.")
773 (home-page "https://www.gnu.org/software/ccd2cue/")
774 (license gpl3+)))
775
776 (define-public libburn
777 (package
778 (name "libburn")
779 (version "1.5.0")
780 (source (origin
781 (method url-fetch)
782 (uri (string-append "http://files.libburnia-project.org/releases/"
783 "libburn-" version ".tar.gz"))
784 (sha256
785 (base32
786 "1gg2kgnqvaa2fwghai62prxz6slpak1f6bvgjh8m4dn16v114asq"))))
787 (build-system gnu-build-system)
788 (native-inputs
789 `(("pkg-config" ,pkg-config)))
790 (home-page "https://dev.lovelyhq.com/libburnia/libburn")
791 (synopsis "Library for reading and writing optical discs")
792 (description
793 "Libburn is a library for reading and writing optical discs.
794 Supported media are: CD-R, CD-RW, DVD-RAM, DVD+RW, DVD+R, DVD+R/DL,
795 DVD-RW, DVD-R, DVD-R/DL, BD-R, and BD-RE.")
796 (license gpl2)))
797
798 (define-public libisofs
799 (package
800 (name "libisofs")
801 (version "1.5.0")
802 (source (origin
803 (method url-fetch)
804 (uri (string-append "http://files.libburnia-project.org/releases/"
805 "libisofs-" version ".tar.gz"))
806 (sha256
807 (base32
808 "001l3akf3wb6msl9man776w560iqyvsbwwzs7d7y7msx13irspys"))))
809 (build-system gnu-build-system)
810 (inputs
811 `(("zlib" ,zlib)
812 ("acl" ,acl)))
813 (native-inputs
814 `(("pkg-config" ,pkg-config)))
815 (home-page "https://dev.lovelyhq.com/libburnia/libisofs")
816 (synopsis "Library to create ISO 9660 images")
817 (description
818 "Libisofs creates ISO 9660 (also known as ECMA-119) file system images
819 which can either be written to POSIX file objects or handed over to
820 libburn for being written directly to optical media.
821 It can read metadata of ISO 9660 filesystems, manipulate them, and use them
822 to produce new complete file system images or add-on images to be appended
823 to the read file system image.
824 Supported extensions to ISO 9660 are Rock Ridge, Joliet, AAIP, zisofs.")
825 (license gpl2+)))
826
827 (define-public cdrkit-libre
828 (package
829 (name "cdrkit-libre")
830 (version "1.1.11")
831 (source (origin
832 (method url-fetch)
833 ;; cdrkit.org is dead.
834 ;;
835 ;; ‘cdrkit-libre’ removes a couple of problematic files,
836 ;; see <https://debbugs.gnu.org/cgi/bugreport.cgi?bug=32165#14>.
837 (uri (string-append
838 "https://repo.parabola.nu/other/cdrkit-libre/cdrkit-libre-"
839 version ".tar.gz"))
840 (sha256
841 (base32
842 "0g2zyzb56czh429qy87lvaddzjnlcq8c616ddxsmsshz3clhyzrh"))))
843 (build-system cmake-build-system)
844 (inputs
845 `(("bzip2" ,bzip2)
846 ("libcap" ,libcap)
847 ("perl" ,perl)
848 ("zlib" ,zlib)))
849 (arguments
850 `(#:tests? #f ;no tests
851 #:phases
852 (modify-phases %standard-phases
853 (add-after 'install 'old-cdrecord
854 (lambda* (#:key outputs #:allow-other-keys)
855 (with-directory-excursion (string-append (assoc-ref outputs "out")
856 "/bin")
857 (symlink "genisoimage" "mkisofs")
858 (symlink "wodim" "cdrecord"))
859 #t)))))
860 (home-page "https://repo.parabola.nu/other/cdrkit-libre/")
861 (synopsis "Command-line CD/DVD recorder")
862 (description "Cdrkit is a suite of programs for recording CDs and DVDs,
863 blanking CD-RW media, creating ISO-9660 file system images, extracting audio
864 CD data, and more. It's mostly compatible with @code{cdrtools}.")
865 (license gpl2+)))