gnu: musl: Fix CVE-2016-8859.
[jackhill/guix/guix.git] / gnu / packages / musl.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2016 Vincent Legoll <vincent.legoll@gmail.com>
3 ;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages musl)
21 #:use-module (guix download)
22 #:use-module (guix packages)
23 #:use-module (guix build-system gnu)
24 #:use-module ((guix licenses) #:prefix license:)
25 #:use-module (gnu packages))
26
27 (define-public musl
28 (package
29 (name "musl")
30 (version "1.1.15")
31 (source (origin
32 (method url-fetch)
33 (uri (string-append "http://www.musl-libc.org/releases/"
34 name "-" version ".tar.gz"))
35 (patches (search-patches "musl-CVE-2016-8859.patch"))
36 (sha256
37 (base32
38 "1ymhxkskivzph0q34zadwfglc5gyahqajm7chqqn2zraxv3lgr4p"))))
39 (build-system gnu-build-system)
40 (arguments
41 `(#:tests? #f ; Musl has no tests
42 #:configure-flags
43 (list "--disable-gcc-wrapper")))
44 (synopsis "Small C standard library")
45 (description "musl is a simple and lightweight C standard library. It
46 strives to be correct in the sense of standards-conformance and safety.")
47 (home-page "http://www.musl-libc.org")
48 ;; Musl as a whole is released under the Expat license. Parts of it are
49 ;; derived from various third-party projects that are released under
50 ;; non-copyleft licenses. See the COPYRIGHT file for details.
51 (license license:expat)))