Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / patches / tcsh-do-not-define-BSDWAIT.patch
1 Do not define BSDWAIT to avoid error "storage size of ‘w’ isn’t known".
2
3 This is an adapted version of the upstream patch taken from here:
4 https://github.com/tcsh-org/tcsh/commit/4689eb60a74bf13bc146ca3d76e9d7a124ab7b49.patch
5
6 From 4689eb60a74bf13bc146ca3d76e9d7a124ab7b49 Mon Sep 17 00:00:00 2001
7 From: christos <christos>
8 Date: Fri, 23 Sep 2016 19:17:28 +0000
9 Subject: [PATCH] Don't define BSDWAIT for linux anymore.
10
11 ---
12 sh.proc.c | 8 +++-----
13 1 file changed, 3 insertions(+), 5 deletions(-)
14
15 diff --git a/sh.proc.c b/sh.proc.c
16 index 49b199f..874d67c 100644
17 --- sh.proc.c
18 +++ sh.proc.c
19 @@ -47,11 +47,9 @@ RCSID("$tcsh$")
20 # define HZ 16
21 #endif /* aiws */
22
23 -#if defined(_BSD) || (defined(IRIS4D) && __STDC__) || defined(__lucid) || defined(__linux__) || defined(__GNU__) || defined(__GLIBC__)
24 -# if !defined(__ANDROID__)
25 -# define BSDWAIT
26 -# endif
27 -#endif /* _BSD || (IRIS4D && __STDC__) || __lucid || glibc */
28 +#if defined(_BSD) || (defined(IRIS4D) && __STDC__) || defined(__lucid)
29 +# define BSDWAIT
30 +#endif /* _BSD || (IRIS4D && __STDC__) || __lucid */
31 #ifndef WTERMSIG
32 # define WTERMSIG(w) (((union wait *) &(w))->w_termsig)
33 # ifndef BSDWAIT