Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / patches / gcc-arm-bug-71399.patch
1 Revert the following commit to work around a bootstrap comparison failure on
2 ARMv7, as reported at <https://gcc.gnu.org/bugzilla/show_bug.cgi?id=71399>.
3
4 commit f6ab85b7049a03962ea98924d00802da357a1ad3
5 Author: renlin <renlin@138bc75d-0d04-0410-961f-82ee72b054a4>
6 Date: Wed Dec 2 14:06:31 2015 +0000
7
8 [PR67383][ARM][4.9]Backport of "Allow any register for DImode values in Thumb2"
9
10 This partially fix PR67383. It allows the reload more flexibility to choose
11 spilling pseudo registers.
12
13
14 gcc/ChangeLog:
15
16 2015-12-02 Renlin Li <renlin.li@arm.com>
17
18 Backport from mainline.
19 2014-04-22 Ramana Radhakrishnan <ramana.radhakrishnan@arm.com>
20
21 * config/arm/arm.c (arm_hard_regno_mode_ok): Loosen
22 restrictions on core registers for DImode values in Thumb2.
23
24
25 git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/branches/gcc-4_9-branch@231177 138bc75d-0d04-0410-961f-82ee72b054a4
26
27 diff --git a/gcc/config/arm/arm.c b/gcc/config/arm/arm.c
28 index 8ba6060..d9028a1 100644
29 --- b/gcc/config/arm/arm.c
30 +++ a/gcc/config/arm/arm.c
31 @@ -22624,19 +22624,12 @@
32 }
33
34 /* We allow almost any value to be stored in the general registers.
35 - Restrict doubleword quantities to even register pairs in ARM state
36 - so that we can use ldrd. Do not allow very large Neon structure
37 - opaque modes in general registers; they would use too many. */
38 + Restrict doubleword quantities to even register pairs so that we can
39 + use ldrd. Do not allow very large Neon structure opaque modes in
40 + general registers; they would use too many. */
41 if (regno <= LAST_ARM_REGNUM)
42 - {
43 - if (ARM_NUM_REGS (mode) > 4)
44 - return FALSE;
45 -
46 - if (TARGET_THUMB2)
47 - return TRUE;
48 -
49 - return !(TARGET_LDRD && GET_MODE_SIZE (mode) > 4 && (regno & 1) != 0);
50 - }
51 + return !(TARGET_LDRD && GET_MODE_SIZE (mode) > 4 && (regno & 1) != 0)
52 + && ARM_NUM_REGS (mode) <= 4;
53
54 if (regno == FRAME_POINTER_REGNUM
55 || regno == ARG_POINTER_REGNUM)