Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / ghostscript.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
3 ;;; Copyright © 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
4 ;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
5 ;;; Copyright © 2013, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
6 ;;;
7 ;;; This file is part of GNU Guix.
8 ;;;
9 ;;; GNU Guix is free software; you can redistribute it and/or modify it
10 ;;; under the terms of the GNU General Public License as published by
11 ;;; the Free Software Foundation; either version 3 of the License, or (at
12 ;;; your option) any later version.
13 ;;;
14 ;;; GNU Guix is distributed in the hope that it will be useful, but
15 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
16 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
17 ;;; GNU General Public License for more details.
18 ;;;
19 ;;; You should have received a copy of the GNU General Public License
20 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
21
22 (define-module (gnu packages ghostscript)
23 #:use-module (gnu packages)
24 #:use-module (gnu packages autotools)
25 #:use-module (gnu packages compression)
26 #:use-module (gnu packages fontutils)
27 #:use-module (gnu packages image)
28 #:use-module (gnu packages perl)
29 #:use-module (gnu packages pkg-config)
30 #:use-module (gnu packages python)
31 #:use-module (gnu packages tcl)
32 #:use-module (gnu packages xorg)
33 #:use-module ((guix licenses) #:prefix license:)
34 #:use-module (guix packages)
35 #:use-module (guix download)
36 #:use-module (guix build-system gnu)
37 #:use-module (guix build-system trivial))
38
39 (define-public lcms
40 (package
41 (name "lcms")
42 (version "2.6")
43 (source (origin
44 (method url-fetch)
45 (uri (string-append "mirror://sourceforge/lcms/lcms/" version
46 "/lcms2-" version ".tar.gz"))
47 (sha256 (base32
48 "1c8lgq8gfs3nyplvbx9k8wzfj6r2bqi3f611vb1m8z3476454wji"))))
49 (build-system gnu-build-system)
50 (inputs `(("libjpeg-8" ,libjpeg-8)
51 ("libtiff" ,libtiff)
52 ("zlib" ,zlib)))
53 (synopsis "Little CMS, a small-footprint colour management engine")
54 (description
55 "Little CMS is a small-footprint colour management engine, with special
56 focus on accuracy and performance. It uses the International Color
57 Consortium standard (ICC), approved as ISO 15076-1.")
58 (license license:x11)
59 (home-page "http://www.littlecms.com/")))
60
61 (define-public libpaper
62 (package
63 (name "libpaper")
64 (version "1.1.24")
65 (source (origin
66 (method url-fetch)
67 (uri (string-append
68 ;; Debian moved their libpaper-1.1.24 to archive.debian.net
69 ;; but in the move the hash of their tarball changed.
70 "http://pkgs.fedoraproject.org/repo/pkgs/libpaper/libpaper_"
71 version ".tar.gz/5bc87d494ba470aba54f6d2d51471834/libpaper_"
72 version ".tar.gz"))
73 (sha256 (base32
74 "0zhcx67afb6b5r936w5jmaydj3ks8zh83n9rm5sv3m3k8q8jib1q"))))
75 (build-system gnu-build-system)
76 (synopsis "Library for handling paper sizes")
77 (description
78 "The paper library and accompanying files are intended to provide a simple
79 way for applications to take actions based on a system- or user-specified
80 paper size.")
81 (license license:gpl2)
82 (home-page "https://packages.qa.debian.org/libp/libpaper.html")))
83
84 (define-public psutils
85 (package
86 (name "psutils")
87 (version "17")
88 (source (origin
89 (method url-fetch)
90 (uri "ftp://ftp.knackered.org/pub/psutils/psutils.tar.gz")
91 (sha256 (base32
92 "1r4ab1fvgganm02kmm70b2r1azwzbav2am41gbigpa2bb1wynlrq"))))
93 (build-system gnu-build-system)
94 (inputs `(("perl" ,perl)))
95 (arguments
96 `(#:tests? #f ; none provided
97 #:phases
98 (alist-replace
99 'configure
100 (lambda* (#:key inputs outputs #:allow-other-keys #:rest args)
101 (let ((perl (assoc-ref inputs "perl"))
102 (out (assoc-ref outputs "out")))
103 (copy-file "Makefile.unix" "Makefile")
104 (substitute* "Makefile"
105 (("/usr/local/bin/perl") (string-append perl "/bin/perl")))
106 (substitute* "Makefile"
107 (("/usr/local") out))
108 ;; for the install phase
109 (substitute* "Makefile"
110 (("-mkdir") "mkdir -p"))
111 ;; drop installation of non-free files
112 (substitute* "Makefile"
113 ((" install.include") ""))))
114 %standard-phases)))
115 (synopsis "Collection of utilities for manipulating PostScript documents")
116 (description
117 "PSUtils is a collection of utilities for manipulating PostScript
118 documents. Programs included are psnup, for placing out several logical pages
119 on a single sheet of paper, psselect, for selecting pages from a document,
120 pstops, for general imposition, psbook, for signature generation for booklet
121 printing, and psresize, for adjusting page sizes.")
122 (license (license:non-copyleft "file://LICENSE"
123 "See LICENSE in the distribution."))
124 (home-page "http://knackered.org/angus/psutils/")))
125
126 (define-public ghostscript
127 (package
128 (name "ghostscript")
129 (version "9.14.0")
130 (source (origin
131 (method url-fetch)
132 (uri (string-append "mirror://gnu/ghostscript/gnu-ghostscript-"
133 version ".tar.xz"))
134 (sha256
135 (base32
136 "0q4jj41p0qbr4mgcc9q78f5zs8cm1g57wgryhsm2yq4lfslm3ib1"))
137 (patches (search-patches "ghostscript-CVE-2013-5653.patch"
138 "ghostscript-CVE-2015-3228.patch"
139 "ghostscript-CVE-2016-7976.patch"
140 "ghostscript-CVE-2016-7978.patch"
141 "ghostscript-CVE-2016-7979.patch"
142 "ghostscript-CVE-2016-8602.patch"
143 "ghostscript-runpath.patch"))
144 (modules '((guix build utils)))
145 (snippet
146 ;; Honor --docdir.
147 '(substitute* "Makefile.in"
148 (("^docdir=.*$") "docdir = @docdir@\n")
149 (("^exdir=.*$") "exdir = $(docdir)/examples\n")))))
150 (build-system gnu-build-system)
151 (outputs '("out" "doc")) ;16 MiB of HTML/PS doc + examples
152 (inputs `(("freetype" ,freetype)
153 ("lcms" ,lcms)
154 ("libjpeg-8" ,libjpeg-8)
155 ("libpng" ,libpng)
156 ("libpaper" ,libpaper)
157 ("libtiff" ,libtiff)
158 ("zlib" ,zlib)))
159 (native-inputs
160 `(("perl" ,perl)
161 ("pkg-config" ,pkg-config) ; needed to find libtiff
162 ("python" ,python-wrapper)
163 ("tcl" ,tcl)))
164 (arguments
165 `(#:disallowed-references ("doc")
166 #:phases
167 (modify-phases %standard-phases
168 (add-after 'configure 'patch-config-files
169 (lambda _
170 (substitute* "base/all-arch.mak"
171 (("/bin/sh") (which "bash")))
172 (substitute* "base/unixhead.mak"
173 (("/bin/sh") (which "bash")))))
174 (add-after 'configure 'remove-doc-reference
175 (lambda _
176 ;; Don't retain a reference to the 'doc' output in 'gs'.
177 ;; The only use of this definition is in the output of
178 ;; 'gs --help', so this change is fine.
179 (substitute* "base/gscdef.c"
180 (("GS_DOCDIR")
181 "\"~/.guix-profile/share/doc/ghostscript\""))))
182 (replace 'build
183 (lambda _
184 ;; Build 'libgs.so', but don't build the statically-linked 'gs'
185 ;; binary (saves 18 MiB).
186 (zero? (system* "make" "so" "-j"
187 (number->string (parallel-job-count))))))
188 (replace 'install
189 (lambda _
190 (zero? (system* "make" "soinstall"))))
191 (add-after 'install 'create-gs-symlink
192 (lambda* (#:key outputs #:allow-other-keys)
193 (let ((out (assoc-ref outputs "out")))
194 ;; some programs depend on having a 'gs' binary available
195 (symlink "gsc" (string-append out "/bin/gs"))))))))
196 (synopsis "PostScript and PDF interpreter")
197 (description
198 "Ghostscript is an interpreter for the PostScript language and the PDF
199 file format. It also includes a C library that implements the graphics
200 capabilities of the PostScript language. It supports a wide variety of
201 output file formats and printers.")
202 (license license:agpl3+)
203 (home-page "http://www.gnu.org/software/ghostscript/")))
204
205 (define-public ghostscript/x
206 (package (inherit ghostscript)
207 (name (string-append (package-name ghostscript) "-with-x"))
208 (inputs `(("libxext" ,libxext)
209 ("libxt" ,libxt)
210 ,@(package-inputs ghostscript)))))
211
212 (define-public ijs
213 (package
214 (name "ijs")
215 (version "9.14.0")
216 (source (origin
217 (method url-fetch)
218 (uri (string-append "mirror://gnu/ghostscript/gnu-ghostscript-"
219 version ".tar.xz"))
220 (sha256 (base32
221 "0q4jj41p0qbr4mgcc9q78f5zs8cm1g57wgryhsm2yq4lfslm3ib1"))))
222 (build-system gnu-build-system)
223 (native-inputs
224 `(("libtool" ,libtool)
225 ("automake" ,automake)
226 ("autoconf" ,autoconf)))
227 (arguments
228 `(#:phases
229 (alist-cons-after
230 'unpack 'autogen
231 (lambda _
232 ;; need to regenerate macros
233 (system* "autoreconf" "-if")
234 ;; do not run configure
235 (substitute* "autogen.sh"
236 (("^.*\\$srcdir/configure.*") ""))
237 (system* "bash" "autogen.sh")
238
239 ;; create configure script in ./ijs/
240 (chdir "ijs")
241 ;; do not run configure
242 (substitute* "autogen.sh"
243 (("^.*\\$srcdir/configure.*") "")
244 (("^ + && echo Now type.*$") ""))
245 (zero? (system* "bash" "autogen.sh")))
246 %standard-phases)))
247 (synopsis "IJS driver framework for inkjet and other raster devices")
248 (description
249 "IJS is a protocol for transmission of raster page images. This package
250 provides the reference implementation of the raster printer driver
251 architecture.")
252 (license license:expat)
253 (home-page "http://www.gnu.org/software/ghostscript/")))
254
255 (define-public gs-fonts
256 (package
257 (name "gs-fonts")
258 (version "8.11")
259 (source (origin
260 (method url-fetch)
261 (uri (string-append "mirror://sourceforge/gs-fonts/gs-fonts/"
262 version
263 "%20%28base%2035%2C%20GPL%29/ghostscript-fonts-std-"
264 version
265 ".tar.gz"))
266 (sha256 (base32
267 "00f4l10xd826kak51wsmaz69szzm2wp8a41jasr4jblz25bg7dhf"))))
268 (build-system gnu-build-system)
269 (arguments
270 `(#:tests? #f ; nothing to check, just files to copy
271 #:modules ((guix build gnu-build-system)
272 (guix build utils)
273 (srfi srfi-1)) ; for alist-delete
274 #:phases
275 (alist-delete
276 'configure
277 (alist-delete
278 'build
279 (alist-replace
280 'install
281 (lambda* (#:key outputs #:allow-other-keys)
282 (let* ((out (assoc-ref outputs "out"))
283 (dir (string-append out "/share/fonts/type1/ghostscript")))
284 (mkdir-p dir)
285 (for-each
286 (lambda (file)
287 (copy-file file (string-append dir "/" file)))
288 (find-files "." "pfb|afm"))))
289 %standard-phases)))))
290 (synopsis "Free replacements for the PostScript fonts")
291 (description
292 "Ghostscript fonts provides fonts and font metrics customarily distributed with
293 Ghostscript. It currently includes the 35 standard PostScript fonts.")
294 (license license:gpl2)
295 (home-page "http://sourceforge.net/projects/gs-fonts/")))
296
297 (define-public libspectre
298 (package
299 (name "libspectre")
300 (version "0.2.7")
301 (source (origin
302 (method url-fetch)
303 (uri (string-append "https://libspectre.freedesktop.org/releases/libspectre-"
304 version ".tar.gz"))
305 (sha256 (base32
306 "1v63lqc6bhhxwkpa43qmz8phqs8ci4dhzizyy16d3vkb20m846z8"))))
307 (build-system gnu-build-system)
308 (inputs `(("ghostscript" ,ghostscript)))
309 (native-inputs `(("pkg-config" ,pkg-config)))
310 (synopsis "Postscript rendering library")
311 (description
312 "libspectre is a small library for rendering Postscript documents.
313 It provides a convenient easy to use API for handling and rendering
314 Postscript documents.")
315 (license license:gpl2+)
316 (home-page "http://www.freedesktop.org/wiki/Software/libspectre")))