Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / file.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
3 ;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
4 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages file)
22 #:use-module (gnu packages)
23 #:use-module (guix licenses)
24 #:use-module (guix packages)
25 #:use-module (guix download)
26 #:use-module (guix build-system gnu))
27
28 (define-public file
29 (package
30 (name "file")
31 (version "5.28")
32 (source (origin
33 (method url-fetch)
34 (uri (string-append "ftp://ftp.astron.com/pub/file/file-"
35 version ".tar.gz"))
36 (sha256
37 (base32
38 "04p0w9ggqq6cqvwhyni0flji1z0rwrz896hmhkxd2mc6dca5xjqf"))))
39 (build-system gnu-build-system)
40
41 ;; When cross-compiling, this package depends upon a native install of
42 ;; itself.
43 (self-native-input? #t)
44
45 (synopsis "File type guesser")
46 (description
47 "The file command is a file type guesser, a command-line tool that tells
48 you in words what kind of data a file contains. It does not rely on filename
49 extensions to tell you the type of a file, but looks at the actual contents
50 of the file.")
51 (license bsd-2)
52 (home-page "http://www.darwinsys.com/file/")))
53